Professional Web Applications Themes

help bring 3D modeling to Mac: deployment linking error: undefined symbols expected in libSystem - Mac Programming

Hi all, I'm having a problem here with a 3D modeling program I'm building - I have a project that builds and links and runs fine in Development build mode (w/ ZeroLink), but when I switch it to Deployment build I get a linker error: Undefined symbols: ___setonlyClocaleconv referenced from CoreFoundation expected to be defined in libSystem So apparently it can't find this function call in libSystem which it thinks should be there, but I can't find reference to setonlyClocaleconv anywhere on the web. I'm fairly sure I've got all the right frameworks included - definitely libSystem, where it thinks ...

  1. #1

    Default help bring 3D modeling to Mac: deployment linking error: undefined symbols expected in libSystem

    Hi all,
    I'm having a problem here with a 3D modeling program I'm building -
    I have a project that builds and links and runs fine in Development
    build mode (w/ ZeroLink), but when I switch it to Deployment build I
    get a linker error:

    Undefined symbols: ___setonlyClocaleconv referenced from
    CoreFoundation expected to be defined in libSystem

    So apparently it can't find this function call in libSystem which
    it thinks should be there, but I can't find reference to
    setonlyClocaleconv anywhere on the web. I'm fairly sure I've got all
    the right frameworks included - definitely libSystem, where it thinks
    this thing should be. Why can it find it with ZeroLink but not when
    building for deployment? Ideas? I'm new to Mac development, so go
    easy on me if it's obvious to you somehow what I need to do. Please
    help!!!

    Sincerely,
    Tom
    Jamchild Guest

  2. #2

    Default Re: help bring 3D modeling to Mac: deployment linking error: undefined symbols expected in libSystem

    Jamchild wrote: 

    zerolink isn't "linking" at all, so it's not surprising that you don't
    see the problem there. i don't recognize the symbol name, but it
    probably has something to do with c/c++ locales. perhaps you could fix
    it by adding /usr/lib/libstdc++.a to your project, but i don't think
    i've had to explicitly include that library since the project builder
    days. can't hurt to try, though.
    Jhnny Guest

  3. #3

    Default Re: help bring 3D modeling to Mac: deployment linking error: undefined symbols expected in libSystem

    Jhnny Fvrt (it means "halo, then resonate") <com> wrote in message news:<nashville.comcast.net>... 
    >
    > zerolink isn't "linking" at all, so it's not surprising that you don't
    > see the problem there. i don't recognize the symbol name, but it
    > probably has something to do with c/c++ locales. perhaps you could fix
    > it by adding /usr/lib/libstdc++.a to your project, but i don't think
    > i've had to explicitly include that library since the project builder
    > days. can't hurt to try, though.[/ref]


    Yeah, I'd tried that (adding libstdc++.a) and it didn't work. Weird
    thing is I just tried the exact same .xcode file on a different
    machine with the exact same version of xCode and it worked without the
    error. I can't think of any differences there could be that would
    cause the one to work and the other to fail.
    Jamchild Guest

  4. #4

    Default Re: help bring 3D modeling to Mac: deployment linking error: undefined symbols expected in libSystem

    In article <google.com>,
    net (Jamchild) wrote:
     

    Do a "clean" on your project. This sounds like some cache in the "build"
    folder has become out of sync and the compiler is choking on it. A clean
    usually fixes that.

    HTH,
    -- Uli
    http://www.zathras.de
    Uli Guest

Similar Threads

  1. Undefined symbols: <nothing here>
    By sebi in forum Mac Programming
    Replies: 2
    Last Post: February 2nd, 01:03 PM
  2. Replies: 2
    Last Post: December 12th, 03:06 PM
  3. Project Builder: undefined symbols, but which?
    By Cor in forum Mac Programming
    Replies: 1
    Last Post: October 1st, 05:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139