Professional Web Applications Themes

Help: Can't access my disk on key from MDK 9.2 - Linux Setup, Configuration & Administration

Hi, I fresh installed Mandrake 9.2 on my PC. Ever since I can't access my (USB) disk on key device. I suspect the problem might be related to the fact that the disk on key is mapped to a device other than sda as I assume, yet I don't know how to find this information (advice please !). BTW, as the whole disk on key has a (FAT32) SINGLE partition, should it be sda1 or just sda? Following is the relevant fstab line which I got from a friend (different PC). I see an icon labeled removable on the desktop, ...

  1. #1

    Default Help: Can't access my disk on key from MDK 9.2

    Hi,
    I fresh installed Mandrake 9.2 on my PC.
    Ever since I can't access my (USB) disk on key device.
    I suspect the problem might be related to the fact that the
    disk on key is mapped to a device other than sda as I assume, yet I don't
    know how to find this information (advice please !). BTW, as the whole
    disk on key has a (FAT32) SINGLE partition, should it be sda1 or just sda?

    Following is the relevant fstab line which I got from a friend (different
    PC). I see an icon labeled removable on the desktop, yet, (double)
    clicking on it indicates thee are no files on the device-WHICH is
    NOT the situation.

    What's more, even as root (from terminal) Linux won't let me umount the
    /mnt/removable.

    While at it, I'd rather have the icon automatically appear on the desktop
    after I connect the device, and disappear after I remove it - any advice?

    ---------------my fstab line------------------------
    none /mnt/removable supermount dev=/dev/sda1,fs=autot,--,sync,umask=0,codepage=850,iocht=utf8 0 0
    ----------------------------------------------------

    Please advise.

    TIA

    Michael Guest

  2. #2

    Default Re: Can't access my disk on key from MDK 9.2


    "Michael Badt" <net.il> a écrit dans le message de
    news:net.il... 
    dev=/dev/sda1,fs=autot,--,sync,umask=0,codepage=850,iocht=utf8 0 0 

    Hi,

    i can only give you a few advises :

    first, you want to know where your disk onkey is...
    plug it in, and use "file" :


    [laurentjoanna laurent]$ file /dev/sda
    /dev/sda: symbolic link to scsi/host0/bus0/target0/lun0/disc


    [laurentjoanna laurent]$ file /dev/sda1
    /dev/sda1: broken symbolic link to scsi/host0/bus0/target0/lun0/part1


    you can see, the device is on sda on my machine : i
    admit that i had to fidle, fight a bit because just
    after plug in i didn't see it... i had a look in hardrake
    then i returned to console.

    once i have located my device, i mount it manually !
    i have no no /etc/fstab file for it.

    an other thing is the format choice : my key is very small
    32Mb, and i format it with

    # mkdosfs -I /dev/sda


    to get a vfat -16 partition, which give me 1Mb more space,
    and, foremost, the partion is put upon the whole key. Then the key is
    seen as a big floppy drive. other ways, without the -I option for
    example, you will get a vfat32 filesyteme, and i dont know with ext2
    and ext3 but in this cases, you may have your drive as a small
    disk, means with sda1 partition on it. However, file should
    tell you about the name.

    you can also clear the key with

    # dd if=/dev/null of=/dev/sda, or sda1.....

    laurent




    Laurent Guest

  3. #3

    Default Re: Can't access my disk on key from MDK 9.2

    Thanks Laurent!

    First, I believe mine is at sda as implied by the fillowing segment of my
    dmesg.
    as the disk contains Windows data it is FAT32 formatted and I'd rather not
    loose this data.
    Any further comment?

    TIA
    ---------segment of my dmesg--------------------


    usb.c: registered new driver usbdevfs
    usb.c: registered new driver hub
    usb-uhci.c: $Revision: 1.275 $ time 12:42:04 Sep 18 2003
    usb-uhci.c: High bandwidth mode enabled
    PCI: Found IRQ 11 for device 00:10.0
    PCI: Sharing IRQ 11 with 00:12.0
    usb-uhci.c: USB UHCI at I/O 0xd400, IRQ 11
    usb-uhci.c: Detected 2 ports
    usb.c: new USB bus registered, assigned bus number 1
    hub.c: USB hub found
    hub.c: 2 ports detected
    PCI: Found IRQ 10 for device 00:10.1
    PCI: Sharing IRQ 10 with 00:09.0
    usb-uhci.c: USB UHCI at I/O 0xd800, IRQ 10
    usb-uhci.c: Detected 2 ports
    usb.c: new USB bus registered, assigned bus number 2
    hub.c: USB hub found
    hub.c: 2 ports detected
    PCI: Found IRQ 5 for device 00:10.2
    PCI: Sharing IRQ 5 with 00:11.5
    PCI: Sharing IRQ 5 with 00:11.6
    usb-uhci.c: USB UHCI at I/O 0xdc00, IRQ 5
    usb-uhci.c: Detected 2 ports
    usb.c: new USB bus registered, assigned bus number 3
    hub.c: USB hub found
    hub.c: 2 ports detected
    usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
    PCI: Found IRQ 3 for device 00:10.3
    ehci_hcd 00:10.3: VIA Technologies, Inc. USB 2.0
    ehci_hcd 00:10.3: irq 3, pci mem deaaa000
    usb.c: new USB bus registered, assigned bus number 4
    ehci_hcd 00:10.3: USB 2.0 enabled, EHCI 1.00, driver 2003-Jun-19/2.4
    hub.c: USB hub found
    hub.c: 6 ports detected
    usbdevfs: remount parameter error

    .....

    hub.c: new USB device 00:10.0-1, assigned address 2
    usb.c: USB device 2 (vend/prod 0x5dc/0x80) is not claimed by any active driver.
    Initializing USB Mass Storage driver...
    usb.c: registered new driver usb-storage
    scsi1 : SCSI emulation for USB Mass Storage devices
    Vendor: LEXAR Model: DIGITAL FILM Rev: /W1.
    Type: Direct-Access ANSI SCSI revision: 02
    WARNING: USB Mass Storage data integrity not assured
    USB Mass Storage device found at 2
    USB Mass Storage support registered.
    Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
    SCSI device sda: 251904 512-byte hdwr sectors (129 MB)
    sda: Write Protect is off
    /dev/scsi/host1/bus0/target0/lun0: p1
    usb.c: USB disconnect on device 00:10.0-1 address 2
    -----------end od dmesg (after disconnecting a connected device------




    On Sat, 29 Nov 2003 12:20:47 +0100, Laurent Herve wrote:
     
    > dev=/dev/sda1,fs=autot,--,sync,umask=0,codepage=850,iocht=utf8 0 0 
    >
    > Hi,
    >
    > i can only give you a few advises :
    >
    > first, you want to know where your disk onkey is...
    > plug it in, and use "file" :
    >
    >
    > [laurentjoanna laurent]$ file /dev/sda
    > /dev/sda: symbolic link to scsi/host0/bus0/target0/lun0/disc
    >
    >
    > [laurentjoanna laurent]$ file /dev/sda1
    > /dev/sda1: broken symbolic link to scsi/host0/bus0/target0/lun0/part1
    >
    >
    > you can see, the device is on sda on my machine : i
    > admit that i had to fidle, fight a bit because just
    > after plug in i didn't see it... i had a look in hardrake
    > then i returned to console.
    >
    > once i have located my device, i mount it manually !
    > i have no no /etc/fstab file for it.
    >
    > an other thing is the format choice : my key is very small
    > 32Mb, and i format it with
    >
    > # mkdosfs -I /dev/sda
    >
    >
    > to get a vfat -16 partition, which give me 1Mb more space,
    > and, foremost, the partion is put upon the whole key. Then the key is
    > seen as a big floppy drive. other ways, without the -I option for
    > example, you will get a vfat32 filesyteme, and i dont know with ext2
    > and ext3 but in this cases, you may have your drive as a small
    > disk, means with sda1 partition on it. However, file should
    > tell you about the name.
    >
    > you can also clear the key with
    >
    > # dd if=/dev/null of=/dev/sda, or sda1.....
    >
    > laurent[/ref]

    Michael Guest

  4. #4

    Default Re: Can't access my disk on key from MDK 9.2

    ....Any other comment ?

    yes, first never let me know if you managed to acceding your disk, :)

    second : you can trim your dmseg with the grep command, for example

    hm, for example, say :

    $ dmesg | grep usb

    then you don't need a vaft 16 filesystem, because
    in fact you have 128 Mb key...

    so, i assume the link to your device is sda,

    as root,

    # mount /dev/sda /mnt/disk

    Should mount it, but as root : means you have only root permission.
    I think only root can mount a device manually when there is no
    line in /etc/fstab. So that's the bad point.But you should be able to see
    your device at /mnt/disk


    laurent



















    Laurent Guest

Similar Threads

  1. Disk or network error- Access DB
    By VJIN in forum Coldfusion Database Access
    Replies: 3
    Last Post: August 16th, 01:51 PM
  2. Why can't I access my floppy disk?
    By Anthony Atkielski in forum FreeBSD
    Replies: 13
    Last Post: February 28th, 07:56 PM
  3. Boot Disk - Access Denied
    By TomM in forum Windows Server
    Replies: 0
    Last Post: June 11th, 09:48 AM
  4. disk access from COM
    By Michael Sinnige in forum ASP.NET Web Services
    Replies: 0
    Last Post: November 20th, 03:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139