Professional Web Applications Themes

Help: Can't setup ADSL in MDK 9.1 - Linux Setup, Configuration & Administration

Hi, I can't setup my ADSL connection under Mandrake 9.1 although the same hardware works under WinXP (it's a dual boot PC). It's a single PC with no local net, just the Internet. I've an on-board single Ethernet card connected to an ECI ADSL modem using PPPoE.(the "modem" is called router 270PR although I'm not sure if it functions as a router without configuration. Anyway, it's working "as is" in WinXP). According to the teleco, the IP address of the ADSL modem is 192.168.1.1 (no dhcp). My ISP recommends using rp-pppoe which I have done. I've setup my connection (using ...

  1. #1

    Default Help: Can't setup ADSL in MDK 9.1

    Hi,

    I can't setup my ADSL connection under Mandrake 9.1 although the same
    hardware works under WinXP (it's a dual boot PC). It's a single PC with no
    local net, just the Internet.

    I've an on-board single Ethernet card connected to an ECI ADSL modem using
    PPPoE.(the "modem" is called router 270PR although I'm not sure if it
    functions as a router without configuration. Anyway, it's working "as is" in
    WinXP).

    According to the teleco, the IP address of the ADSL modem is 192.168.1.1 (no
    dhcp).

    My ISP recommends using rp-pppoe which I have done. I've setup my connection
    (using adsl-setup) but, when I run (as root) adsl-start I get time out.

    Actually I can't even connect to the modem neither by pinging 192.168.1.1
    nor by pointing my browser to [url]http://192.168.1.1[/url]

    During all this time I've shut down the firewall (shorewall).



    Following find copies of:

    1.. ifconfig response (note that there is NO ppp0 as I would expect).
    2.. Route (note that originally only the first 2 rows were there. I've
    added te default gw with no change in behavior.
    3.. Copy of dmesg | grep eth


    Note that both /etc/hosts.allow & /etc/hosts.deny are empty (no entries).



    Please advise as to how to set up my ADSL under MDK 9.1.



    Thanks in advance.







    ----------Output of ifconfig--------------------------



    eth0 Link encap:Ethernet HWaddr 00:0D:87:06:16:80

    inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0

    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

    RX packets:0 errors:0 dropped:0 overruns:0 frame:0

    TX packets:0 errors:1 dropped:0 overruns:0 carrier:0

    collisions:0 txqueuelen:100

    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    Interrupt:16 Base address:0xe800



    lo Link encap:Local Loopback

    inet addr:127.0.0.1 Mask:255.0.0.0

    UP LOOPBACK RUNNING MTU:16436 Metric:1

    RX packets:70 errors:0 dropped:0 overruns:0 frame:0

    TX packets:70 errors:0 dropped:0 overruns:0 carrier:0

    collisions:0 txqueuelen:0

    RX bytes:4594 (4.4 Kb) TX bytes:4594 (4.4 Kb)



    ------------------Output of route (note that I've added the last default gw
    line myself)-------



    Kernel IP routing table

    Destination Gateway Genmask Flags Metric Ref Use Iface

    192.168.1.0 * 255.255.255.0 U 0 0 0 eth0

    127.0.0.0 * 255.0.0.0 U 0 0 0 lo

    default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0



    ----------output of dmesg | grep eth-------------------------------

    eth0: VIA VT6102 Rhine-II at 0xe800, 00:0d:87:06:16:80, IRQ 16.

    eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 41e1.

    eth0: Setting full-duplex based on MII #1 link partner capability of 41e1.

    NETDEV WATCHDOG: eth0: transmit timed out

    eth0: Transmit timed out, status 0002, PHY status 786d, resetting...

    NETDEV WATCHDOG: eth0: transmit timed out

    eth0: Transmit timed out, status 0003, PHY status 786d, resetting...

    NETDEV WATCHDOG: eth0: transmit timed out

    eth0: Transmit timed out, status 0003, PHY status 786d, resetting...

    NETDEV WATCHDOG: eth0: transmit timed out

    eth0: Transmit timed out, status 0003, PHY status 786d, resetting...



    --------------------------end------------------------------------











    Michael Badt Guest

  2. #2

    Default Re: Help: Can't setup ADSL in MDK 9.1

    On Tue, 16 Sep 2003 23:19:46 +0200
    "Michael Badt" <mbadtactcom.net.il> wrote:
    > Hi,
    >
    > I can't setup my ADSL connection under Mandrake 9.1 although the same
    > hardware works under WinXP (it's a dual boot PC). It's a single PC with no
    > local net, just the Internet.
    >
    > I've an on-board single Ethernet card connected to an ECI ADSL modem using
    > PPPoE.(the "modem" is called router 270PR although I'm not sure if it
    > functions as a router without configuration. Anyway, it's working "as is" in
    > WinXP).
    >
    > According to the teleco, the IP address of the ADSL modem is 192.168.1.1 (no
    > dhcp).
    >
    > My ISP recommends using rp-pppoe which I have done. I've setup my connection
    > (using adsl-setup) but, when I run (as root) adsl-start I get time out.
    >
    > Actually I can't even connect to the modem neither by pinging 192.168.1.1
    > nor by pointing my browser to [url]http://192.168.1.1[/url]
    >
    > During all this time I've shut down the firewall (shorewall).
    >
    >
    >
    > Following find copies of:
    >
    > 1.. ifconfig response (note that there is NO ppp0 as I would expect).
    > 2.. Route (note that originally only the first 2 rows were there. I've
    > added te default gw with no change in behavior.
    > 3.. Copy of dmesg | grep eth
    >
    >
    > Note that both /etc/hosts.allow & /etc/hosts.deny are empty (no entries).
    >
    >
    >
    > Please advise as to how to set up my ADSL under MDK 9.1.
    >
    >
    >
    > Thanks in advance.
    >
    >
    >
    >
    >
    >
    >
    > ----------Output of ifconfig--------------------------
    >
    >
    >
    > eth0 Link encap:Ethernet HWaddr 00:0D:87:06:16:80
    >
    > inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0
    >
    > UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    >
    > RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    >
    > TX packets:0 errors:1 dropped:0 overruns:0 carrier:0
    >
    > collisions:0 txqueuelen:100
    >
    > RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    >
    > Interrupt:16 Base address:0xe800
    >
    >
    >
    > lo Link encap:Local Loopback
    >
    > inet addr:127.0.0.1 Mask:255.0.0.0
    >
    > UP LOOPBACK RUNNING MTU:16436 Metric:1
    >
    > RX packets:70 errors:0 dropped:0 overruns:0 frame:0
    >
    > TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
    >
    > collisions:0 txqueuelen:0
    >
    > RX bytes:4594 (4.4 Kb) TX bytes:4594 (4.4 Kb)
    >
    >
    >
    > ------------------Output of route (note that I've added the last default gw
    > line myself)-------
    >
    >
    >
    > Kernel IP routing table
    >
    > Destination Gateway Genmask Flags Metric Ref Use Iface
    >
    > 192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
    >
    > 127.0.0.0 * 255.0.0.0 U 0 0 0 lo
    >
    > default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
    >
    >
    >
    > ----------output of dmesg | grep eth-------------------------------
    >
    > eth0: VIA VT6102 Rhine-II at 0xe800, 00:0d:87:06:16:80, IRQ 16.
    >
    > eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 41e1.
    >
    > eth0: Setting full-duplex based on MII #1 link partner capability of 41e1.
    >
    > NETDEV WATCHDOG: eth0: transmit timed out
    >
    > eth0: Transmit timed out, status 0002, PHY status 786d, resetting...
    >
    > NETDEV WATCHDOG: eth0: transmit timed out
    >
    > eth0: Transmit timed out, status 0003, PHY status 786d, resetting...
    >
    > NETDEV WATCHDOG: eth0: transmit timed out
    >
    > eth0: Transmit timed out, status 0003, PHY status 786d, resetting...
    >
    > NETDEV WATCHDOG: eth0: transmit timed out
    >
    > eth0: Transmit timed out, status 0003, PHY status 786d, resetting...
    >
    >
    >
    > --------------------------end------------------------------------
    >
    I have rp-pppoe working with ADSL in a similar configuration.

    It is my understanding that you should not have eth0 come up with an ip address nor should you have a default route before enabling the adsl/pppoe connection. The fact that eth0 has an ip address of 192.168.1.10 may be a problem. Once the connection is established ppp0 will be assigned an ip address and a defaultroute will be set. You do have DEFAULTROUTE=yes specified in /etc/ppp/pppoe.conf don't you?

    I don't use Mandrake so I can't tell you how to ensure that eth0 has no ip address and you have no defaultroute set after booting and before trying to bring up the adsl/pppoe connection.

    Good luck,
    Randy
    Randy Cooper Guest

Similar Threads

  1. ADSL for nothing for a year
    By Jenny in forum Macromedia Contribute Connection Administrtion
    Replies: 1
    Last Post: March 28th, 06:28 AM
  2. ADSL e LINUX
    By Dario in forum Linux Setup, Configuration & Administration
    Replies: 0
    Last Post: August 11th, 03:42 PM
  3. Problems with ADSL in Win XP
    By Trond Ruud in forum Windows Networking
    Replies: 2
    Last Post: July 16th, 12:00 AM
  4. USB adsl modem/network
    By Michael in forum Windows Networking
    Replies: 0
    Last Post: July 8th, 05:59 AM
  5. solaris 8 & ADSL
    By Dave Uhring in forum Sun Solaris
    Replies: 1
    Last Post: July 4th, 08:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139