Professional Web Applications Themes

HELP LILO/Bootpart problem - Linux Setup, Configuration & Administration

On my machine I have two disks: hda has win2k installed on it, hdb contains Linux (Mandrake 9.1). I have installed lilo on hdb. I have used the BOOTPART utility to dual boot Win2k/Linux. The only problem is that once I choose the Linux boot option, a string of characters like: L 99 99 99 99 99 99 99 .... appear on screen and after 4 or 5 lines the LILO screen will appear and a normal boot follows. Once booted everything works fine. I did not have this problem before on Mandrake 9. What is going wrong? Any advice ...

  1. #1

    Default HELP LILO/Bootpart problem

    On my machine I have two disks: hda has win2k installed on it, hdb contains
    Linux (Mandrake 9.1). I have installed lilo on hdb. I have used the BOOTPART
    utility to dual boot Win2k/Linux. The only problem is that once I choose the
    Linux
    boot option, a string of characters like:

    L 99 99 99 99 99 99 99 ....

    appear on screen and after 4 or 5 lines the LILO screen will appear and a
    normal boot follows. Once booted everything works fine.
    I did not have this problem before on Mandrake 9.
    What is going wrong? Any advice is welcome.


    Mehrdad Guest

  2. #2

    Default Re: HELP LILO/Bootpart problem

    Mehrdad Ghassempoory wrote:
     

    .... that is indicative of a failure of the first-stage loader.
    when the first-stage loader runs, it writes an "L", then when
    it's passing control to the second stage, it put up an "I",
    so since you arent getting to the second stage, this would
    [usually] indicate an issue with the disk; in this case:
    99 invalid second stage index sector (LILO)
    this one relates to a disk read error, normally an issue with
    reading the map file
    ..
    --
    /// Michael J. Tobler: motorcyclist, surfer, skydiver, \\\
    \\\ and author: "Inside Linux", "C++ HowTo", "C++ Unleashed" ///
    When Marriage is Outlawed, Only Outlaws will have Inlaws.

    mjt Guest

  3. #3

    Default Re: HELP LILO/Bootpart problem

    On Wed, 29 Oct 2003 12:09:42 GMT, mjt <com>
    wrote:
     
    >
    >... that is indicative of a failure of the first-stage loader.
    >when the first-stage loader runs, it writes an "L", then when
    >it's passing control to the second stage, it put up an "I",
    >so since you arent getting to the second stage, this would
    >[usually] indicate an issue with the disk; in this case:
    >99 invalid second stage index sector (LILO)
    >this one relates to a disk read error, normally an issue with
    >reading the map file[/ref]

    All true, but not generally due to a disk I/O error. Generally the underlying
    cause is some confusion over BIOS device codes; i.e., the map file is not on
    the BIOS device code which was used for the disk in question when LILO was
    installed.

    Two solutions:

    1. Use: disk=/dev/hdX bios=0x8N # X=a,b,c,... N=0,1,2,...
    to resolve the BIOS codes explicitly.
    2. Use LILO version 22.5 or later (22.5.8 is current), which boots by disk
    VolumeID, resolving the BIOS codes at boot time.

    #2 is the more fault tolerant approach.

    --John


    JohnInSD Guest

Similar Threads

  1. lilo and win 2k
    By sridhar in forum Linux Setup, Configuration & Administration
    Replies: 4
    Last Post: October 27th, 07:57 AM
  2. lilo + raid1
    By Roger in forum Linux Setup, Configuration & Administration
    Replies: 3
    Last Post: October 3rd, 03:23 PM
  3. Booting 2nd HDD from Lilo
    By Darsin in forum Linux Setup, Configuration & Administration
    Replies: 5
    Last Post: August 15th, 07:33 AM
  4. boot problem after Mandrake upgrade and cannot make LILO work
    By Giovanni in forum Linux Setup, Configuration & Administration
    Replies: 2
    Last Post: August 9th, 02:02 AM
  5. lilo install problem
    By Timo Voipio in forum Linux Setup, Configuration & Administration
    Replies: 1
    Last Post: July 19th, 05:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139