But clicking on the links merely opens the target file at page 1, i.e.
it won't open at the chosen page within the selected file.




If Mr. Walker's advice doesn't work, you may also try de-selecting the "Open Cross-Doc Links In Same Window" box in the General Preferences.