Professional Web Applications Themes

How do I start the mysql service with old-passwords - MySQL

This works find from the command line mysqld-nt --defaults-file="C:\Program Files\MySQL\MySQL Server 5.0\my.ini" --old-passwords="1" I want to change the registry so that the old-passwords option is set automatically. I don't want to change my my.ini file The ImagePath key under HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\M ySQL501 has this value. "C:\Program Files\MySQL\MySQL Server 5.0\bin\mysqld-nt" --defaults-file="C:\Program Files\MySQL\MySQL Server 5.0\my.ini" "MySQL501" and it works fine. But if I change it to be like this it doesn't work. "C:\Program Files\MySQL\MySQL Server 5.0\bin\mysqld-nt" --defaults-file="C:\Program Files\MySQL\MySQL Server 5.0\my.ini" --old-passwords="1" "MySQL501" "C:\Program Files\MySQL\MySQL Server 5.0\bin\mysqld-nt" --old-passwords="1" --defaults-file="C:\Program Files\MySQL\MySQL Server 5.0\my.ini" "MySQL501" Nor this "C:\Program Files\MySQL\MySQL Server 5.0\bin\mysqld-nt" --old-passwords --defaults-file="C:\Program Files\MySQL\MySQL Server 5.0\my.ini" ...

  1. #1

    Default How do I start the mysql service with old-passwords

    This works find from the command line
    mysqld-nt --defaults-file="C:\Program Files\MySQL\MySQL Server
    5.0\my.ini" --old-passwords="1"

    I want to change the registry so that the old-passwords option is set
    automatically. I don't want to change my my.ini file

    The ImagePath key under
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\M ySQL501 has this
    value.

    "C:\Program Files\MySQL\MySQL Server 5.0\bin\mysqld-nt"
    --defaults-file="C:\Program Files\MySQL\MySQL Server 5.0\my.ini"
    "MySQL501" and it works fine.

    But if I change it to be like this it doesn't work.

    "C:\Program Files\MySQL\MySQL Server 5.0\bin\mysqld-nt"
    --defaults-file="C:\Program Files\MySQL\MySQL Server 5.0\my.ini"
    --old-passwords="1" "MySQL501"

    "C:\Program Files\MySQL\MySQL Server 5.0\bin\mysqld-nt"
    --old-passwords="1" --defaults-file="C:\Program Files\MySQL\MySQL
    Server 5.0\my.ini" "MySQL501"

    Nor this "C:\Program Files\MySQL\MySQL Server 5.0\bin\mysqld-nt"
    --old-passwords --defaults-file="C:\Program Files\MySQL\MySQL Server
    5.0\my.ini" "MySQL501"

    What option do I use if I want to run mysql as a service with the
    old-passwords preference set?

    Mike Guest

  2. #2

    Default Re: How do I start the mysql service with old-passwords

    Mike Vidal wrote: 

    Ok, I just tried this. I got it to work, kind of. Instead of editing
    the registry directly, I used the mysqld command, which has "--install"
    and "--remove" options you can use.

    The trick is that when installing the service, it seems to accept only
    _one_ argument besides the name of the service. That is, either of the
    following work:

    mysqld-max-nt --install MySQL5 --old-passwords
    mysqld-max-nt --install MySQL5 --defaults-file="..."

    But trying to give both options does not work:

    mysqld-max-nt --install MySQL5 --old-passwords --defaults-file="..."

    To make it worse, the error message given is totally misleading:

    [ERROR] mysqld-max-nt.exe: unknown option '--install'

    Anyway, I got the --old-passwords option to take effect. "SHOW
    VARIABLES LIKE 'old_passwords'" returns "ON", which verifies this.

    The my.ini file happens to be at the default path that's hardcoded into
    the mysqld binary. But if it weren't, I'd need to specify the path to
    the my.ini file in the service startup. I'm not sure if there is a way
    to specify both --old-passwords and --defaults-file in the service
    definition.

    Why don't you want to put the old_passwords option into the my.ini file?

    Regards,
    Bill K.
    Bill Guest

Similar Threads

  1. Replies: 2
    Last Post: April 28th, 10:11 PM
  2. Win2000 - CF Service Will Not Start
    By shaykewich in forum Coldfusion Server Administration
    Replies: 1
    Last Post: December 16th, 04:42 AM
  3. CFMX7 service won't start
    By dawils in forum Macromedia ColdFusion
    Replies: 4
    Last Post: April 6th, 04:05 AM
  4. Replies: 0
    Last Post: September 10th, 12:02 AM
  5. Replies: 0
    Last Post: September 10th, 12:01 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139