Professional Web Applications Themes

HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS) - Macromedia Flash Player

This solution is for WINDOWS ONLY!!! Unfortunately I believe it is a bug in flash itself as I have read more than one instance of this same no audio problem occuring on MAC'S and LINUX based systems as well. IF YOU KNOW OF SOLUTIONS TO THE MAC OR LINUX BASED PROBLEMS, PLEASE POST THEM IN THIS THREAD. Description of the problem: Video sites such as YouTube, VideoSift, Break, Google Videos, Yahoo, and a plethora of others do not stream embedded audio. Viewing a YouTube video, for example, on VideoSift.com results in the video playing back with no audio. However, by ...

  1. #1

    Default HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    This solution is for WINDOWS ONLY!!! Unfortunately I believe it is a bug in
    flash itself as I have read more than one instance of this same no audio
    problem occuring on MAC'S and LINUX based systems as well. IF YOU KNOW OF
    SOLUTIONS TO THE MAC OR LINUX BASED PROBLEMS, PLEASE POST THEM IN THIS THREAD.

    Description of the problem: Video sites such as YouTube, VideoSift, Break,
    Google Videos, Yahoo, and a plethora of others do not stream embedded audio.
    Viewing a YouTube video, for example, on VideoSift.com results in the video
    playing back with no audio. However, by going directly to YouTube and playing
    back the same video, it appears to work.

    THERE ARE SEVERAL POSSIBLE SOLUTIONS.

    Problem: You may be missing your WAVEMAPPER driver.
    Cause: Wavemapper driver was removed during installation or updating of the
    Flash Player. It might not necessarily be Flash that removes it but apparently
    something does.
    Solution #1: Google "Flash No Audio WAVEMAPPER" for directions, its been
    covered a bunch, but basically requires running REGEDIT and readding the
    WAVEMAPPER key to the appropriate location and value in the registry. Its not
    as difficult as it sounds.


    [url]http://weyland.be/wrdprss/index.php/2006/08/22/no-sound-in-macromedia-flash-play[/url]
    er-9/

    if your wavemapper key is installed correctly...

    Possible Cause: Corrupted or damaged flash content preventing audio streaming
    from working correctly.
    Soltuion #2: Run CC Cleaner and delete only cached Flash content. It is a
    free program, again just google "download CC Cleaner". This particular
    solution worked for me.

    If CC Cleaner also does not work, the description of your problem may differ
    slightly. In my case on several computers, one day it worked, the next day it
    didnt. If it never worked, this would be a logical solution for you. One
    variation of this that I have found is to create a new Windows User Account and
    log into it. The reason the CC Cleaner method may work better is that the User
    Accounts have their own separate cache folders so a corrupted cache preventing
    audio playback on one profile will not be available on the other User Account
    to cause the same problem. I wont explain how to do this as the CC Cleaner
    will work better but if you are curious, yet again google "create new windows
    user accounts". I have also seen this method work on one of my affected
    computers but it did not fix the issue on the account I was having problems
    with.

    [url]http://www.ccleaner.com[/url] Install and run it, use it only to remove Flash under
    the Applications Tab, Multimedia, Adobe Flash Player. Check it and uncheck
    everything else, then hit yze then Run Cleaner.

    Possible Cause: Missing Codec
    Solution #2: Download and install the K-Lite Codec pack. Again, google it.
    A CODEC stands for COmpressor DECompressor and is a way to make audio and video
    files small enough to be transferred on the internet. There are a lot of
    different codecs and if you want to play back a video that was compressed using
    a particular codec, you will need that same corresponding codec to decompress
    your media source and view its content. Basically if you dont have a codec,
    you cant observe the content of the media. If you have a VCR and want to play
    back a DVD, you are out of luck unless you get a DVD Player. DivX and XVid
    Codecs are some of the very popular codecs used on the net, but to get those, I
    still suggest getting the K-Lite Codec Pack.

    [url]http://www.free-codecs.com/download/K_Lite_Codec_Pack.htm[/url]

    Solution #4: Go back to Flash 7. If it aint broke dont fix it. This Final
    alternative is only to be used as a last resort. You'll have to get rid of
    Flash 9 and go back to Flash 7. The really tricky part here is that you have
    to prevent Flash from auto updating itself. If you install Flash 7, and hit up
    YouTube, you'll immediately get Flash 9+ installed again with the same
    problems. So AFTER you uninstall Flash 9 (use Macromedias / Adobes
    uninstaller, yet again go google it) make a new text file and name it MMS.CFG,
    in the file put this one line "AutoUpdateDisable=1" (without the quotes) and
    put it in BOTH your c:\windows\system32 AND c:\windows\system32\Macromed\Flash
    folders. This will prevent flash from Auto Updating to 9+, then have to find
    some place to download the old flash 7 installer. I found one here.
    [url]http://www.intercomm.com/downloads/Flash7[/url]. Only problem is that most sites
    will try to make you install Flash 9 and Flash 7 does not work on all sites,
    but it does on some like YouTube. DO NOT UPDATE TO FLASH 9+ IF YOU USE THIS
    METHOD.

    You will probably want to IMMEDIATELY go to
    [url]http://www.macromedia.com/support/doentation/en/flashplayer/help/settings_man[/url]
    ager05.html after installing Flash 7 and UNCHECK the update feature

    I've tried to write this quick little guide at 3AM so Im not going to take
    more time to research other ways to fix this problem. If you have other
    solutions, such as for MAC and LINUX, or feel like adding on to something else
    that I've written here (links would be useful to the downloads I suggested) or
    correcting any mistakes I probably have made, please say so.

    One of these solutions is bound to help you. Theres multiple causes for this
    no audio problem so there is obviously multiple fixes.

    beezlebob666 Guest

  2. #2

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    Double post, sue me. Ok, another possible fix is to install the standalone
    player. Hopefully at the time youre reading this (if this msg is archived)
    this version will be current.

    Solution #5 Install Standalone Player
    [url]http://www.softwarepatch.com/internet/flash.html[/url]

    You might want to refer to this thread for more detail on some of the other
    Java stuff that may have to be reinstalled also:

    [url]http://www.adobe.com/cfusion/webforums/forum/messageview.cfm?forumid=44&catid=18[/url]
    4&threadid=1245905&enterthread=y

    By the way, if ANY of these fixes helped you solve this NO AUDIO problem,
    please post which one worked for you...

    beezlebob666 Guest

  3. #3

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    YOU ROCK beezlebob666.

    Bow's before you. Fixed my problem in flash video on youtube.com with no audio / sound in seconds. Thank you soooooo much!!! I can now hear flash 9.0 sound!!!
    CenterC Guest

  4. #4

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    Just out of curiousity, which one of those fixes was it?
    beezlebob666 Guest

  5. #5

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    CCleaner took out a corupted flash file and all worked!!! Follow instructions,
    if you closed a youtube video and it corrupted, example you shut down computer.
    Ccleaner removes it and youtube works again.

    CenterC Guest

  6. #6

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    Nothing seems to work!

    I checked the registry key to see that "wavemapper" key was there. I
    downloaded CCleanner and ran it to clean out my cache as well as using it to
    unistall Flash 9 (and reinstall). The fore-mentioned link to Flash 7 is now
    gone to I couldn't try that. I downloaded and installed the K-Lite Codec, as
    well as the stand alone Flash player and still no audio!

    I have sound everywhere else; I even checked my own website where I have
    streaming Quicktime and there is sound. For good measure I even uninstalled an
    reinstalled my audio drivers to no solution.

    While I have a 5.1 surround sound card plugged in, the system for some reason
    does not "see" it. Instead I am using the surround sound system and drivers
    off of the main-board.

    Any other solutions to this problem?

    Exordia Guest

  7. #7

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    Resolved my no sound issue by using the Flash Uninstaller to remove Flash
    Player 9, rebooting and then installing Flash Player 8. Now I have sound in
    Youtube. Not sure what has changed between 8 and 9 but I imagine one day I'll
    be forced to upgrade, but hopefully the issue will be resolved.

    Archived players
    [url]http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=tn_14266[/url]

    fataldata Guest

  8. #8

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    For Mac OS, the following tech doc is most likely to help:
    [url]http://www.adobe.com/go/41f8f08d[/url]
    i-wt Guest

  9. #9

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    For everyone who has tried all of the above 5 solutions and still cant get it
    to work under WINDOWS (XP) try this?.

    All AC97 sound systems are capable of surround sound.

    It seems that by default if you have enabled surround sound then WINDOWS
    mirrors most stereo sounds to the surround speakers.

    It also seems that the latest version of FLASH (I tired 9 and 7) is surround
    sound aware and thus doesn?t have its stereo sound mirrored to the surround
    speakers.

    I found that in my sound card utility (c-media) I had surround sound enabled
    (4 speakers). The sound test in that utility only played sound in the rear 2
    speakers. Unplugging the stereo speakers from the surround port and plugging
    them into the stereo headphone port and using the utility to configure the
    system for only stereo speakers I found I could then get sound in FLASH files
    and online (youtube) again :))


    lillucky Guest

  10. #10

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    the solutions above didn't help :(

    I've noticed, that anytime I visit youtube, there is created a file
    "sounddata.sol" in folder ..\macromedia\flash player\# shared objects\

    i've opened it in notepad - it says "4TCSO  soundData volume
    mute" (so no wonder there is no sound :|)

    I deleted the file - but it is created again when i visit youtube. I tried to
    be smarter, changed "mute" to "on", but when i visited youtube it was replaced
    again. I changed file properties to read only - then it created another file.
    oh, i have the same thing with myspace :(
    I'm getting really frustrated :(

    anyone can help?? pleaaase?


    silme# Guest

  11. #11

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    Hey Beezlebob, thanks ever sooooo muchhh, it was the CCleaner that fixed it for
    me. Just followed your instructions and it was done. :grin;:music;
    So even though I got Flash Player 9, You Tube works fine now for me.

    Viperblue Guest

  12. #12

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    Strangest configuration I ever saw, but it works...

    Yeah, I've got the AC'97 surround sound system: I have the the center,
    sub-woofer and back speaker connectors in the back of the computer, and my main
    front speakers connected to the front panel!

    Now I have all my Windows sounds back as well.
    Thanks!:grin;

    Exordia Guest

  13. #13

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    Just wanted to thank you for posting this link. I'd tried EVERYTHING to get
    the sound to work on my mac and this article finally showed me how to fix it.
    I was literally pulling my hair out, so thanks again!

    maggie_the_cat Guest

  14. #14

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    Hi i have tried all of the suggested solutions and i still have no sound!!!

    Sound is fine on windows media, just not on youtube and other online video
    players.

    First (when it went wrong) i could only hear the sound very faintly out of one
    speaker, now there is no sound at all. But as mentioned there is sound on
    windows.

    Can any one help. Any ideas? In LAMENS terms (directions) if poss. Im not that
    knowledgable on pcs.

    Thanx

    utopia2004 Guest

  15. #15

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    I too had NO SOUND in Flash players. I just finished building this computer
    for my wife. Installed late at night. Not many lights on. Keep this in
    mind...

    Yesterday I had a sound problem and had to adjust my surround sound to get
    ANYTHING, Had to go to 4 speakers even though I only had 2. Hmmmmmm.

    A couple of the suggestions talked about the Flash , Stereo / Surround Sound,
    and AC97 audio devices.

    After reading these posts I started the Free Napster [Flash] player and went
    back to my surround sound (Clicked on the little Xear 3D emblem to launch) and,
    while playing a 4 minute song, messed with the settings. Heard NO SOUND on 2
    speakers, and Only 3D sound on 4 speakers. No sound from the 4 minute song.

    Checked where I plugged the Speaker cable in. It was NOT in the pretty green
    hole. Plugged the Green Plug into the Green Hole - ALL SORTS OF MUSIC NOW!!!!!


    Problem Solved!!! I had plugged the cable in to the computer at
    night...Into the WRONG hole. SO, the Surround Sound was telling the system
    that I had 4 speakers, and Flash wanted to ONLY go to stereo, which the
    Surround Sound was routing to non-existent speakers.

    I have only been building computers since 1993. You would think I know better
    by now, eh??

    Anyway , for those having problems, perhaps your speakers are not plugged in
    correctly or your surround sound is not configured correctly.

    As I found out, Not Everything is a driver fault. As a tech with 20 years of
    PC experience I have seen my fair share of Operator error - Now I are one :-)

    rnamen Guest

  16. #16

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    http://www.camsohbeti.com http://www.aramadanbuldum.com http://www.hulyaca.tr.gg
    camsohbeti Guest

  17. #17

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    Ha... I created my account to comment on beezlebob666 valiant effort to assist
    people with various flash problems. You rock, you managed to put MOST of the
    solution into one post and walk people through it. Every other post I've seen
    literally seems to copy/paste from some tech booklet.

    So, I am running with XP home-MC edition, sp2, althlon64 4200+ w/ 2g ram and a
    nvidia8600gs. Never had any audio problems before, couldn't recall any new
    programs I've installed. I should point out I've been putting at least an
    hour(plus) a night into solving this one for the last 3-ish weeks.

    Solution 1) Did it, three times and in various version. No gas. Many restarts.
    Solution 2) Got it. Love the program, helped with other problems but no go.
    Solution 3) Installed every codec that exists and a few I am sure that don't.
    Nothing (Btw, you have solution 3 labeled "2")
    Solution 4) Did it, I even went crazy and tried a few stand-alone players and
    knock-offs. Nothing.
    Solution 5) See solution 4.

    Very thorough indeed.

    But, in the end I need to thank rnamen. I pulled what Troll calls a "Flashing
    12" move... I had my stereo unplugged... I was checking my surround sound and
    noticed that I wasn't getting any front sound and just added that to the list
    of crap that I needed to work on. So, when I read your post, I thought it was
    possible. I just got a razor tarantula and I may have swapped the wrong
    audio-cord or unplugged something in error. Low-and-behold, I was plugged into
    the wrong damned line.


    Khollest Guest

  18. #18

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    [q]Originally posted by: lillucky
    For everyone who has tried all of the above 5 solutions and still cant get it
    to work under WINDOWS (XP) try this?.

    All AC97 sound systems are capable of surround sound.

    It seems that by default if you have enabled surround sound then WINDOWS
    mirrors most stereo sounds to the surround speakers.

    It also seems that the latest version of FLASH (I tired 9 and 7) is surround
    sound aware and thus doesn?t have its stereo sound mirrored to the surround
    speakers.

    I found that in my sound card utility (c-media) I had surround sound enabled
    (4 speakers). The sound test in that utility only played sound in the rear 2
    speakers. Unplugging the stereo speakers from the surround port and plugging
    them into the stereo headphone port and using the utility to configure the
    system for only stereo speakers I found I could then get sound in FLASH files
    and online (youtube) again :))
    [/q]

    People should really try this solution first, as I had tried a good 10 others
    that didn't work in my situation until I stumbled upon this one and it worked
    like a charm. LISTEN CLOSE!

    If you have a computer that has a headphone jack in the front as well as
    speaker jacks in the back, check to make sure that you are getting sound on
    youtube from the headphone jack on the front ( by plugging headphones into the
    front jack ). If you get youtube/Flash 9 sound from your front headphones WITH
    A PAIR OF HEADPHONES but are not getting youtube sound from the speaker jacks
    in the back of your computer, odds are the quote from lillucky above applies
    EXACTLY to your situation. Hope this helps people that have had the same
    problem I had where I could hear youtube sound in my headphones but not through
    my surround sound speakers.

    waywardspooky Guest

  19. #19

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    I believe the latest Flash version addresses this problem.

    http://www.pcdoctorsgroup.com/ http://www.spinoff.com/
    http://www.second-life-blogger.com/ http://www.baby-boomer-blog.com/
    http://www.pick-my-proxy.com/

    rhondaray Guest

  20. #20

    Default Re: HOW TO FIX NO AUDIO PROBLEM IN FLASH (4 SOLUTIONS)

    Thanks m8 this really helped me out,
    Kelevra79 Guest

Page 1 of 2 12 LastLast

Similar Threads

  1. Flash 9 audio problem with Firefox 2.0.0.3
    By aj51linux in forum Macromedia Flash Player
    Replies: 0
    Last Post: April 21st, 02:20 AM
  2. Flash 9 and Youtube Audio Problem
    By akablueeye in forum Macromedia Flash Player
    Replies: 0
    Last Post: February 15th, 10:44 PM
  3. cam/audio problem with Flash 9
    By harrison37 in forum Macromedia Flash Player
    Replies: 3
    Last Post: August 18th, 07:23 PM
  4. Flash 9 audio problem
    By Kevin Quick in forum Macromedia Flash Player
    Replies: 12
    Last Post: August 4th, 08:41 PM
  5. Flash 8 Audio Problem on Mac
    By video conferencing in forum Macromedia Flash Flashcom
    Replies: 1
    Last Post: September 16th, 05:02 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139