Professional Web Applications Themes

How to identify xterm font - FreeBSD

I like the size of the xterm window. It is small and it uses very easy to read font. Unfortunately, it does not play very well with emacs. For these reasons I use Gnome terminal. Gnome font is bigger, thus it takes more space on the screen. How do I identify which font is used by xterm, so I can apply it for gnome terminal? I also would like to know why my ~/.Xdefaults configuration is not applied in Gnome. It worked just fine in KDE and most other environments....

  1. #1

    Default How to identify xterm font

    I like the size of the xterm window. It is small and it uses very
    easy to read font. Unfortunately, it does not play very well with
    emacs. For these reasons I use Gnome terminal. Gnome font is bigger,
    thus it takes more space on the screen. How do I identify which font
    is used by xterm, so I can apply it for gnome terminal?

    I also would like to know why my ~/.Xdefaults configuration is not
    applied in Gnome. It worked just fine in KDE and most other
    environments.

    Sergei Guest

  2. #2

    Default Re: How to identify xterm font

    Sergei Gnezdov wrote:
     

    Gnome terminal uses Xft, so I'd say you'd first have to mess with
    fontconfig and alias your xterm core font to an appropriate Xft font.
     

    try ln -s .Xdefaults .Xresources
    Matthias Guest

  3. #3

    Default Re: How to identify xterm font

    On Thu, Mar 10, 2005 at 07:31:09AM +0000, Sergei Gnezdov wrote: 

    I can't answer this question, but want to chime in on this thread just
    because I had the same question a few weeks ago, but could never figure
    it out. I poked around my system and Googled until I was blue in the
    face, but came up with nothing. The reason is that I had recently
    switched from rxvt to urxvt (for Unicode support) and the default font,
    or whichever one it ended up grabbing) looked awful, but I liked very
    much the font that rxvt was using. I even ran a kernel trace on the
    program in an attempt to figure out what font it was settling on, but
    was only able to get a partial answer from that, as the font lines were
    truncated. As I say, this doesn't help, but I post here only in the
    hope that perhaps another post to the thread will catch someones eye who
    might know how to figure out what font a particular X terminal is using
    when it hasn't been explicity set already.

    Nathan

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.2.4 (GNU/Linux)

    iD8DBQFCMNJbO0ZIEthSfkkRAszuAJwPTThMhTNSzOT52TxZHT zdtjp41ACcD/Ln
    TNhc9/yUyZrEmDHjaGT3FkU=
    =yzWK
    -----END PGP SIGNATURE-----

    Nathan Guest

  4. #4

    Default Re: How to identify xterm font

    On 2005-03-10 17:03, Nathan Kinkade <edu.bz> wrote: [/ref]

    Just FYI,

    I usually start a screen(1) session within ALL my xterm windows with a
    TERM environment variable of "vt220", because this is available on all
    the systems I commonly connect to through ssh(1).

    Emacs within screen within xterm works absolutely *perfect*, after a bit
    of tweaking to the key map is applied. My ~/.emacs file contains, among
    other things, the following keys:

    ;; Some bindings to make using Emacs nicer on vt220 terminals.
    (global-set-key "\C-h" 'backward-delete-char)
    (global-set-key [delete] 'delete-char)
    (global-set-key [deletechar] 'backward-delete-char)
    (global-set-key "\M-\C-h" 'backward-kill-word)
    ;;
    (global-set-key [home] 'beginning-of-line)
    (global-set-key [find] 'beginning-of-line)
    (global-set-key [end] 'end-of-line)
    (global-set-key [select] 'end-of-line)

    CTRL-a and CTRL-e are ok when I'm working on the GNU bash command line,
    but when I am in Emacs, I some times find it easier to hit END :-)
     [/ref]

    The default font used by xterm windows is 'fixed'. Or whatever this has
    been aliased to. Its real font name can be found by grepping the
    font.alias files under /usr/X11R6/lib/X11/fonts for 'fixed':

    $ cd /usr/X11R6/lib/X11/fonts
    $ grep -r '^fixed[[:space:]]' .
    ./cyrillic/fonts.alias:fixed -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-koi8-r
    ./misc/fonts.alias:fixed -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso8859-1
    $
     [/ref]

    Are you using an X11 desktop manager with Gnome? This could explain
    what you see. When GDM, KDM or XDM is used to fire up the X server
    *after* obtaining a username/password from a valid user, the default
    script of actions that xinit runs is ~/.xsession or one that the
    "desktop manager" chooses (for XDM this is Xsession from the directory
    /usr/X11R6/lib/X11/xdm).

    When you just type "startx" in a console window, a different script is
    executed to start the X programs you will use. This is teh ~/.xinitrc
    script or /usr/X11R6/lib/X11/xinit/xinitrc if the former doesn't exist.

    It may be that one of these runs xrdb with ~/.Xdefaults but the other
    doesn't -- and this would explain why you see a different behavior now.

    - Giorgos

    Giorgos Guest

  5. #5

    Default Re: How to identify xterm font

    On Thu, 10 Mar 2005, Nathan Kinkade wrote:
     
    >
    > I can't answer this question, but want to chime in on this thread just
    > because I had the same question a few weeks ago, but could never figure
    > it out. I poked around my system and Googled until I was blue in the
    > face, but came up with nothing. The reason is that I had recently
    > switched from rxvt to urxvt (for Unicode support) and the default font,
    > or whichever one it ended up grabbing) looked awful, but I liked very
    > much the font that rxvt was using. I even ran a kernel trace on the
    > program in an attempt to figure out what font it was settling on, but
    > was only able to get a partial answer from that, as the font lines were
    > truncated. As I say, this doesn't help, but I post here only in the
    > hope that perhaps another post to the thread will catch someones eye who
    > might know how to figure out what font a particular X terminal is using
    > when it hasn't been explicity set already.[/ref]

    Don't know about rxvt or urxvt, but for plain old xterm, the font settings
    are in /usr/X11R6/lib/X11/app-defaults/XTerm.


    --
    David Fleck
    com

    David Guest

Similar Threads

  1. How to identify correct font for TouchUp Text tool.
    By John_Deer@adobeforums.com in forum Adobe Acrobat Macintosh
    Replies: 4
    Last Post: October 3rd, 10:02 PM
  2. Can't identify font
    By Kenneth_Hendrickson@adobeforums.com in forum Adobe Illustrator Windows
    Replies: 2
    Last Post: April 7th, 08:42 PM
  3. identify a font
    By Broke in Arizona in forum Macromedia Dreamweaver
    Replies: 4
    Last Post: July 19th, 05:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139