Nick Forest wrote:
> I am using Mandrake 9.1 & tried to burn a music CD finding that it's
> slow.
> I've configured /etc/syslog/harddisks to support DMA.
> And the following test were done:
>
> (1)
> dmesg|grep hd
>
> Kernel command line: BOOT_IMAGE=linux ro root=307 devfs=mount
> hdd=ide-scsi acpi=off quiet
> ide_setup: hdd=ide-scsi
> ide0: BM-DMA at 0xe000-0xe007, BIOS settings: hda:DMA, hdb:pio
> ide1: BM-DMA at 0xe008-0xe00f, BIOS settings: hdc:DMA, hdd:DMA
> hda: ST340016A, ATA DISK drive
> hda: DMA disabled
> hdc: ATAPI-CD ROM-DRIVE-50MAX, ATAPI CD/DVD-ROM drive
> hdd: LITE-ON LTR-16102B, ATAPI CD/DVD-ROM drive
> hdc: DMA disabled
> hdd: DMA disabled
> hda: host protected area => 1
> hda: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=4865/255/63,
> UDMA(66)
> hdc: ATAPI 50X CD-ROM drive, 128kB Cache, UDMA(33)
>
> (2)/dev/hda:
>
> Model=ST340016A, FwRev=3.19, SerialNo=3HS2W5GZ
> Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs RotSpdTol>.5% }
> RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
> BuffType=unknown, BuffSize=2048kB, MaxMultSect=16, MultSect=16
> CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=78165360
> IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
> PIO modes: pio0 pio1 pio2 pio3 pio4
> DMA modes: mdma0 mdma1 mdma2
> UDMA modes: udma0 udma1 udma2 udma3 *udma4
> AdvancedPM=no WriteCache=enabled
> Drive conforms to: device does not report version: 1 2 3 4 5
>
> (3)
> hdparm -t /dev/hda
>
> /dev/hda:
> Timing buffered disk reads: 64 MB in 3.53 seconds = 18.13 MB/sec
>
> My HD is Seagate Barracuda 40G (ATA100), which souldn'g be so slow?
> How do I open the DMA support properly?
man hdparm

hth david (remove nospam in address)

Registered Linux User 226449: Machine no. 164641

Everybody brings us happiness,some as they
arrive,others as they leave.