I've been trying to get my new HP Deskjet 5550 printer to work
with RH 7.3. (At linuxprinting.org they said it worked
"perfectly" with Linux)

I didn't know there were two spooling systems available when I
installed hpijs 1.4.1 as described at linuxprinting.org.

I did another of linuxprinting.org checks as well, my
ghostscript 6.52 does have the ijs driver even though it is only
supposed to be present starting with 6.53.

Then I discovered I was running LPRng. I haven't found any
doents on how to make the 5550 work with 7.3. (I did find
one that didn't work, it seems RH has done some clever things to
their system so the directions did not apply.)

And I've tried to break open the Red Hat package that upgrades
hpijs to 1.3 but it won't install unless I install many other
things (I've had that upgrade nightmare before, you end up
replacing one thing after another). There ought to be a way to
break open a package (as in tar -xf) so it will dump them in a
directory so I can add, maybe manually, the definitions for a
5550. Is there? The definitions for a printer ought to be
plain text. Although, I never have found it. Where are these
definitions anyway?

But then I found cups, version 1.1.14 on the PC and I thought,
OK, I don't care what spooling system does the work.

But you can't install a cups printer without first doing:

/sbin/service lpd stop
/sbin/service cups start

So I did that and proceeded to try to add a printer using the
web based form from the cups organization.

Their form had one odd entry, "Location". My first thought was
/dev/lp0 because it's the parallel port I'm using. But a later
form had /dev/lp0. Then I thought maybe the answer was
"localhost". Then I thought maybe "http://localhost". Now I
think it means nothing except a comment. (Someone ought to
doent what "location" means on that form.)

But printing did not work. I found doentation on how to
debug cups and I got:

I [02/Aug/2003:18:14:31 -0500] Setting deskjet5550 device-uri to
"parallel:/dev/lp0" (was "".)
I [02/Aug/2003:18:14:31 -0500] Setting deskjet5550
printer-is-accepting-jobs to 1 (was 0.)
I [02/Aug/2003:18:14:31 -0500] Setting deskjet5550 printer-state to 3
(was 5.)
I [02/Aug/2003:18:14:31 -0500] Saving printers.conf...
I [02/Aug/2003:18:14:31 -0500] New printer 'deskjet5550' added by 'root'.
I [02/Aug/2003:18:18:32 -0500] Listening to 0:631
I [02/Aug/2003:18:18:32 -0500] Configured for up to 100 clients.
I [02/Aug/2003:18:18:32 -0500] LoadPPDs: Read "/etc/cups/ppds.dat", 1664
PPDs...
I [02/Aug/2003:18:18:33 -0500] LoadPPDs: No new or changed PPDs...
E [02/Aug/2003:18:18:33 -0500] StartListening: Unable to bind socket -
Address already in use.

I'm thinking that's the problem right up there.

I [02/Aug/2003:18:18:46 -0500] Started "/usr/lib/cups/cgi-bin/admin.cgi"
(pid=4606)
I [02/Aug/2003:18:18:48 -0500] Started
"/usr/lib/cups/cgi-bin/printers.cgi" (pid=4607)
I [02/Aug/2003:18:18:50 -0500] Started
"/usr/lib/cups/cgi-bin/printers.cgi" (pid=4608)
I [02/Aug/2003:18:18:51 -0500] Job 7 queued on 'deskjet5550' by 'root'.
I [02/Aug/2003:18:18:51 -0500] Started filter
/usr/lib/cups/filter/pstops (PID 4609) for job 7.
I [02/Aug/2003:18:18:51 -0500] Started filter
/usr/lib/cups/filter/foomatic-rip (PID 4610) for job 7.
I [02/Aug/2003:18:18:51 -0500] Started backend
/usr/lib/cups/backend/parallel (PID 4611) for job 7.
E [02/Aug/2003:18:18:53 -0500] PID 4610 stopped with status 1!

Then foomatic-rip quit with an exit code of 1.

So, can anyone help?

Thanks,

Don Tveter, [email]dondontveter.com[/email], [email]drtunidial.com[/email]