I'm trying to share an HP ScanJet 7450c, which is
connected by USB to my XP Pro machine, with another
machine on my Windows peer-to-peer network. I was able to
do this a couple of months ago, but I can't now. The
scanner works fine in stand-alone mode.

When I tried to open the HP software I got an HP error
dialog box that said "This PC doesn't have any network
protocols loaded." In fact, the network actually has
IPX/SPX and TCP/IP loaded and fully functional. Standard
ping tests work fine. Internet, e-mail, etc., all fine.

At HP's suggestion I tried connecting the scanner to what
I had hoped would be the client PC, thus making that PC
the host, and trying to make the XP Pro machine the
client. This time the scanner-sharing software opened,
but it failed to see any network activity and therefore
will not become the client.

As far as I can tell, the network is otherwise fully
functional--each machine sees the other, they can exchange
files, etc.

I have tried to disable the IPX protocol just to be sure
it wasn't "confusing" the HP software, which works over
TCP/IP, but it made no difference.

Gigabyte GA-8KNXP with Intel 875P chipset, latest BIOS, P4
3GHz multi-threaded processor, 1 GB dual-channel DDR RAM.
Software firewall in the XP network is disabled. Big fast
IDE HDDs, no RAID setup. XP Pro SP1 w/all current
security patches.

All ideas appreciated.

Thanks,

Herb Silverberg