Professional Web Applications Themes

IBM eServer 346 ServeRaid is too slow - FreeBSD

Hi List I've got Subj and FreeBSD-5.4PRE on it. But RAID0 is too slow: rootbeta:eugene# dd if=/dev/zero of=/var/tmp/1 bs=1m count=100 100+0 records in 100+0 records out 104857600 bytes transferred in 31.949508 secs (3281979 bytes/sec) Also what does the following mean? Interrupt storm detected on "irq16: bge0 bge1+"; throttling interrupt Kernel boot messages: Copyright (c) 1992-2005 The FreeBSD Project. Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994 The Regents of the University of California. All rights reserved. FreeBSD 5.4-PRERELEASE #3: Wed Apr 6 17:46:08 MSD 2005 cosmo.ru:/usr/obj/usr/src/sys/BETA Timecounter "i8254" frequency 1193182 Hz quality 0 CPU: Intel(R) Xeon(TM) ...

  1. #1

    Default IBM eServer 346 ServeRaid is too slow

    Hi List

    I've got Subj and FreeBSD-5.4PRE on it. But RAID0 is too slow:
    rootbeta:eugene# dd if=/dev/zero of=/var/tmp/1 bs=1m count=100
    100+0 records in
    100+0 records out
    104857600 bytes transferred in 31.949508 secs (3281979 bytes/sec)

    Also what does the following mean?
    Interrupt storm detected on "irq16: bge0 bge1+"; throttling interrupt

    Kernel boot messages:

    Copyright (c) 1992-2005 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    The Regents of the University of California. All rights reserved.
    FreeBSD 5.4-PRERELEASE #3: Wed Apr 6 17:46:08 MSD 2005
    cosmo.ru:/usr/obj/usr/src/sys/BETA
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Intel(R) Xeon(TM) CPU 3.00GHz (3000.13-MHz 686-class CPU)
    Origin = "GenuineIntel" Id = 0xf34 Stepping = 4
    Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE ,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH, DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
    real memory = 3221016576 (3071 MB)
    avail memory = 3153862656 (3007 MB)
    ACPI APIC Table: <IBM SERONYXP>
    FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
    cpu0 (BSP): APIC ID: 0
    cpu1 (AP): APIC ID: 6
    ioapic2 <Version 2.0> irqs 48-71 on motherboard
    ioapic1 <Version 2.0> irqs 24-47 on motherboard
    ioapic0 <Version 2.0> irqs 0-23 on motherboard
    npx0: <math processor> on motherboard
    npx0: INT 16 interface
    acpi0: <IBM SERONYXP> on motherboard
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    acpi0: Power Button (fixed)
    acpi_bus_number: can't get _ADR
    acpi_bus_number: can't get _ADR
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x588-0x58b on acpi0
    cpu0: <ACPI CPU> on acpi0
    cpu1: <ACPI CPU> on acpi0
    pcib0: <ACPI Host-PCI bridge> on acpi0
    pci0: <ACPI PCI bus> on pcib0
    pci0: <unknown> at device 0.1 (no driver attached)
    pcib1: <ACPI PCI-PCI bridge> at device 2.0 on pci0
    pci2: <ACPI PCI bus> on pcib1
    pcib2: <ACPI PCI-PCI bridge> at device 4.0 on pci0
    pci3: <ACPI PCI bus> on pcib2
    pcib3: <ACPI PCI-PCI bridge> at device 0.0 on pci3
    pci4: <ACPI PCI bus> on pcib3
    mpt0: <LSILogic 1030 Ultra4 Adapter> port 0x4000-0x40ff mem
    0xcffe0000-0xcffeffff,0xcfff0000-0xcfffffff irq 28 at device 1.0 on pci4
    pcib4: <ACPI PCI-PCI bridge> at device 0.2 on pci3
    pci5: <ACPI PCI bus> on pcib4
    pcib5: <ACPI PCI-PCI bridge> at device 6.0 on pci0
    pci6: <ACPI PCI bus> on pcib5
    bge0: <Broadcom BCM5721 Gigabit Ethernet, ASIC rev. 0x4001> mem
    0xcdff0000-0xcdffffff irq 16 at device 0.0 on pci6
    miibus0: <MII bus> on bge0
    brgphy0: <BCM5750 10/100/1000baseTX PHY> on miibus0
    brgphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX,
    1000baseTX-FDX, auto
    bge0: Ethernet address: 00:0d:60:9a:8d:08
    pcib6: <ACPI PCI-PCI bridge> at device 7.0 on pci0
    pci7: <ACPI PCI bus> on pcib6
    bge1: <Broadcom BCM5721 Gigabit Ethernet, ASIC rev. 0x4001> mem
    0xcbff0000-0xcbffffff irq 16 at device 0.0 on pci7
    miibus1: <MII bus> on bge1
    brgphy1: <BCM5750 10/100/1000baseTX PHY> on miibus1
    brgphy1: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX,
    1000baseTX-FDX, auto
    bge1: Ethernet address: 00:0d:60:9a:8d:09
    pci0: <base peripheral> at device 8.0 (no driver attached)
    uhci0: <Intel 82801EB (ICH5) USB controller USB-A> port 0x2200-0x221f irq
    16 at device 29.0 on pci0
    usb0: <Intel 82801EB (ICH5) USB controller USB-A> on uhci0
    usb0: USB revision 1.0
    uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub0: 2 ports with 2 removable, self powered
    uhci1: <Intel 82801EB (ICH5) USB controller USB-B> port 0x2600-0x261f irq
    19 at device 29.1 on pci0
    usb1: <Intel 82801EB (ICH5) USB controller USB-B> on uhci1
    usb1: USB revision 1.0
    uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub1: 2 ports with 2 removable, self powered
    ehci0: <EHCI (generic) USB 2.0 controller> mem 0xf0000000-0xf00003ff irq 23
    at device 29.7 on pci0
    ehci_pci_attach: companion usb0
    ehci_pci_attach: companion usb1
    usb2: EHCI version 1.0
    usb2: companion controllers, 2 ports each: usb0 usb1
    usb2: <EHCI (generic) USB 2.0 controller> on ehci0
    usb2: USB revision 2.0
    uhub2: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
    uhub2: single transaction translator
    uhub2: 4 ports with 4 removable, self powered
    pcib7: <ACPI PCI-PCI bridge> at device 30.0 on pci0
    pci1: <ACPI PCI bus> on pcib7
    drm0: <ATI Radeon QY RV100 7000/VE> port 0x3000-0x30ff mem
    0xdfff0000-0xdfffffff,0xd0000000-0xd7ffffff irq 16 at device 1.0 on pci1
    info: [drm] Initialized radeon 1.11.0 20020828 on minor 0
    isab0: <PCI-ISA bridge> at device 31.0 on pci0
    isa0: <ISA bus> on isab0
    atapci0: <Intel ICH5 SATA150 controller> port
    0x480-0x48f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 31.2 on pci0
    ata0: channel #0 on atapci0
    ata1: channel #1 on atapci0
    ichsmb0: <Intel 82801EB (ICH5) SMBus controller> port 0x440-0x45f irq 17 at
    device 31.3 on pci0
    smbus0: <System Management Bus> on ichsmb0
    smb0: <SMBus generic I/O> on smbus0
    atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
    atkbd0: <AT Keyboard> irq 1 on atkbdc0
    atkbd: unable to set the command byte.
    kbd0 at atkbd0
    sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on
    acpi0
    sio0: type 16550A
    orm0: <ISA Option ROMs> at iomem 0xcb000-0xcefff,0xc0000-0xcafff on isa0
    pmtimer0 on isa0
    sc0: <System console> at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    Timecounters tick every 1.000 msec
    ipfw2 initialized, divert enabled, rule-based forwarding enabled, default
    to accept, logging limited to 100 packets/entry by default
    acd0: DVDROM <DV-18E/2.0D> at ata0-master UDMA33
    Waiting 8 seconds for SCSI devices to settle
    Interrupt storm detected on "irq16: bge0 bge1+"; throttling interrupt
    source
    ses0 at mpt0 bus 0 target 8 lun 0
    ses0: <IBM 25P3495a S320 1 1> Fixed Processor SCSI-2 device
    ses0: 3.300MB/s transfers
    ses0: SAF-TE Compliant Device
    pt0 at mpt0 bus 0 target 8 lun 0
    pt0: <IBM 25P3495a S320 1 1> Fixed Processor SCSI-2 device
    pt0: 3.300MB/s transfers
    da0 at mpt0 bus 0 target 0 lun 0
    da0: <LSILOGIC 1030 IM IM 1000> Fixed Direct Access SCSI-2 device
    da0: 320.000MB/s transfers (160.000MHz, offset 127, 16bit), Tagged Queueing
    Enabled
    da0: 34678MB (71020544 512 byte sectors: 255H 63S/T 4420C)
    SMP: AP CPU #1 Launched!
    Mounting root from ufs:/dev/da0s1a

    Best regards
    --
    EMIT-RIPN, EVM7-RIPE
    Eugene Guest

  2. #2

    Default Re: IBM eServer 346 ServeRaid is too slow

    Hi Eugene,

    Eugene Mitrofanov wrote:
     
    I'd say you are seeing the same as I am with the same card in a Dell
    1855. There is something wrong with the mpt driver and the disks when
    they are setup in a raid0 set. If you split the disks and use them as
    individual drives then you will get full performance.


    Carl.

    Carl Guest

  3. #3

    Default Re: IBM eServer 346 ServeRaid is too slow

    On Thu, 7 Apr 2005, Carl Makin wrote: 

    It's also a known problem, though not being tracked very well.

    http://lists.freebsd.org/pipermail/freebsd-scsi/2004-December/001577.html
    http://lists.freebsd.org/pipermail/freebsd-scsi/2004-December/001578.html

    Doesn't look like (from viewcvs.cgi) there's been any recent work on
    this.

    Brian
    Brian Guest

  4. #4

    Default Re: IBM eServer 346 ServeRaid is too slow

    In the future, don't cross post -questions and other lists. I'm
    leaving the cc: on since we may have people watching the thread,
    but please remove -questions for any followups. Thanks.

    On Thu, 7 Apr 2005, Brian Behlendorf wrote:
     
    >
    > It's also a known problem, though not being tracked very well.
    >
    > http://lists.freebsd.org/pipermail/freebsd-scsi/2004-December/001577.html
    > http://lists.freebsd.org/pipermail/freebsd-scsi/2004-December/001578.html
    >
    > Doesn't look like (from viewcvs.cgi) there's been any recent work on
    > this.[/ref]

    We're waiting on a driver update that is tied up in legalities at the
    moment.

    --
    Doug White | FreeBSD: The Power to Serve
    com | www.FreeBSD.org
    Doug Guest

Similar Threads

  1. 7.0.8 on OS X 10.4.6 Slow?
    By David_E._S._Stein@adobeforums.com in forum Adobe Acrobat Macintosh
    Replies: 2
    Last Post: July 31st, 06:47 PM
  2. Slow printing on fast copier but fast printing on slow printer!
    By Davie_Helms@adobeforums.com in forum Adobe Acrobat Windows
    Replies: 0
    Last Post: May 7th, 08:24 PM
  3. SLOW DOWN..Why is my Photoshop CS Super Slow in PANTHER?
    By Aerosyn-Lex@adobeforums.com in forum Adobe Photoshop Mac CS, CS2 & CS3
    Replies: 4
    Last Post: February 23rd, 10:42 PM
  4. Replies: 0
    Last Post: July 7th, 07:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139