Professional Web Applications Themes

Incoming connections hanging - Linux Setup, Configuration & Administration

My RH8.0 box is not responding to incoming connections (though it can open outbound connections without trouble). When I try to connect from another computer (IP 10.0.0.1), the connection is refused. What sort of things should I look for in terms of enabling it to talk to the outside world? * /etc/hosts.allow has 10.0.0.1:ALL, * /etc/hosts.deny has ALL:ALL * Taking Portsentry from -atcp to -tcp made no observable change. * When I installed Linux, I specified a high security firewall. What should I look at to let my box talk with the outside world? ++ Jonathan Hayward, [email]jonathan.haywardpobox.com[/email] ** To ...

  1. #1

    Default Incoming connections hanging

    My RH8.0 box is not responding to incoming connections (though it can
    open outbound connections without trouble). When I try to connect from
    another computer (IP 10.0.0.1), the connection is refused. What sort
    of things should I look for in terms of enabling it to talk to the
    outside world?

    * /etc/hosts.allow has 10.0.0.1:ALL,
    * /etc/hosts.deny has ALL:ALL
    * Taking Portsentry from -atcp to -tcp made no observable change.
    * When I installed Linux, I specified a high security firewall.

    What should I look at to let my box talk with the outside world?

    ++ Jonathan Hayward, [email]jonathan.haywardpobox.com[/email]
    ** To see an award-winning website with stories, essays, artwork,
    ** games, and a four-dimensional maze, why not visit my home page?
    ** All of this is waiting for you at [url]http://JonathansCorner.com[/url]
    Jonathan Hayward Guest

  2. #2

    Default Re: Incoming connections hanging

    Jonathan Hayward wrote:
    > My RH8.0 box is not responding to incoming connections (though it can
    > open outbound connections without trouble). When I try to connect from
    > another computer (IP 10.0.0.1), the connection is refused. What sort
    > of things should I look for in terms of enabling it to talk to the
    > outside world?
    >
    > * /etc/hosts.allow has 10.0.0.1:ALL,
    > * /etc/hosts.deny has ALL:ALL
    > * Taking Portsentry from -atcp to -tcp made no observable change.
    > * When I installed Linux, I specified a high security firewall.
    >
    > What should I look at to let my box talk with the outside world?
    >
    > ++ Jonathan Hayward, [email]jonathan.haywardpobox.com[/email]
    > ** To see an award-winning website with stories, essays, artwork,
    > ** games, and a four-dimensional maze, why not visit my home page?
    > ** All of this is waiting for you at [url]http://JonathansCorner.com[/url]
    Since the 10.0.0.0/8 is a private IP range (IANA) your system
    should accept connections from the internet on that IP range.

    Comment: This block is reserved for special purposes.
    Comment: Please see RFC 1918 for additional information.

    Only allow access to specific ports you want the world to have
    access to.

    --
    Confucius: He who play in root, eventually kill tree.
    Registered with The Linux Counter. [url]http://counter.li.org/[/url]
    Slackware 9.0 Kernel 2.4.22 i686 (GCC) 3.3
    Uptime: 5 days, 21:34, 1 user, load average: 1.12, 1.30, 1.35

    David Guest

  3. #3

    Default Re: Incoming connections hanging

    David wrote:
    > Jonathan Hayward wrote:
    >
    >> My RH8.0 box is not responding to incoming connections (though it can
    >> open outbound connections without trouble). When I try to connect from
    >> another computer (IP 10.0.0.1), the connection is refused. What sort
    >> of things should I look for in terms of enabling it to talk to the
    >> outside world?
    >>
    >> * /etc/hosts.allow has 10.0.0.1:ALL,
    >> * /etc/hosts.deny has ALL:ALL
    >> * Taking Portsentry from -atcp to -tcp made no observable change.
    >> * When I installed Linux, I specified a high security firewall.
    >>
    >> What should I look at to let my box talk with the outside world?
    >>
    >> ++ Jonathan Hayward, [email]jonathan.haywardpobox.com[/email]
    >> ** To see an award-winning website with stories, essays, artwork,
    >> ** games, and a four-dimensional maze, why not visit my home page?
    >> ** All of this is waiting for you at [url]http://JonathansCorner.com[/url]
    >
    >
    > Since the 10.0.0.0/8 is a private IP range (IANA) your system should
    > accept connections from the internet on that IP range.
    Ooops! that should read:
    Since the 10.0.0.0/8 is a private IP range (IANA) your system
    should not accept connections from the internet on that IP range.


    --
    Confucius: He who play in root, eventually kill tree.
    Registered with The Linux Counter. [url]http://counter.li.org/[/url]
    Slackware 9.0 Kernel 2.4.22 i686 (GCC) 3.3
    Uptime: 5 days, 21:49, 1 user, load average: 1.06, 1.22, 1.29

    David Guest

  4. #4

    Default Re: Incoming connections hanging

    David wrote:
    >
    > Since the 10.0.0.0/8 is a private IP range (IANA) your system should
    > accept connections from the internet on that IP range.
    Ooops! that should read:
    Since the 10.0.0.0/8 is a private IP range (IANA) your system
    should not accept connections from the internet on that IP range.

    --
    Confucius: He who play in root, eventually kill tree.
    Registered with The Linux Counter. [url]http://counter.li.org/[/url]
    Slackware 9.0 Kernel 2.4.22 i686 (GCC) 3.3
    Uptime: 5 days, 21:49, 1 user, load average: 1.06, 1.22, 1.29

    David Guest

  5. #5

    Default Re: Incoming connections hanging

    On Thu, 04 Sep 2003 at 23:48 GMT, David eloquently wrote:
    > Jonathan Hayward wrote:
    >> My RH8.0 box is not responding to incoming connections (though it can
    >> open outbound connections without trouble). When I try to connect from
    >> another computer (IP 10.0.0.1), the connection is refused. What sort
    >> of things should I look for in terms of enabling it to talk to the
    >> outside world?
    >>
    >> * /etc/hosts.allow has 10.0.0.1:ALL,
    >> * /etc/hosts.deny has ALL:ALL
    >> * Taking Portsentry from -atcp to -tcp made no observable change.
    >> * When I installed Linux, I specified a high security firewall.
    >>
    >> What should I look at to let my box talk with the outside world?
    [...]
    > Since the 10.0.0.0/8 is a private IP range (IANA) your system
    > should accept connections from the internet on that IP range.
    >
    > Comment: This block is reserved for special purposes.
    > Comment: Please see RFC 1918 for additional information.
    >
    > Only allow access to specific ports you want the world to have
    > access to.
    I saw your corrections but I think your assuption is wrong.
    I think the OP has a local lan. The OP should check his
    firewall, /etc/hosts.allow, /etc/hosts.deny...

    HTH.

    --
    Registered Linux User # 125653 ([url]http://counter.li.org[/url]) | Please remove
    Certified: 55% , 31% of which is tard. | '.invalid'
    [url]http://www.thespark.com/test[/url] | to reply.
    Switch to: [url]http://www.speakeasy.net/refer/190653[/url]
    ne... Guest

Similar Threads

  1. Setting up incoming dial up connections
    By NIck in forum Windows Server
    Replies: 2
    Last Post: July 2nd, 07:29 PM
  2. Win2003 server hanging at bootup at network connections
    By nyugati in forum Windows Server
    Replies: 4
    Last Post: June 22nd, 05:27 PM
  3. ASP and incoming mail
    By Phil in forum ASP
    Replies: 3
    Last Post: October 12th, 06:39 AM
  4. ICS for Incoming Connections clients, officially unsupported?
    By Zoltan Radnai in forum Windows Networking
    Replies: 0
    Last Post: July 17th, 04:37 AM
  5. OSR 5.0.7 MSTPPP incoming
    By Robert Brady in forum SCO
    Replies: 0
    Last Post: July 1st, 11:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139