Professional Web Applications Themes

Install CF8.01 on Windows Server 2008 64bits - Coldfusion Server Administration

Hello, I have a new machine whith Windows server 2008 x64 and i installed on it CF8.01. For installing, no problems and the service work fine. But, when i launch one page on the web server, not a .cfm but just a classic html the IIS 7 return a error 500.21 : HTTP Error 500.21 - Internal Server Error Handler "AboMapperCustom-26364" has a bad module "IsapiModule" in its module list Detailed Error InformationModule IIS Web Core Notification ExecuteRequestHandler Handler AboMapperCustom-26364 Error Code 0x8007000d Requested URL http://127.0.0.1:80/ Physical Path C:\inetpub\wwwroot Logon Method Anonymous Logon User Anonymous In IIS config panel, handlers ...

  1. #1

    Default Install CF8.01 on Windows Server 2008 64bits

    Hello,

    I have a new machine whith Windows server 2008 x64 and i installed on it
    CF8.01.
    For installing, no problems and the service work fine.
    But, when i launch one page on the web server, not a .cfm but just a classic
    html the IIS 7 return a error 500.21 :

    HTTP Error 500.21 - Internal Server Error
    Handler "AboMapperCustom-26364" has a bad module "IsapiModule" in its module
    list Detailed Error InformationModule IIS Web Core
    Notification ExecuteRequestHandler
    Handler AboMapperCustom-26364
    Error Code 0x8007000d
    Requested URL http://127.0.0.1:80/
    Physical Path C:\inetpub\wwwroot
    Logon Method Anonymous
    Logon User Anonymous

    In IIS config panel, handlers mapping, i have entry for all CF handler and one
    with path * and direct from jrun_iis6_wildcard.dll.

    the section of web config for handlers is :
    <handlers accessPolicy="Read, Script,Execute">
    <clear />
    <add name="AboMapperCustom-23790" path="*" verb="*"
    modules="IsapiModule"
    scriptProcessor="C:\ColdFusion8\runtime\lib\wsconf ig\1\jrun_iis6_wildcard.dll"
    requireAccess="None" responseBufferLimit="0" />
    <add name="AboMapperCustom-23791" path="*.jsp" verb="*"
    modules="IsapiModule"
    scriptProcessor="C:\ColdFusion8\runtime\lib\wsconf ig\jrun_iis6.dll"
    requireAccess="Script" responseBufferLimit="0" />
    <add name="AboMapperCustom-23792" path="*.jws" verb="*"
    modules="IsapiModule"
    scriptProcessor="C:\ColdFusion8\runtime\lib\wsconf ig\jrun_iis6.dll"
    requireAccess="Script" responseBufferLimit="0" />
    <add name="AboMapperCustom-23793" path="*.cfm" verb="*"
    modules="IsapiModule"
    scriptProcessor="C:\ColdFusion8\runtime\lib\wsconf ig\jrun_iis6.dll"
    requireAccess="Script" responseBufferLimit="0" />
    <add name="AboMapperCustom-23794" path="*.cfml" verb="*"
    modules="IsapiModule"
    scriptProcessor="C:\ColdFusion8\runtime\lib\wsconf ig\jrun_iis6.dll"
    requireAccess="Script" responseBufferLimit="0" />
    <add name="AboMapperCustom-23795" path="*.cfc" verb="*"
    modules="IsapiModule"
    scriptProcessor="C:\ColdFusion8\runtime\lib\wsconf ig\jrun_iis6.dll"
    requireAccess="Script" responseBufferLimit="0" />
    <add name="AboMapperCustom-23796" path="*.cfr" verb="*"
    modules="IsapiModule"
    scriptProcessor="C:\ColdFusion8\runtime\lib\wsconf ig\jrun_iis6.dll"
    requireAccess="Script" responseBufferLimit="0" />
    <add name="AboMapperCustom-23797" path="*.cfswf" verb="*"
    modules="IsapiModule"
    scriptProcessor="C:\ColdFusion8\runtime\lib\wsconf ig\jrun_iis6.dll"
    requireAccess="Script" responseBufferLimit="0" />
    <add name="TRACEVerbHandler" path="*" verb="TRACE"
    modules="ProtocolSupportModule" requireAccess="None" />
    <add name="OPTIONSVerbHandler" path="*" verb="OPTIONS"
    modules="ProtocolSupportModule" requireAccess="None" />
    <add name="StaticFile" path="*" verb="*"
    modules="StaticFileModule,DefaultDoentModule" resourceType="Either"
    requireAccess="Read" />
    </handlers>
    and

    Application 32bits mode is ok
    <applicationPoolDefaults enable32BitAppOnWin64="true">
    <processModel identityType="NetworkService" />
    </applicationPoolDefaults>

    Have you an idea why the application server fail.
    Thanks for your responses.

    Seb


    sebFrance Guest

  2. #2

    Default Re: Install CF8.01 on Windows Server 2008 64bits

    Seb,
    I believe the issue is you have a 32 bit connector attached to 64 bit IIS.
    This should be easy to fix. Open a DOS window in \ColdFusion8\bin\connectors.
    Run remove_all_connectors.bat to get rid of your current connector. Edit
    IIS_connector.bat. The line that counts is:
    %CFUSION_HOME%\runtime\bin\wsconfig -server coldfusion -ws IIS -site 0
    -coldfusion -cfwebroot
    append to the end -ws64:
    %CFUSION_HOME%\runtime\bin\wsconfig -server coldfusion -ws IIS -site 0
    -coldfusion -cfwebroot -ws64
    Save the file and run. This will configure using 64 bit dlls for the
    connector. Also, the "-site 0" argument and value means the connector will be
    setup for all sites or at the global level. If you wanted a single site to be
    configured use its number or the name as a quoted string as, "default web site".

    ksmith Guest

  3. #3

    Default Re: Install CF8.01 on Windows Server 2008 64bits

    Hello ksmith,

    I took a full installation of the server by installing windows server 2008
    64bits and the role Web Server

    At first I did not installed the compatibility service.

    Then I downloaded the version CF8 8.01 "coldfusion-801-win.exe" on the server.

    I installed the version 8.01 with my Series Number and everything went well.

    I've changed my IIS_connector with:
    CFUSION_HOME%% \ runtime \ bin \ wsconfig-server IIS coldfusion-ws-site
    0-coldfusion-cfwebroot-ws64

    Then in launching a page of the admin I had an error 404.3.

    wsconfig of the saw not IIS.

    I installed the service IIS6 compatibility and revive wsconfig.

    I restarted the wsconfig and he found the IIS and configured.

    Despite the change that has not solved the problem.

    Is what I should not download a 64bits of CF8 and install it with my key to
    the standard version?

    Thanks again for your explanations.

    S?bastien



    sebFrance Guest

  4. #4

    Default Re: Install CF8.01 on Windows Server 2008 64bits

    You have to set the 64-bit IIS 7 to run 32-bit applications:

    To enable 32-bit applications on 64-bit IIS:

    In IIS Manager, select Application Pools.
    In the list of Application Pools, select the application pool you have configured for use with your site.
    In the Actions pane, select Advanced Settings under Edit Application Pool.
    Expand the General settings, set Enable 32-bit Applications to True, and click OK.

    Another way:

    http://tinyurl.com/5qfe7l

    The 64-bit version of ColdFusion for Windows is for the Enterprise Edition only

    --
    Ken Ford
    Adobe Community Expert - Dreamweaver/ColdFusion
    Fordwebs, LLC
    http://www.fordwebs.com


    "sebFrance" <com> wrote in message news:g1edah$646$macromedia.com... 
    Ken Guest

  5. #5

    Default Re: Install CF8.01 on Windows Server 2008 64bits

    Hello and thank you again,
    I configured Application Pools in 32bitsenabled.

    I had always error 500.21

    Then I uninstalled CF8 and reinstalled with 32bits enabled in the application
    pools.
    I've always the same mistake.

    It is also important to know that when I webserver config to remove the server
    I get an error:

    "Error deleting IIS application extensions. Jsp,. Jsw,. Cfm,. Cfml,. Cfc,.
    Cf.,. Cfswf,. Mxml, from web site Any (0)"

    In addition, handlers configured in the web site "AboMapperCustom-26764" with
    the isapi module for the "*" is the one that fails.

    East I forgot something:

    I recall the installation process complete server:

    Installing Windows Server 2008 64bits.
    ----
    Installing the Web server role with IIS7 :
    ----
    Common HHTP Features (All options)
    Health and diagnostics -> request monitor
    Security -> Request Filtering
    Performance -> Static content compression
    Managements tools (IIS Management Console + IIS6 Compatibility)
    ----
    Installing SQL server 2005 64bits
    ----
    Passage of the authorized application pools in 32-bit applications
    ----
    Installing CF8 version 8.01 standard 32bits
    ----
    Modifying files as indicated ksmith.
    ----
    For each phase I restart the machine so that changes are properly taken into
    account.

    Despite all this I have always error 500.21

    East I forgot some things, a service or a component that I should download.

    But thank you for your valuable advice.

    S?bastien



    sebFrance Guest

  6. #6

    Default Re: Install CF8.01 on Windows Server 2008 64bits

    I'm pretty sure Adobe offers free installation support, try contacting them:

    http://www.adobe.com/support/contact/

    --
    Ken Ford
    Adobe Community Expert - Dreamweaver/ColdFusion
    Fordwebs, LLC
    http://www.fordwebs.com


    "sebFrance" <com> wrote in message news:g1el1t$e2l$macromedia.com... 
    Ken Guest

  7. #7

    Default Re: Install CF8.01 on Windows Server 2008 64bits

    Thank you,

    But the problem is an error during installation, the support is therefore
    free, but I do not know if involved in the call center can solve the problem
    because it seems quite within the application and, after tried everything on
    the 32/64bits and IIS7 that the problem must come from "jrun_iis6_wildcard.dll"
    which is not written correctly or the call to this function is not effective.
    In any case tomorrow I try and the other concerns is the jetlag.
    In any case thank you very much for your help and of course I remain very
    optimistic and I am sure adobe find a solution. I'm an old developer using
    products Allaire, Macromedia and Adobe since the beginning and I've never been
    disappointed.

    Best regards
    Sébastien



    sebFrance Guest

  8. #8

    Default Re: Install CF8.01 on Windows Server 2008 64bits

    I am not sure this will help.

    Try to install the Coldfusion 8.0 first, and install the 8.01 update.

    I have similar problem when i try to install 8.01 to Vista IIS7, the 8.01
    installer doesn't seen to enable some of the IIS 7 optional options (eg
    ISAPIModule and IIS6 compatible), without these, the install 8.01 doesn't able
    create the coldfusion IIS application extension (eg. cfm, cfml).

    But if i use the 8.0 installer first, then I will able to see some addtional
    IIS options is turn on after installation.

    I also notice in the 8.0 installation, the install will freeze for few
    miniutes during one of the wizard screen (the screen before you select where is
    the wwwroot), i believe the cause of that is the installer is working on try to
    turn on those additional option.

    But this isn't happen in the 8.01 installation.

    Jeremy Guest

  9. #9

    Default Re: Install CF8.01 on Windows Server 2008 64bits

    Installation support is free. Please contact them for some direct support with this as KenF mentioned.
    ksmith Guest

  10. #10

    Default Re: Install CF8.01 on Windows Server 2008 64bits

    Hello everyone,

    Voila after numerous attempts, coldfusion is installed correctly.
    In fact you must install in the role of IIS7 enforcement whole with
    development. Net and other (ISAPI).
    These are services that do not put the installation in road and as the minimum
    service are not doented qu'adobe should make a paper with components and
    services necessary for the installation of CF8 that go well with Windows 2008
    server 32bits or 64bits.
    In all cases thank you to everyone for me very well directed and hope that
    this experience to serve others.
    Here I am again for another adventure.

    Best regards
    S?bastien


    sebFrance Guest

  11. #11

    Default Re: Install CF8.01 on Windows Server 2008 64bits

    I am not sure if this helps or not, but I was attempting to install CF8.01 on
    Vista today and ran into the same error. After a lot of research with no
    answer, I started over. I made sure IIS was working properly. I installed the
    standalone version and made sure CF worked. Then, I used the Web Configuration
    Tool to add CF8.01 to IIS. I received the same errors regarding the bad
    IsapiModule error. I went back and checked my IIS configuration. At the Web
    server root, the ISAPI module was installed, but when I checked the web site
    root, I found that the ISAPI module wasn't listed. I clicked the "Add Native
    Module" link and added the ISAPI Module. This solved the issue.

    thcase Guest

Similar Threads

  1. FDF Toolkit with Windows Server 2008 x64
    By Ricardo_Rollins@adobeforums.com in forum Adobe Acrobat SDK
    Replies: 0
    Last Post: December 26th, 01:34 PM
  2. Windows Server 2008
    By jnicholson in forum Macromedia Flash Flashcom
    Replies: 10
    Last Post: November 7th, 10:00 PM
  3. Contribute and Windows Server 2008 64-bit
    By wwwlord in forum Macromedia Contribute General Discussion
    Replies: 0
    Last Post: September 23rd, 03:09 PM
  4. Replies: 2
    Last Post: February 27th, 05:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139