i get the following error when i try to install HTML::Template to my
local space, ie, not as root:

+----------------------------
% perl -MCPAN -e 'install HTML::Template'
CPAN: Storable loaded ok
Going to read /home/bettyann/.cpan/Metadata
Database was generated on Sat, 24 Jul 2004 04:11:44 GMT
Running install for module HTML::Template
Running make for S/SA/SAMTREGAR/HTML-Template-2.7.tar.gz
CPAN: Digest::MD5 loaded ok
CPAN: Compress::Zlib loaded ok
Checksum for /home/bettyann/.cpan/sources/authors/id/S/SA/SAMTREGAR/HTML-Template-2.7.tar.gz
ok
Scanning cache /home/bettyann/.cpan/build for sizes
x HTML-Template-2.7, 0 bytes, 0 tape blocks
x HTML-Template-2.7/templates, 0 bytes, 0 tape blocks
[snip]
x HTML-Template-2.7/Template.pm, 115408 bytes, 226 tape blocks
x HTML-Template-2.7/ARTISTIC, 6111 bytes, 12 tape blocks

CPAN.pm: Going to build S/SA/SAMTREGAR/HTML-Template-2.7.tar.gz

Checking if your kit is complete...
Looks good
Writing Makefile for HTML::Template
cp Template.pm blib/lib/HTML/Template.pm
Manifying blib/man3/HTML::Template.3
/usr/local/bin/gmake -j3 -- OK
Running make test
PERL_DL_NONLAZY=1 /usr/local/bin/perl "-MExtUtils::Command::MM" "-e"
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/99-old-test-pl....ok 37/0HTML::Template::new() - Problem reading
cache file blib/temp_cache_dir/c2/97ba276ecd19a94dd2dbfadf4669ec
(file_cache => 1) : can't get shared lock on
blib/temp_cache_dir/c2/97ba276ecd19a94dd2dbfadf4669ec: Bad file number
at /home/bettyann/.cpan/build/HTML-Template-2.7/blib/lib/HTML/Template.pm
line 1343
at t/99-old-test-pl.t line 500
# Looks like your test died just after 37.
t/99-old-test-pl....dubious
Test returned status 255 (wstat 65280, 0xff00)
after all the subtests completed successfully
Failed Test Stat Wstat Total Fail Failed List of Failed
-------------------------------------------------------------------------------
t/99-old-test-pl.t 255 65280 37 0 0.00% ??
2 subtests skipped.
Failed 1/1 test scripts, 0.00% okay. 0/37 subtests failed, 100.00%
okay.
gmake: *** [test_dynamic] Error 2
/usr/local/bin/gmake test -- NOT OK
Running make install
make test had returned bad status, won't install without force
+----------------------------

i have installed six other modules with success so installing to my
local space works.

when i look at file blib/temp_cache_dir/c2/97ba276ecd19a94dd2dbfadf4669ec,
it seems to have some garbage in it, ie, it is not all ascii text as i
would expect an .html file to be:

% cat ./HTML-Template-2.7/blib/temp_cache_dir/c2/97ba276ecd19a94dd2dbfadf4669ec
pst0432:??HTML::Template::VAR adjective
F<HTML>
<HEAD>
<TITLE>
Simple Template
</TITLE>

any help with this problem is greatly appreciated. thanks. -bettyann