I tried to install FlashPlayer for Linux using the Macromedia installation
script file, but it failed
because your script is looking for both "plugins" and "components"
directories in the browser installation directory, but Fedora 3 only has
the plugins directory. The script fell out of the if/elif tree with an
"invalid" result. When I (as root) made an empty directory called
"components" in the /usr/lib/mozilla directory, where the plugins
subdirection is located, the script subsequently
installed successfully.

On this computer, I'm running a fairly pristine new installation of
Fedora Core 3 with all of the updates available at this moment from
Fedora's "Up2Date" server, using the default browser (Firefox 1.0.6).
Fedora 3 does not by default install the old Mozilla, although it uses
the /usr/lib/mozilla directory for Firefox (the executable binary installs
in /usr/bin/firefox). I suggest that Macromedia's programmers change the
installation script to
eliminate the "-a -d components" part, or look for firefox as a separate
logic branch and then just look for the plugins directory
in /usr/lib/mozilla or whatever directory the user enters at
installation.

As a workaround, I suggest users create the "components" directory in the same
directory as the plugins directory (that is, in /usr/lib/mozilla, if
installing as root), before
executing the Macromedia installation script file. Even easier is to just
copy the two flashplayer plugin files manually into the plugins directory, as
the
Macromedia README file explains. Both of these methods work, and FlashPlayer
then installs in a flash, so to speak.

I have not tried this on Fedora Core 4, which is the current release,
but I will. If the fix I suggest here would not solve the problem on
Fedora 4, I'll send you another suggestion.

Thanks for supporting Linux,

Stanley Sokolow