Professional Web Applications Themes

Invalid Gateway IPv4 Address Specified - FreeBSD

Hi, i'm installing FreeBSD on my desktop, almost everything went fine, except when i try to setup my connection. The scenario: a static-ip, a direct connection to a router (which i do NOT have ANY control over it) and a outside DNS server. When trying to enter the gateway ip (10.0.0.9) through sysinstall, a box appears on the screen: Invalid Gateway IPv4 Address Specified. And that's it. Therefore i've tried including defaultrouter="10.0.0.9" in /etc/rc.conf, and restarted net, my computer still excluded from outside world. Thanks....

  1. #1

    Default Invalid Gateway IPv4 Address Specified

    Hi, i'm installing FreeBSD on my desktop, almost everything went fine,
    except when i try to setup my connection.

    The scenario: a static-ip, a direct connection to a router (which i do
    NOT have ANY control over it) and a outside DNS server. When trying to
    enter the gateway ip (10.0.0.9) through sysinstall, a box appears on the
    screen: Invalid Gateway IPv4 Address Specified.

    And that's it. Therefore i've tried including defaultrouter="10.0.0.9"
    in /etc/rc.conf, and restarted net, my computer still excluded from
    outside world.

    Thanks.
    Augusto Guest

  2. #2

    Default Re: Invalid Gateway IPv4 Address Specified

    Augusto Cesar <com> wrote:
     

    What is your IP address/netmask? What's the output of 'netstat -rn'?

    Not enough information to be sure, but my first guess (based on the
    source code for sysinstall) is that you're specifying an IP for the
    gateway that is not reachable based on the IP/netmask for the interface.
    For example: If your IP/netmask is 172.16.0.1/255.255.255.0, then the
    system has no way to reach 10.0.0.9.

    If that's not the problem, the I suggest collecting some more detailed
    information and posting again.

    --
    Bill Moran
    Potential Technologies
    http://www.potentialtech.com
    Bill Guest

  3. #3

    Default Re: Invalid Gateway IPv4 Address Specified

    Bill Moran wrote:
     
    The netmask was the problem, thanks!
    Shame on me for not thinking of it.
    Augusto Guest

Similar Threads

  1. #39846 [NEW]: Invalid IPv4 treated as valid
    By webvelosix at yahoo dot com in forum PHP Bugs
    Replies: 2
    Last Post: December 16th, 09:48 PM
  2. Invalid IP address 0.0.0.0 and error 1068
    By jetcargo in forum Windows Networking
    Replies: 2
    Last Post: July 29th, 05:09 PM
  3. Solaris 8 mmap returns an invalid address in 64-bit code
    By Philip Willoughby in forum Sun Solaris
    Replies: 8
    Last Post: July 26th, 12:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139