I'm running ColdFusion MX 6.1 Developer Edition (J2EE configuration w/ JRun)
with the built-in web server (JRun Web Server) on Windows XP Pro. I'm trying
to place my webroot on a network drive and I'm running into what I belive to be
a permissions problem. I've modified my
Jrun4/servers/cfusion/cfusion-ear/cfusion-war/WEB-INF/jrun-web.xml file to
include a virtual mapping for '/*' according to Macromedia Technote
[url]http://www.macromedia.com/go/tn_19400[/url] (see attached). This works fine if I run
CF as a process (started from the command line using 'jrun -start cfusion') but
not as a Windows service (get 404 error). I've configured the service to run
with my credentials instead of the system account but that didn't work either
(same error). If I remove the virtual mapping from jrun-web.xml and run CF as
a service, I have no problem reading files from the network share using cffile
which leads me to believe the problem is with the JRun Web Server. Is there a
way to get this to work while running CF as a service?


<virtual-mapping>
<resource-path>/*</resource-path>
<system-path>p:/web</system-path>
</virtual-mapping>