Professional Web Applications Themes

kbd_mode - Linux / Unix Administration

On our UNIX workstation we have a problem with keyboard setting regularly, ie. keboard prints strange characters. I must login as root as give kbd_mode -a >/dev/console to set it right. How can I solve this problem. Irfian...

  1. #1

    Default kbd_mode

    On our UNIX workstation we have a problem with keyboard setting
    regularly, ie. keboard prints strange characters.
    I must login as root as give
    kbd_mode -a >/dev/console
    to set it right.
    How can I solve this problem.

    Irfian
    Irfian Guest

  2. #2

    Default Re: kbd_mode

    Irfian <irfian> wrote:
    > On our UNIX workstation we have a problem with keyboard setting
    > regularly, ie. keboard prints strange characters.
    > I must login as root as give
    > kbd_mode -a >/dev/console
    > to set it right.
    > How can I solve this problem.
    What type of unix ? What keyboard ( = language) are used ?
    > Irfian
    --
    Peter Håkanson
    IPSec Sverige ( At Gothenburg Riverside )
    Sorry about my e-mail address, but i'm trying to keep spam out,
    remove "icke-reklam" if you feel for mailing me. Thanx.
    phn@icke-reklam.ipsec.nu Guest

  3. #3

    Default Re: kbd_mode

    We have SunOS 5.8 machine Sun-Blade-100, english keyboard on this machine.


    [email]phnicke-reklam.ipsec.nu[/email] wrote in message news:<catrsu$oum$1nyheter.ipsec.se>...
    > Irfian <irfian> wrote:
    > > On our UNIX workstation we have a problem with keyboard setting
    > > regularly, ie. keboard prints strange characters.
    > > I must login as root as give
    > > kbd_mode -a >/dev/console
    > > to set it right.
    > > How can I solve this problem.
    >
    > What type of unix ? What keyboard ( = language) are used ?
    >
    > > Irfian
    Irfian Guest

  4. #4

    Default Re: kbd_mode

    Irfian wrote:
    >
    > On our UNIX workstation we have a problem with keyboard setting
    > regularly, ie. keboard prints strange characters.
    > I must login as root as give
    > kbd_mode -a >/dev/console
    > to set it right.
    > How can I solve this problem.
    Running X windows can put your keyboard in event mode so each key
    triggers an X event that can be mapped to any character set and
    to any window.

    If you never run a windowing system on the console keyboard, it
    should never go into event mode. If you run a windowing system
    on it the windowing system has to exit gracefully. Most likely
    something is killing CDE.
    Doug Freyburger Guest

  5. #5

    Default Re: kbd_mode

    Hi Doug,
    I am not sure if the CDE is the problem, as on other UNIX machines (we
    have around 30 more SUN machines) we do not have such a problem.
    After enetering the kbd_mode -a >/dev/console command, one can log in
    and use. Also exiting is not a problem !! Strangely this problem
    appears once in a while on a particular machine.
    Irfian


    [email]dfreybur[/email] (Doug Freyburger) wrote in message news:<7960d3ee.0406181115.725e3412posting.google. com>...
    > Irfian wrote:
    > >
    > > On our UNIX workstation we have a problem with keyboard setting
    > > regularly, ie. keboard prints strange characters.
    > > I must login as root as give
    > > kbd_mode -a >/dev/console
    > > to set it right.
    > > How can I solve this problem.
    >
    > Running X windows can put your keyboard in event mode so each key
    > triggers an X event that can be mapped to any character set and
    > to any window.
    >
    > If you never run a windowing system on the console keyboard, it
    > should never go into event mode. If you run a windowing system
    > on it the windowing system has to exit gracefully. Most likely
    > something is killing CDE.
    Irfian Guest

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139