Professional Web Applications Themes

Language change alters line endings - Adobe Indesign Macintosh

In InDesign CS2 version 4.0.2, changing the language of a text block alters the line endings. In one doent, for example, switching from "No Language" to "English USA" in a text block hyphenates/breaks a word on a line that hadn't been hyphenated previously. Why does it do this, and how can we stop it? This behavior is causing our copy editors quite a bit of grief; if they somehow forget to apply a language, they either have forego a spell check (or spell check a copy of the doent) or risk changing all of the line endings at a critical ...

  1. #1

    Default Language change alters line endings

    In InDesign CS2 version 4.0.2, changing the language of a text block alters the line endings. In one doent, for example, switching from "No Language" to "English USA" in a text block hyphenates/breaks a word on a line that hadn't been hyphenated previously. Why does it do this, and how can we stop it? This behavior is causing our copy editors quite a bit of grief; if they somehow forget to apply a language, they either have forego a spell check (or spell check a copy of the doent) or risk changing all of the line endings at a critical stage of production.

    FWIW, we're using Macs and OS X 10.4.6.

    Thanks,
    Kevin
    Kevin_R._Stauffer@adobeforums.com Guest

  2. #2

    Default Re: Language change alters line endings

    Are you using paragraph styles? If so, just switch off hyphenation. But if you are, how come the language is getting ed up in the first place?

    Dave
    Dave_Saunders@adobeforums.com Guest

  3. #3

    Default Re: Language change alters line endings

    You could try switching to the single line composer but you're still
    likely going to have a problem.

    It's important to note that the problem is not with InDesign which is
    doing exactly as it's told...hyphenating text based on the language
    you've assigned...but with your workflow.

    Besides turning off hyphenation altogether, I don't think there's any
    perfect solution.

    Bob
    Bob Levine Guest

  4. #4

    Default Re: Language change alters line endings

    "No Language" actually means "do not hyphenate".
    That is what this setting is for.
    As soon as you apply a language and have "Hyphenation" set to on in the paragraph-palette you will get hyphenation.

    This is as it should be.

    Educate your editors.
    Work with templates that have the correct language set.
    Turn on Dynamic Spell Check by default. (No red squiggles -> no language)
    Gerald_Singelmann@adobeforums.com Guest

  5. #5

    Default Re: Language change alters line endings

    > (No red squiggles -> no language)

    Or no mistakes. <G>

    Bob
    Bob Levine Guest

  6. #6

    Default Re: Language change alters line endings

    Thank you for the quick and insightful responses, and in particular for pointing out the connection between language and hyphenation in InDesign. For us, education and a review of our templates sounds like a good strategy.
    Kevin
    Kevin_R._Stauffer@adobeforums.com Guest

Similar Threads

  1. Help! My line endings change when I create a PDF . . . why?
    By Sara_Temby@adobeforums.com in forum Adobe Acrobat Macintosh
    Replies: 10
    Last Post: January 23rd, 07:56 AM
  2. Forced line break changes previous line endings
    By Olav_Kvern@adobeforums.com in forum Adobe Indesign Macintosh
    Replies: 12
    Last Post: September 8th, 01:11 AM
  3. Change language interface
    By Mouchi webforumsuser@macromedia.com in forum Macromedia Freehand
    Replies: 1
    Last Post: February 20th, 08:19 PM
  4. change WIN XP language
    By Walter Clayton in forum Windows XP/2000/ME
    Replies: 4
    Last Post: July 18th, 10:33 PM
  5. Can i change language on my OS
    By Rob Tween in forum Windows XP/2000/ME
    Replies: 1
    Last Post: July 7th, 08:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139