Professional Web Applications Themes

LILO and my MBR - Linux Setup, Configuration & Administration

I have a dual-boot system running XP on one partition and Linux (Mandrake 9.0) on the other. Originally I was just running XP. Then I partitioned using PartitionMagic 8.0, which came with BootMagic 8.0. BootMagic required me to use up another primary partition, but I got it all set up and all was good. I installed Linux onto my second partition, and the next time I booted up, BootMagic was gone and Lilo in its place. Not a big deal at first--I like Lilo just fine, (or at least would if I weren't too lazy to configure it properly). But ...

  1. #1

    Default LILO and my MBR

    I have a dual-boot system running XP on one partition and Linux
    (Mandrake 9.0) on the other.

    Originally I was just running XP. Then I partitioned using
    PartitionMagic 8.0, which came with BootMagic 8.0. BootMagic required me
    to use up another primary partition, but I got it all set up and all was
    good. I installed Linux onto my second partition, and the next time I
    booted up, BootMagic was gone and Lilo in its place.

    Not a big deal at first--I like Lilo just fine, (or at least would if I
    weren't too lazy to configure it properly). But BootMagic took its
    replacement pretty hard I guess (;)) and now I can't even open it in
    Windows or uninstall it (maybe because half of it is sitting on its own
    partition?)

    I've been ignoring the problem rather successfully for what must be
    months now, but lately I've been thinking I'd like to try another Linux
    distro. If I uninstall Mandrake, though, it'll uninstall Lilo with it
    and I'll have nothing in my MBR. I fear the chaos that will follow so
    before I uninstall Mandrake I'd like to get BootMagic working again, or
    even just the Windows default (although I honestly can't find any
    Windows start disks with fdisk on them lying around).

    Not specifically a Linux problem but I was hoping there'd be some other
    folks dual booting around here that might be able to help me out.

    Thanks in advance!

    --
    -Jill S. <JAWS>

    "Somewhere on this globe, every ten seconds, there is a woman giving
    birth to a child. She must be found and stopped."
    Sam Levenson (1911 - 1980)

    einstein.rr.com -- remove the scientist to contact me.

    Jill Guest

  2. #2

    Default Re: LILO and my MBR

    Jill S. wrote:
     

    To get the XP boot back, find the CD and boot it. You will have a chance
    to type recover or rescue, it is one of those but don't remember now.
    You may be ask what drive to boot into, if you have dual boot Windows,
    then asked for the Admin password. You will get a dos prompt. Type
    FIXMBR or HELP. You can take if from there. It works, done it many
    times.
    --
    robert - redhat & slackware

    reh Guest

  3. #3

    Default Re: LILO and my MBR

    On Sun, 09 Nov 2003 23:51:57 GMT,
    Jill S. <einstein.rr.com> wrote: 

    You don't typically uninstall a distro. You select the partition when
    installing the new distro and have it format the partition before
    installing.

    Just setup Lilo again when you install the new distro. If you get stuck
    in between for XP, run the recovery console from your XP CD. FIXMBR.

    Or fdisk /mbr from most windows boot disks, or install CDs.

    Michael C.
    --
    com http://mcsuper5.freeshell.org/
    Registered Linux User #303915 http://counter.li.org/


    Michael Guest

Similar Threads

  1. lilo and win 2k
    By sridhar in forum Linux Setup, Configuration & Administration
    Replies: 4
    Last Post: October 27th, 07:57 AM
  2. LILO vs grub
    By Timothy in forum Linux Setup, Configuration & Administration
    Replies: 14
    Last Post: October 10th, 03:16 PM
  3. lilo + raid1
    By Roger in forum Linux Setup, Configuration & Administration
    Replies: 3
    Last Post: October 3rd, 03:23 PM
  4. Booting 2nd HDD from Lilo
    By Darsin in forum Linux Setup, Configuration & Administration
    Replies: 5
    Last Post: August 15th, 07:33 AM
  5. Lilo Problems
    By Jefferson Cowart in forum Debian
    Replies: 7
    Last Post: August 12th, 05:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139