Professional Web Applications Themes

LOCALE with Knoppix - Linux Setup, Configuration & Administration

I am running Knoppix with KDE. I have set KDE to have Austalian language, etc, and these details are correct, but the LOCALE command shows that everything is set to "C". Dates are in U.S. format, while Oz uses British. The problem may be that Aus is not supplied with Knoppix. Can I download it with apt-get? What do I tell it to download? Doug. -- Registered Linux user No. 277548. Linux: in a world without fences, who needs Gates?...

  1. #1

    Default LOCALE with Knoppix

    I am running Knoppix with KDE. I have set KDE to have Austalian language,
    etc, and these details are correct, but the LOCALE command shows that
    everything is set to "C". Dates are in U.S. format, while Oz uses British.
    The problem may be that Aus is not supplied with Knoppix. Can I download it
    with apt-get? What do I tell it to download?

    Doug.
    --
    Registered Linux user No. 277548.
    Linux: in a world without fences, who needs Gates?
    Doug Laidlaw Guest

  2. #2

    Default Re: LOCALE with Knoppix

    In article <ksrkv-mi2.ln1dougshost.mydomain.org.au>, Doug Laidlaw wrote:
    > Doug Laidlaw wrote:
    >
    >> I am running Knoppix with KDE. I have set KDE to have Austalian language,
    >> etc, and these details are correct, but the LOCALE command shows that
    >> everything is set to "C". Dates are in U.S. format, while Oz uses
    >> British. The problem may be that Aus is not supplied with Knoppix. Can I
    >> download it
    >> with apt-get? What do I tell it to download?
    >>
    >> Doug.
    > Took my own advice and googled. Found the Chinese Debian setup instructions
    > in English (if that doesn't sound too Irish.) Downloaded the locales, but
    > the only WM I have in Knoppix is KDE. The locale command still shows the
    > default, "C". Can I set it outside KDE?
    I'm at work (on a RH machine), so I cannot easily check. But Debian has
    'localeconf' or some such. Perhaps Knoppix has it too. Also, you can try
    'dpkg-reconfigure locales'.

    --
    Juha Siltala
    Juha Kustaa Siltala Guest

  3. #3

    Default Re: LOCALE with Knoppix

    Doug Laidlaw wrote:
    > I am running Knoppix with KDE. I have set KDE to have Austalian language,
    > etc, and these details are correct, but the LOCALE command shows that
    > everything is set to "C". Dates are in U.S. format, while Oz uses
    > British. The problem may be that Aus is not supplied with Knoppix. Can I
    > download it
    > with apt-get? What do I tell it to download?
    >
    > Doug.
    Took my own advice and googled. Found the Chinese Debian setup instructions
    in English (if that doesn't sound too Irish.) Downloaded the locales, but
    the only WM I have in Knoppix is KDE. The locale command still shows the
    default, "C". Can I set it outside KDE?

    Doug.
    --
    Registered Linux user No. 277548.
    Linux: in a world without fences, who needs Gates?
    Doug Laidlaw Guest

Similar Threads

  1. Locale-Codes 2.07
    By Neil Bowers in forum PERL Modules
    Replies: 0
    Last Post: June 11th, 09:42 AM
  2. [PHP-DEV] Locale
    By Wojtek Meler in forum PHP Development
    Replies: 0
    Last Post: September 3rd, 09:04 AM
  3. Install Knoppix 3.1
    By Andreas Janssen in forum Linux Setup, Configuration & Administration
    Replies: 4
    Last Post: August 23rd, 01:00 AM
  4. PHP and my locale
    By Joozju in forum PHP Development
    Replies: 0
    Last Post: July 8th, 08:14 PM
  5. Enable x-servers access on Knoppix
    By mjt in forum Linux Setup, Configuration & Administration
    Replies: 2
    Last Post: July 1st, 04:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139