Professional Web Applications Themes

logging proftpd question - FreeBSD

Presently all my proftpd logging goes to /var/log/messages but it is clogging that file because I have an ftp login every couple of minutes. I want to redirect proftpd logging. I tried putting proftpd:* /var/log/proftpd.log in my /etc/syslog.conf but syslogd complains; syslogd: unknown facility name "proftpd" looking at the man page for proftpd is says; Each successful and failed ftp(1) session is logged using syslog with a facility of LOG_FTP. Note: LOG_FTP messages are not displayed by sys- logd(8) by default, and may have to be enabled in syslogd(8)'s configu- ration file. So I tried; LOG_FTP:* /var/log/proftpd.log still no go. ...

  1. #1

    Default logging proftpd question

    Presently all my proftpd logging goes to /var/log/messages but
    it is clogging that file because I have an ftp login every couple of
    minutes. I want to redirect proftpd logging. I tried putting

    proftpd:* /var/log/proftpd.log

    in my /etc/syslog.conf

    but syslogd complains;
    syslogd: unknown facility name "proftpd"

    looking at the man page for proftpd is says;

    Each successful and failed ftp(1) session is logged using syslog with a
    facility of LOG_FTP. Note: LOG_FTP messages are not displayed by sys-
    logd(8) by default, and may have to be enabled in syslogd(8)'s configu-
    ration file.


    So I tried;

    LOG_FTP:* /var/log/proftpd.log

    still no go.

    I am unfamiliar with logging. Can someone help me along here?

    --
    David Banning Guest

  2. #2

    Default Re: logging proftpd question

    On Tue, Feb 22, 2005 at 01:35:25AM -0500, David Banning wrote:
    > Presently all my proftpd logging goes to /var/log/messages but
    > it is clogging that file because I have an ftp login every couple of
    > minutes. I want to redirect proftpd logging. I tried putting
    >
    > proftpd:* /var/log/proftpd.log
    >
    > in my /etc/syslog.conf
    >
    > but syslogd complains;
    > syslogd: unknown facility name "proftpd"
    >
    > looking at the man page for proftpd is says;
    >
    > Each successful and failed ftp(1) session is logged using syslog with a
    > facility of LOG_FTP. Note: LOG_FTP messages are not displayed by sys-
    > logd(8) by default, and may have to be enabled in syslogd(8)'s configu-
    > ration file.
    >
    >
    > So I tried;
    >
    > LOG_FTP:* /var/log/proftpd.log
    >
    > still no go.
    >
    > I am unfamiliar with logging. Can someone help me along here?
    >
    > --
    $ man syslog.conf
    <snip>
    The facility describes the part of the system generating the message, and
    is one of the following keywords: auth, authpriv, console, cron, daemon,
    ftp, kern, lpr, mail, mark, news, ntp, security, syslog, user, uucp and
    local0 through local7. These keywords (with the exception of mark) cor-
    respond to similar ``LOG_'' values specified to the openlog(3) and
    syslog(3) library routines.
    <snip>

    I believe the syntax you want is

    ftp.* /var/log/proftpd.log

    Make sure the logfile exists (and is writable),
    otherwise I think syslog will complain.

    - James Cook
    [email]james.cookutoronto.ca[/email]
    James Alexander Cook Guest

  3. #3

    Default Re: logging proftpd question

    > I believe the syntax you want is
    >
    > ftp.* /var/log/proftpd.log
    >
    > Make sure the logfile exists (and is writable),
    > otherwise I think syslog will complain.
    Thanks, fellow Torontonian, for your reply.

    I tried your suggestion previous to my posting, with no result.

    Now, could something in the;


    I tried your suggestion previous to my posting, with no result. I
    also did a "touch /var/log/proftpd.log" and "chmod 600
    /var/log/proftpd.log"

    The line;

    *.notice;kern.debug;lpr.info;mail.crit;news.err /var/log/messages

    is what is grabbing the messages I want to redirect. (I beleive *.notice)

    I just wonder if the line I just mention takes the log entry, if another
    can still take it. Can a log entry only be logged once? Or can you have
    it go to multiply files? (via multiple syslog.conf entries)

    It sure would be easier if in the log entry it said "ftp.notice" or
    some such thing so you -know- how it is being directed.

    I have tried running syslog with -d and -vv and there seems to be no
    indication what the facility name that is used.


    --
    David Banning Guest

  4. #4

    Default Re: logging proftpd question

    On Tue, Feb 22, 2005 at 02:31:03PM -0500, David Banning wrote:
    > > I believe the syntax you want is
    > >
    > > ftp.* /var/log/proftpd.log
    > >
    > > Make sure the logfile exists (and is writable),
    > > otherwise I think syslog will complain.
    >
    > Thanks, fellow Torontonian, for your reply.
    >
    > I tried your suggestion previous to my posting, with no result.
    >
    > Now, could something in the;
    >
    >
    > I tried your suggestion previous to my posting, with no result. I
    > also did a "touch /var/log/proftpd.log" and "chmod 600
    > /var/log/proftpd.log"
    >
    > The line;
    >
    > *.notice;kern.debug;lpr.info;mail.crit;news.err /var/log/messages
    >
    > is what is grabbing the messages I want to redirect. (I beleive *.notice)
    >
    > I just wonder if the line I just mention takes the log entry, if another
    > can still take it. Can a log entry only be logged once? Or can you have
    > it go to multiply files? (via multiple syslog.conf entries)
    I'm pretty sure a log entry can go to as many files as you want. For example,
    my syslog.conf file currently has

    *.err;kern.debug;auth.notice;mail.crit /dev/console
    *.notice;authpriv.none;kern.debug;lpr.info;mail.cr it;news.err /var/log/messages
    security.* /var/log/security
    auth.info;authpriv.info /var/log/auth.log
    mail.info /var/log/maillog
    lpr.info /var/log/lpd-errs
    ftp.info /var/log/xferlog
    cron.* /var/log/cron
    *.=debug /var/log/debug.log
    *.emerg *
    *.* /var/log/all.log
    !startslip
    *.* /var/log/slip.log
    !ppp
    *.* /var/log/ppp.log

    All of my log messages end up in /var/log/all.log, even though they're also put in /var/log/messages.

    The only thing I can think of is that you might have a program or hostname
    specification that's messing things up (any line starting with !, #!, + or +!).
    Anything following such a line will only apply to certain things; for example,
    the only things that end up in /var/log/ppp.log in my configuration are
    ppp-related messages (even though the ppp.log line starts with *.*).

    That's all I can think of, anyway. I never touched my syslog.conf file before
    a few days ago, so I'm hardly an authority.
    >
    > It sure would be easier if in the log entry it said "ftp.notice" or
    > some such thing so you -know- how it is being directed.
    >
    > I have tried running syslog with -d and -vv and there seems to be no
    > indication what the facility name that is used.
    >
    - James Cook
    [email]james.cookutoronto.ca[/email]
    James Alexander Cook Guest

Similar Threads

  1. Logging Settings Question
    By cfsmith in forum Coldfusion Server Administration
    Replies: 0
    Last Post: February 23rd, 06:44 PM
  2. Logging question
    By Madison Kelly in forum PostgreSQL / PGSQL
    Replies: 12
    Last Post: January 18th, 02:00 PM
  3. Proftpd errors
    By Jeremy McMasters in forum Linux / Unix Administration
    Replies: 2
    Last Post: March 2nd, 01:42 PM
  4. proftpd and NIS... HELP
    By Luca Miselli in forum Sun Solaris
    Replies: 3
    Last Post: August 6th, 12:14 PM
  5. proftpd configuration problem
    By Jander in forum Linux Setup, Configuration & Administration
    Replies: 0
    Last Post: July 23rd, 02:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139