Professional Web Applications Themes

Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON' - ASP Database

From what I can tell by looking through the responses this appears to be a general problem that often results in general responses. To help anyone who wishes to provide assistance, I will provide as much information as possible: Webserver: W2K Server, IIS 5.0, ASP not ASPX, Share Point/FP Extensions 2002 SQL 2000: On SBS2003 server DSN on W2K Server tests fine. I have tried multiple resolutions including adding the IUSR_(computername of my web server) as well as addressing the SBS2003 server directly and still I cannot connect. I am using DSN's for Access just fine. This does appear to ...

  1. #1

    Default Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

    From what I can tell by looking through the responses this appears to be a
    general problem that often results in general responses. To help anyone who
    wishes to provide assistance, I will provide as much information as possible:

    Webserver: W2K Server, IIS 5.0, ASP not ASPX, Share Point/FP Extensions 2002
    SQL 2000: On SBS2003 server
    DSN on W2K Server tests fine.

    I have tried multiple resolutions including adding the IUSR_(computername of
    my web server) as well as addressing the SBS2003 server directly and still I
    cannot connect. I am using DSN's for Access just fine. This does appear to be
    a communication problem between SQL2000 and the W2K server et al.

    I have reviewed all the suggestions provided on this board and many of them
    were found by searching MSDN directly. However, the most promising ones
    including those offered here clearly state that they are for NT server and
    not W2k Server.

    I would really appreciate if someone could point me in the right direction
    on this one.

    FYI: I am able to access the database from a workstation using the
    management console and update the database from VB. Clearly this is strictly
    a problem with IIS 5/ASP/SQL2000 and I believe that is is related to
    differences in authentication between W2k and SBS2003.

    None of the suggestions provided have worked so far but this may be due to a
    lack of understanding on my part. Thanks in advance.
    --
    Ralph E. Outcalt, Jr.
    REO Visual
    http://www.reovisual.com
    Ralph Guest

  2. #2

    Default Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

    Have you looked at this article?

    http://www.aspfaq.com/show.asp?id=2009 - 80004005 errors

    Bob Barrows

    Ralph O. wrote: 

    --
    Microsoft MVP - ASP/ASP.NET
    Please reply to the newsgroup. This email account is my spam trap so I
    don't check it very often. If you must reply off-line, then remove the
    "NO SPAM"


    Bob Guest

  3. #3

    Default Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

    Thanks Bob,

    I have not seen it before but on first glance there seems a wealth of
    informaiton. It will take me some time to sort it all out but I will get back
    when it works or I have not been able to get it to work. One promising idea
    is to connect by using ODBC instead of DSN. I will be looking into this one.

    Ralph

    "Bob Barrows [MVP]" wrote:
     
    >
    > --
    > Microsoft MVP - ASP/ASP.NET
    > Please reply to the newsgroup. This email account is my spam trap so I
    > don't check it very often. If you must reply off-line, then remove the
    > "NO SPAM"
    >
    >
    >[/ref]
    Ralph Guest

  4. #4

    Default Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

    Ralph O. wrote: 
    Actually, the recommendation is to connect via the native OLEDB Provider for
    SQL Server instead of ODBC. However, that does not address your problem, as
    you will see when you read the rest of the article. You will probably find
    matters easier if you use a sQL Server login instead of Integrated Security.
    See SQL Books Online if these terms are unfamiliar.

    Bob Barrows
    --
    Microsoft MVP - ASP/ASP.NET
    Please reply to the newsgroup. This email account is my spam trap so I
    don't check it very often. If you must reply off-line, then remove the
    "NO SPAM"


    Bob Guest

  5. #5

    Default Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

    Bob,

    You are correct and I went that route almost immediately. I have yet to
    solve the problem however but I am working on several options. The problem
    with the SWAG method is that when you change one parameter, you have no way
    of knowing if the failure is that paramater or a previous change. I am
    attempting to get things back to their origional state each time but one can
    seldom be sure. I am looking at SQL Login now.

    Ralph

    "Bob Barrows [MVP]" wrote:
     
    > Actually, the recommendation is to connect via the native OLEDB Provider for
    > SQL Server instead of ODBC. However, that does not address your problem, as
    > you will see when you read the rest of the article. You will probably find
    > matters easier if you use a sQL Server login instead of Integrated Security.
    > See SQL Books Online if these terms are unfamiliar.
    >
    > Bob Barrows
    > --
    > Microsoft MVP - ASP/ASP.NET
    > Please reply to the newsgroup. This email account is my spam trap so I
    > don't check it very often. If you must reply off-line, then remove the
    > "NO SPAM"
    >
    >
    >[/ref]
    Ralph Guest

  6. #6

    Default Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

    Well, I seem to have come full circle. No doubt there is some small setting
    that I am overlooking but search as I can, I do not seem to be able to find
    it. No matter what connection method or login method I attempt, I always get
    the above error message or "Not associated with a trusted SQL Server
    connection" if I attempt login to the SQL Server.

    It only feels good when I stop pounding my head with a frying-pan. I have
    followed all the links and included links and am still where I started.
    Perhaps tomorrow I can get a fresh start.

    Ralph

    "Bob Barrows [MVP]" wrote:
     
    > Actually, the recommendation is to connect via the native OLEDB Provider for
    > SQL Server instead of ODBC. However, that does not address your problem, as
    > you will see when you read the rest of the article. You will probably find
    > matters easier if you use a sQL Server login instead of Integrated Security.
    > See SQL Books Online if these terms are unfamiliar.
    >
    > Bob Barrows
    > --
    > Microsoft MVP - ASP/ASP.NET
    > Please reply to the newsgroup. This email account is my spam trap so I
    > don't check it very often. If you must reply off-line, then remove the
    > "NO SPAM"
    >
    >
    >[/ref]
    Ralph Guest

  7. #7

    Default Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

    conn.open "Provider=sqloledb;data source=<server_name>;" & _
    "user ID-<sql login name>;Password=<password>;" & _
    "initial catalog-<database_name>"

    What happens when you use this connection string?

    Ralph O. wrote: 
    >> Actually, the recommendation is to connect via the native OLEDB
    >> Provider for SQL Server instead of ODBC. However, that does not
    >> address your problem, as you will see when you read the rest of the
    >> article. You will probably find matters easier if you use a sQL
    >> Server login instead of Integrated Security. See SQL Books Online if
    >> these terms are unfamiliar.
    >>
    >> Bob Barrows
    >> --
    >> Microsoft MVP - ASP/ASP.NET
    >> Please reply to the newsgroup. This email account is my spam trap so
    >> I don't check it very often. If you must reply off-line, then remove
    >> the "NO SPAM"[/ref][/ref]

    --
    Microsoft MVP - ASP/ASP.NET
    Please reply to the newsgroup. This email account is my spam trap so I
    don't check it very often. If you must reply off-line, then remove the
    "NO SPAM"


    Bob Guest

  8. #8

    Default Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

    Thanks, I have tried this before but I did it again anyway. Here is the result:

    Microsoft OLE DB Provider for SQL Server error '80004005'

    Login failed for user 'REO'. Reason: Not associated with a trusted SQL
    Server connection.

    /classified_list.asp, line 17

    NOTE: When I used your connect string, I changed the two "-" characters to
    "=".

    This error message keeps me going in circles because it appears to have no
    clear resolution. Thanks for your efforts. There is another problem outside
    of all the listed solutions. Some critical but overlooked setting between all
    the MS peices that I have yet to discover.


    "Bob Barrows [MVP]" wrote:
     [/ref]
    >
    > --
    > Microsoft MVP - ASP/ASP.NET
    > Please reply to the newsgroup. This email account is my spam trap so I
    > don't check it very often. If you must reply off-line, then remove the
    > "NO SPAM"
    >
    >
    >[/ref]
    Ralph Guest

  9. #9

    Default Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

    One other peice of information: If I set trusted_connection to yes, I get the
    subject error message, otherwise, I get the "Not associated with a trusted
    SQL Server connection" message. My best guess is that there is an issue
    between SBS2003 and W2K Server. It may simply not be possible to do this in a
    SBS2003 domain. I know there are issues and limitations (stores) with
    Exchange in SBS2003. This may be another limitation.

    "Bob Barrows [MVP]" wrote:
     [/ref]
    >
    > --
    > Microsoft MVP - ASP/ASP.NET
    > Please reply to the newsgroup. This email account is my spam trap so I
    > don't check it very often. If you must reply off-line, then remove the
    > "NO SPAM"
    >
    >
    >[/ref]
    Ralph Guest

  10. #10

    Default Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

    Ralph O. wrote: 

    That means you need to set your sql server up to use SQL Security (mixed)
    instead of integrated security. This can be done in Enterprise Manager (SEM)
    by right-clicking your server's node, choosing Properties, and clicking into
    the Security tab. Click the radio button labeled "SQL Server and Window",
    This will allow you to create a SQL Server login which you will use in your
    connection string. (in SEM expand the node for your server, expand the
    Security node, right-click the Logins node, choose New Login, and enter the
    information it requires. You need to do some reading in SQL Books Online
    (BOL) about security.
     

    Sorry - typos

    --
    Microsoft MVP - ASP/ASP.NET
    Please reply to the newsgroup. This email account is my spam trap so I
    don't check it very often. If you must reply off-line, then remove the
    "NO SPAM"


    Bob Guest

  11. #11

    Default Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

    Ralph O. wrote: 

    Where did I say to do that?
     

    No, It's simply a matter that your sql server is not set up to use SQL
    Security See my previous message.
     

    You're too hung up on this point. You need to open BOL and start reading up
    about security. The aspfaq article (or one of the articles it linked to)
    should have covered this.
     
    >>
    >> --
    >> Microsoft MVP - ASP/ASP.NET
    >> Please reply to the newsgroup. This email account is my spam trap so
    >> I don't check it very often. If you must reply off-line, then remove
    >> the "NO SPAM"[/ref][/ref]

    --
    Microsoft MVP - ASP/ASP.NET
    Please reply to the newsgroup. This email account is my spam trap so I
    don't check it very often. If you must reply off-line, then remove the
    "NO SPAM"


    Bob Guest

  12. #12

    Default Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

    Bob,

    I did that as it was in one of the peices of information. Added the user and
    followed the steps. I have read the SQL Books online about security. As I
    indicated before, I may not be understanding what I am reading. That is why I
    am asking for help.

    Ralph

    "Bob Barrows [MVP]" wrote:
     
    >
    > That means you need to set your sql server up to use SQL Security (mixed)
    > instead of integrated security. This can be done in Enterprise Manager (SEM)
    > by right-clicking your server's node, choosing Properties, and clicking into
    > the Security tab. Click the radio button labeled "SQL Server and Window",
    > This will allow you to create a SQL Server login which you will use in your
    > connection string. (in SEM expand the node for your server, expand the
    > Security node, right-click the Logins node, choose New Login, and enter the
    > information it requires. You need to do some reading in SQL Books Online
    > (BOL) about security.

    >
    > Sorry - typos
    >
    > --
    > Microsoft MVP - ASP/ASP.NET
    > Please reply to the newsgroup. This email account is my spam trap so I
    > don't check it very often. If you must reply off-line, then remove the
    > "NO SPAM"
    >
    >
    >[/ref]
    Ralph Guest

  13. #13

    Default Re: Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

    You didn't. This was from my search. I provided it in case it was of some use
    to you. Apparently, you are as frusted with me as I am with this problem. I
    would prefer to hear from someone who is not so involved in trying to make me
    the problem. Of course I am the problem. If I knew how to solve this I would
    not need to ask for help. Thanks for your efforts anyway.

    Ralph


    "Bob Barrows [MVP]" wrote:
     
    >
    > Where did I say to do that?

    >
    > No, It's simply a matter that your sql server is not set up to use SQL
    > Security See my previous message.

    >
    > You're too hung up on this point. You need to open BOL and start reading up
    > about security. The aspfaq article (or one of the articles it linked to)
    > should have covered this.
    > [/ref]
    >
    > --
    > Microsoft MVP - ASP/ASP.NET
    > Please reply to the newsgroup. This email account is my spam trap so I
    > don't check it very often. If you must reply off-line, then remove the
    > "NO SPAM"
    >
    >
    >[/ref]
    Ralph Guest

Similar Threads

  1. Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'
    By Justin in forum ASP.NET Security
    Replies: 7
    Last Post: July 1st, 05:27 PM
  2. Login failed for user 'NT AUTHORITY\NETWORK SERVICE'
    By ecoder in forum ASP.NET Security
    Replies: 13
    Last Post: September 26th, 04:12 AM
  3. Pls Help : WINNT user/Anonymous login error in Webservices ?
    By Raghu Raman in forum ASP.NET Web Services
    Replies: 0
    Last Post: September 11th, 01:01 PM
  4. Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON' msg
    By Pierre Semaan in forum ASP Database
    Replies: 0
    Last Post: July 13th, 03:58 PM
  5. Replies: 2
    Last Post: March 5th, 04:46 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139