Professional Web Applications Themes

login: ROOT LOGIN ttyp0 from - Sun Solaris

In comp.unix.solaris cljlk <com> wrote:  Hi! Exitcodevaluement!     Let me ask SPOCK'S BRAIN! "Uncomment the line CONSOLE=/dev/console in /etc/default/login." Just kidding, I knew that one myself!   Youz welcome! -am 2003...

  1. #1

    Default Re: login: ROOT LOGIN ttyp0 from

    In comp.unix.solaris cljlk <com> wrote: 

    Hi! Exitcodevaluement!
     
     

    Let me ask SPOCK'S BRAIN!

    "Uncomment the line CONSOLE=/dev/console in /etc/default/login."

    Just kidding, I knew that one myself!
     

    Youz welcome!

    -am 2003
    Anthony Guest

  2. #2

    Default Re: login: ROOT LOGIN ttyp0 from

    In comp.unix.solaris cljlk <com> wrote: 

    DOH!!! It's not SPOCK'S BRAIN's fault, I didn't notice the
    4.1.4 part to tell him.

    Tony Walton wants to know why you are running 4.1.4.
     

    Okay, I don't remember if there's a system way to do it.

    Ogg died and willed me no manuals.

    Also, you have stated BOTH

    a) I don't want to allow direct remote root login
    b) I need to allow direct remote root login

    If you want #a:

    Here's a script way to do it. IIRC, I was never able to
    CTL/C out of it to a shell at the right time to get a
    root prompt. Try it yourself.

    Assuming you're running a Bourne shell, edit this into
    the top of /etc/profile:

    trap "trap '' 0 1 2 3;exit 1" 0 1 2 3
    uid=`id|sed 's/(.*//'`
    if [ "$uid" = "uid=0" -a `tty` != "/dev/console" ]
    then
    echo "Root logins are only permitted on the console"
    exit
    fi
    unset uid


    When you need to su to root, use "su" instead of "su -".

    And check/test/hack with /etc/syslog.conf to get the
    logging you want.

    -am 2003

    Anthony Guest

  3. #3

    Default Re: login: ROOT LOGIN ttyp0 from

    On Thu, 28 Aug 2003, cljlk wrote:

    Please don't top post.
     

    Why does your user need to login as root, as opposed to
    using su? Network root logins are a security no-no. If
    you open a terminal console, the console message should
    appear there.

    --
    Rich Teer, SCNA, SCSA

    President,
    Rite Online Inc.

    Voice: +1 (250) 979-1638
    URL: http://www.rite-online.net

    Rich Guest

  4. #4

    Default Re: login: ROOT LOGIN ttyp0 from

    I need to let user login as root for some reason and I need to use SunOS
    4.1.4. It is not my choice.

    I have consol woindow opened on the SunOS machine, anyone login as root,
    "su" or "su - root",
    the login: ROOT LOGIN appear on the screen instead of going to consol
    window.
    I need to solve the problem, thus I post here.

    Thanks.

    "cljlk" <com> wrote in message
    news:biltjt$fsn$news.rcn.net... 
    root, 
    do 


    cljlk Guest

  5. #5

    Default Re: login: ROOT LOGIN ttyp0 from

    In article <Pine.GSO.4.44.0308282224500.1882-100000zaphod>,
    com says... 
    >
    > Why does your user need to login as root, as opposed to
    > using su?[/ref]

    Why are you answering his question with an unrelated question? You are
    one of those s who creates more problems instead of solving
    problems that already exist. God, how I hate those people.

    PLONK
    Thom Guest

  6. #6

    Default Re: login: ROOT LOGIN ttyp0 from

    On Sat, 30 Aug 2003, Thom wrote:
     

    A good consultant finds out what his customers' real needs are,
    which aren't necessarily the same as the questions they ask.
    For example, a person asking how to enable remote root logins
    may not have heard of the su command. And the only way to find
    that out is to ask questions that fools like you think are
    unrelated to the original question.

    There may be a solution to the OP's problem that doesn't require
    the security of the system to be compromised.

    --
    Rich Teer, SCNA, SCSA

    President,
    Rite Online Inc.

    Voice: +1 (250) 979-1638
    URL: http://www.rite-online.net

    Rich Guest

  7. #7

    Default Re: login: ROOT LOGIN ttyp0 from

    In comp.unix.solaris Thom <dmn> wrote: 
    > >
    > > Why does your user need to login as root, as opposed to
    > > using su?[/ref]
    >
    > Why are you answering his question with an unrelated question? You are
    > one of those s who creates more problems instead of solving
    > problems that already exist. God, how I hate those people.
    >
    > PLONK[/ref]

    Rich is a real troublemaker around here. < giggle >

    BTW, Rich, direct root login as a specific user-root instance is secure.

    -am 2003
    Anthony Guest

Similar Threads

  1. readhat can not login with root
    By Abhijeet in forum Linux Setup, Configuration & Administration
    Replies: 4
    Last Post: November 1st, 03:40 PM
  2. can't login as root
    By knocte in forum Linux Setup, Configuration & Administration
    Replies: 20
    Last Post: September 27th, 10:34 PM
  3. can't login as root on gdm
    By Icarus in forum Debian
    Replies: 2
    Last Post: August 11th, 12:40 AM
  4. CDE login disabled for root - how to enable?
    By Chris Mattern in forum AIX
    Replies: 3
    Last Post: August 8th, 05:56 AM
  5. Root login on NIS Client
    By Fausto in forum Sun Solaris
    Replies: 5
    Last Post: July 25th, 06:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139