Professional Web Applications Themes

logitech cordless mouse w/ freebsd 5.3 stable - FreeBSD

My ugly mouse hack: I am sure this question has already been answered, although I couldn't find the answer via google. Hardware and Software: Logitech USB cordless mouse M/N:M-RN67 P/N:851390-0000 w/ ps/2 adapter Auravision slimseries ps/2 keyboard /w wire a starband kvm switch, 4 port PS/2 for both keyboard and mouse w/ extern power source. FreeBSD 5.3 stable cpu=2.8 cel Using the ps/2 adapter with my mouse, was required to use the kvm. dmesg reports this for my mouse by default: psm0: <PS/2 Mouse> flags 0x24 irq 12 on atkbdc0 psm0: [GIANT-LOCKED] psm0: model IntelliMouse Explorer, device ID 4 the ...

  1. #1

    Default Re: logitech cordless mouse w/ freebsd 5.3 stable

    My ugly mouse hack:
    I am sure this question has already been answered, although I couldn't
    find the answer via google.

    Hardware and Software:
    Logitech USB cordless mouse M/N:M-RN67 P/N:851390-0000 w/ ps/2 adapter
    Auravision slimseries ps/2 keyboard /w wire
    a starband kvm switch, 4 port PS/2 for both keyboard and mouse w/ extern
    power source.
    FreeBSD 5.3 stable cpu=2.8 cel

    Using the ps/2 adapter with my mouse, was required to use the kvm.

    dmesg reports this for my mouse by default:

    psm0: <PS/2 Mouse> flags 0x24 irq 12 on atkbdc0
    psm0: [GIANT-LOCKED]
    psm0: model IntelliMouse Explorer, device ID 4

    the mouse will not work.

    appending: hint.psm.0.flags="0x204"
    to /boot/device.hints

    I now get this via dmesg:

    psm0: <PS/2 Mouse> flags 0x204 irq 12 on atkbdc0
    psm0: [GIANT-LOCKED]
    psm0: model Generic PS/2 mouse, device ID 0

    I then edited /etc/rc.conf and disabled my console mouse (moused) (which
    I would prefere worked)

    moused_enable="NO"

    I then edit the pointer section of /etc/X11/xorg.conf to:

    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "Auto"
    Option "Device" "/dev/bpsm0"

    notice that is the "b" psm device that i am using which is for blocking
    mode or bpsm

    At any rate, the mouse now works in X, through the kvm, and through usb
    to ps/2 adapter.

    I hope this helps someone else :)
    YMMV,
    Eric


    Eric Guest

  2. #2

    Default Re: logitech cordless mouse w/ freebsd 5.3 stable

    On Sun, 13 Mar 2005, Eric wrote:
     

    I am running FreeBSD-6.0-current, but I bet it works for you like it works
    (just fine) for me. Try it, what have you got to lose? However, if it
    works, you owe us a usage report, Sirrah!

    Anyhow, FreeBSD is not terribly willing to share the mouse. When it
    boots, the stupid thing will start 'moused' processes on both mouses.
    Check this with:

    ps -ax | grep mouse

    if it's like I think it is, one of the lines that come back will report a
    device filename of ums0. You need this process dead, dead, dead. You
    *could*, I suppose, edit /etc/usbd.conf ...

    After you do that, the stuff you have above for Xorg isn't enough either,
    cause you left out the wheel. take those lines out and replace them with

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/ums0"
    Option "Buttons" "5"
    Option "ZAxisMapping" "4 5"
    EndSection

    Don't forget, at the top:

    Section "ServerLayout"
    Identifier "X.org Configured"
    Screen 0 "Screen0" 0 0
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection


    Try this, tell me how it works.
     

    ----------------------------------------------------------------------------
    Chuck Robey | Interests include C & Java programming, FreeBSD,
    org | electronics, communications, and SF/Fantasy.

    New Year's Resolution: I will not sphroxify gullible people into looking up
    fictitious words in the dictionary (on the wall at my old fraternity,
    Signa Phi Nothing).
    ----------------------------------------------------------------------------
    Chuck Guest

  3. #3

    Default RE: logitech cordless mouse w/ freebsd 5.3 stable


    Eric,

    Please submit this via the send-pr mechanism so that it will
    get fixed in the next version of FreeBSD.

    thanks,
    Ted


    org wrote: 


    Ted Guest

  4. #4

    Default Re: logitech cordless mouse w/ freebsd 5.3 stable

    I removed above this to save some bandwidth, as bandwidth is not free
    every where in the world :)

    Chuck Robey wrote:
     
    >
    >I am running FreeBSD-6.0-current, but I bet it works for you like it works
    >(just fine) for me. Try it, what have you got to lose? However, if it
    >works, you owe us a usage report, Sirrah!
    >
    >Anyhow, FreeBSD is not terribly willing to share the mouse. When it
    >boots, the stupid thing will start 'moused' processes on both mouses.
    >Check this with:
    >
    >ps -ax | grep mouse
    >
    >if it's like I think it is, one of the lines that come back will report a
    >device filename of ums0. You need this process dead, dead, dead. You
    >*could*, I suppose, edit /etc/usbd.conf ...
    >
    >After you do that, the stuff you have above for Xorg isn't enough either,
    >cause you left out the wheel. take those lines out and replace them with
    >
    >Section "InputDevice"
    > Identifier "Mouse0"
    > Driver "mouse"
    > Option "Protocol" "auto"
    > Option "Device" "/dev/ums0"
    > Option "Buttons" "5"
    > Option "ZAxisMapping" "4 5"
    >EndSection
    >
    >Don't forget, at the top:
    >
    >Section "ServerLayout"
    > Identifier "X.org Configured"
    > Screen 0 "Screen0" 0 0
    > InputDevice "Mouse0" "CorePointer"
    > InputDevice "Keyboard0" "CoreKeyboard"
    >EndSection
    >
    >
    >Try this, tell me how it works.
    >
    >
    >[/ref]
    Chuck,
    Setting my mouse driver to "ums0", will make X crash before loading.
    My box never reported the ums0 device/the usb mouse. The usbd is
    running. There is no moused processes running on this box, as it is
    disabled in /etc/rc.conf. I get the scroll wheel to work as a middle
    button, but you are right, the scroll feature does not work.

    Option "Buttons" "5"
    Option "ZAxisMapping" "4 5"

    Setting those two options does not enable the scroll wheel. I think that
    is due to the generic PS/2 driver reported in dmesg. Having a working
    scroll wheel was never a issue for me :) Also note, I never tried
    FreeBSD 6.x .

    I am not sure if the following info matters or not:

    This is included as it may give you some hints for fixing the wheel
    feature. This mouse config was a combination of some google hints that
    led me to look at, 'man psm', 'man device.hints', and my experience
    with Freebsd 4.x. FreeBSD 4.x taught me that using /dev/bpsm0 in
    the X config would work, with this mouse and this kvm. I didn't try
    setting up the moused in /etc/rc.conf with FreeBSD 5.x. In FreeBSD 4.x
    adding the bpsm0 config to /etc/rc.conf just lead to error messages
    getting reported to my shells every so often.

    Here is some additional info:


    %ls /dev
    acd0 ata fido psm0 ttyv3
    acpi atkbd0 geom.ctl ptyp0 ttyv4
    ad0 audio0.0 io ptyp1 ttyv5
    ad0s1 audio0.1 kbd0 ptyp2 ttyv6
    ad0s10 bpf0 klog ptyp3 ttyv7
    ad0s1a bpsm0 kmem random ttyv8
    ad0s1b console log sndstat ttyv9
    ad0s1c consolectl lpt0 stderr ttyva
    ad0s1d ctty lpt0.ctl stdin ttyvb
    ad0s1e cuaa0 mdctl stdout ttyvc
    ad0s1f cuaia0 mem sysmouse ttyvd
    ad0s2 cuala0 mixer0 ttyd0 ttyve
    ad0s3 devctl net ttyid0 ttyvf
    ad0s4 devstat net1 ttyld0 urandom
    ad0s5 dsp0.0 net2 ttyp0 usb
    ad0s6 dsp0.1 net3 ttyp1 usb0
    ad0s7 dspW0.0 network ttyp2 usb1
    ad0s8 dspW0.1 nfs4 ttyp3 usb2
    ad0s9 dspr0.1 null ttyv0 xpt0
    agpgart fd pci ttyv1 zero
    apm fd0 ppi0 ttyv2
    %cat /etc/rc.conf

    # -- sysinstall generated deltas -- # Mon Jan 3 05:51:08 2005
    # Created: Mon Jan 3 05:51:08 2005
    # Enable network daemons for user convenience.
    # Please make all changes to this file, not to /etc/defaults/rc.conf.
    # This file now contains just the overrides from /etc/defaults/rc.conf.
    hostname="demon-spawn.bsdunix.us"
    ifconfig_rl0="DHCP"
    linux_enable="YES"
    usbd_enable="YES"
    moused_port="/dev/psm0"
    moused_type="auto"
    moused_enable="NO"
    %
    %ps auxw | grep usbd
    root 362 0.0 0.2 1240 780 ?? Ss 5:51AM 0:00.01 /usr/sbin/usbd
    eric 871 0.0 0.1 348 232 p3 R+ 7:38AM 0:00.00 grep usbd

    %ps auxw | grep mouse
    eric 1240 0.0 0.5 2276 1760 p1 RV 9:18AM 0:00.00 grep mouse
    (csh)

    this seems like a waste of bandwidth but...

    %dmesg
    Copyright (c) 1992-2005 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    The Regents of the University of California. All rights reserved.
    FreeBSD 5.3-STABLE #0: Sun Mar 13 08:53:16 CST 2005
    bsdunix.us:/usr/obj/usr/src/sys/CUSTOM
    ACPI APIC Table: <AMIINT INTEL845>
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Intel(R) Celeron(R) CPU 2.80GHz (2790.96-MHz 686-class CPU)
    Origin = "GenuineIntel" Id = 0xf34 Stepping = 4

    Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE ,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH, DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
    real memory = 394199040 (375 MB)
    avail memory = 376037376 (358 MB)
    ioapic0 <Version 2.0> irqs 0-23 on motherboard
    npx0: [FAST]
    npx0: <math processor> on motherboard
    npx0: INT 16 interface
    acpi0: <AMIINT INTEL845> on motherboard
    acpi0: Power Button (fixed)
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
    cpu0: <ACPI CPU> on acpi0
    acpi_button0: <Power Button> on acpi0
    pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
    pci0: <ACPI PCI bus> on pcib0
    agp0: <Intel 82845G (845G GMCH) SVGA controller> mem
    0xdff80000-0xdfffffff,0xd0000000-0xd7ffffff irq 16 at device 2.0 on pci0
    agp0: detected 8060k stolen memory
    agp0: aperture size is 128M
    uhci0: <Intel 82801DB (ICH4) USB controller USB-A> port 0xe400-0xe41f
    irq 16 at device 29.0 on pci0
    uhci0: [GIANT-LOCKED]
    usb0: <Intel 82801DB (ICH4) USB controller USB-A> on uhci0
    usb0: USB revision 1.0
    uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub0: 2 ports with 2 removable, self powered
    uhci1: <Intel 82801DB (ICH4) USB controller USB-B> port 0xe800-0xe81f
    irq 19 at device 29.1 on pci0
    uhci1: [GIANT-LOCKED]
    usb1: <Intel 82801DB (ICH4) USB controller USB-B> on uhci1
    usb1: USB revision 1.0
    uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub1: 2 ports with 2 removable, self powered
    uhci2: <Intel 82801DB (ICH4) USB controller USB-C> port 0xec00-0xec1f
    irq 18 at device 29.2 on pci0
    uhci2: [GIANT-LOCKED]
    usb2: <Intel 82801DB (ICH4) USB controller USB-C> on uhci2
    usb2: USB revision 1.0
    uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub2: 2 ports with 2 removable, self powered
    pci0: <serial bus, USB> at device 29.7 (no driver attached)
    pcib1: <ACPI PCI-PCI bridge> at device 30.0 on pci0
    pci3: <ACPI PCI bus> on pcib1
    pci3: <display, VGA> at device 5.0 (no driver attached)
    rl0: <RealTek 8139 10/100BaseTX> port 0xcc00-0xccff mem
    0xdfdfbf00-0xdfdfbfff irq 17 at device 10.0 on pci3
    miibus0: <MII bus> on rl0
    rlphy0: <RealTek internal media interface> on miibus0
    rlphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    rl0: Ethernet address: 00:0b:6a:66:64:b3
    isab0: <PCI-ISA bridge> at device 31.0 on pci0
    isa0: <ISA bus> on isab0
    atapci0: <Intel ICH4 UDMA100 controller> port
    0xfc00-0xfc0f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 31.1 on pci0
    ata0: channel #0 on atapci0
    ata1: channel #1 on atapci0
    pcm0: <Intel ICH4 (82801DB)> port 0xdc00-0xdc3f,0xe000-0xe0ff mem
    0xdff7b900-0xdff7b9ff,0xdff7ba00-0xdff7bbff irq 17 at device 31.5 on pci0
    pcm0: [GIANT-LOCKED]
    pcm0: <Unknown AC97 Codec (id = 0x434d4983)>
    fdc0: <floppy drive controller> port 0x3f7,0x3f4-0x3f5,0x3f2-0x3f3 irq 6
    drq 2 on acpi0
    fdc0: [FAST]
    fd0: <1440-KB 3.5" drive> on fdc0 drive 0
    sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on
    acpi0
    sio0: type 16550A
    ppc0: <ECP parallel printer port> port 0x778-0x77b,0x378-0x37f irq 7 drq
    3 on acpi0
    ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
    ppc0: FIFO with 16/16/9 bytes threshold
    ppbus0: <Parallel port bus> on ppc0
    plip0: <PLIP network interface> on ppbus0
    lpt0: <Printer> on ppbus0
    lpt0: Interrupt-driven port
    ppi0: <Parallel I/O> on ppbus0
    atkbdc0: <Keyboard controller (i8042)> port 0x64,0x60 irq 1 on acpi0
    atkbd0: <AT Keyboard> irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    psm0: <PS/2 Mouse> flags 0x204 irq 12 on atkbdc0
    psm0: [GIANT-LOCKED]
    psm0: model Generic PS/2 mouse, device ID 0
    pmtimer0 on isa0
    sc0: <System console> at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    sio1: configured irq 3 not in bitmap of probed irqs 0
    sio1: port may not be enabled
    vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    Timecounter "TSC" frequency 2790956669 Hz quality 800
    Timecounters tick every 10.000 msec
    acpi_cpu: throttling enabled, 8 steps (100% to 12.5%), currently 100.0%
    ad0: 38166MB <WDC WD400BB-00JHA0/05.01C05> [77545/16/63] at ata0-master
    UDMA100
    acd0: CDROM <SAMSUNG CD-ROM SH-152A/C503> at ata1-master UDMA33
    Mounting root from ufs:/dev/ad0s1a
    %

    I hope all the above answered your questions Chuck and maybe gives you
    and others some more info :)
    YMMV,
    Eric

    Eric Guest

  5. #5

    Default Re: logitech cordless mouse w/ freebsd 5.3 stable

    On Mon, 14 Mar 2005, Eric wrote:
     
    > >
    > >I am running FreeBSD-6.0-current, but I bet it works for you like it works
    > >(just fine) for me. Try it, what have you got to lose? However, if it
    > >works, you owe us a usage report, Sirrah!
    > >
    > >Anyhow, FreeBSD is not terribly willing to share the mouse. When it
    > >boots, the stupid thing will start 'moused' processes on both mouses.
    > >Check this with:
    > >
    > >ps -ax | grep mouse
    > >
    > >if it's like I think it is, one of the lines that come back will report a
    > >device filename of ums0. You need this process dead, dead, dead. You
    > >*could*, I suppose, edit /etc/usbd.conf ...
    > >
    > >After you do that, the stuff you have above for Xorg isn't enough either,
    > >cause you left out the wheel. take those lines out and replace them with
    > >
    > >Section "InputDevice"
    > > Identifier "Mouse0"
    > > Driver "mouse"
    > > Option "Protocol" "auto"
    > > Option "Device" "/dev/ums0"
    > > Option "Buttons" "5"
    > > Option "ZAxisMapping" "4 5"
    > >EndSection
    > >
    > >Don't forget, at the top:
    > >
    > >Section "ServerLayout"
    > > Identifier "X.org Configured"
    > > Screen 0 "Screen0" 0 0
    > > InputDevice "Mouse0" "CorePointer"
    > > InputDevice "Keyboard0" "CoreKeyboard"
    > >EndSection
    > >
    > >
    > >Try this, tell me how it works.
    > >
    > >
    > >[/ref]
    > Chuck,
    > Setting my mouse driver to "ums0", will make X crash before loading.
    > My box never reported the ums0 device/the usb mouse. The usbd is
    > running. There is no moused processes running on this box, as it is
    > disabled in /etc/rc.conf. I get the scroll wheel to work as a middle
    > button, but you are right, the scroll feature does not work.[/ref]

    Just 1 thing I need to confirm: did you kill the moused process BEFORE
    starting X? Because if you didn't, that's exactly what happens to me. I
    need to kill the moused process that is tying up ums0, then I can start up
    X.
     

    No, let's fix the mouse first, then we worry about the mouse wheel.
     

    ----------------------------------------------------------------------------
    Chuck Robey | Interests include C & Java programming, FreeBSD,
    org | electronics, communications, and SF/Fantasy.

    New Year's Resolution: I will not sphroxify gullible people into looking up
    fictitious words in the dictionary (on the wall at my old fraternity,
    Signa Phi Nothing).
    ----------------------------------------------------------------------------
    Chuck Guest

  6. #6

    Default Re: logitech cordless mouse w/ freebsd 5.3 stable

    Chuck Robey wrote:
     
    >>Chuck,
    >> Setting my mouse driver to "ums0", will make X crash before loading.
    >>My box never reported the ums0 device/the usb mouse. The usbd is
    >>running. There is no moused processes running on this box, as it is
    >>disabled in /etc/rc.conf. I get the scroll wheel to work as a middle
    >>button, but you are right, the scroll feature does not work.
    >>
    >>[/ref]
    >
    >Just 1 thing I need to confirm: did you kill the moused process BEFORE
    >starting X? Because if you didn't, that's exactly what happens to me. I
    >need to kill the moused process that is tying up ums0, then I can start up
    >X.
    >
    >
    >[/ref]
    I do not have any problem with the moused running at all (after doing
    the steps in the original email). Also as far as my os is concerned
    there is no USB mouse attached to the workstation. We are using
    different versions of FreeBSD :)

    By editing /etc/rc.conf and adding this line at the end:
    moused_enable="NO" , and then rebooting, keeps my moused from starting.
    I suppose I could have done #killall -9 moused *and* edited /etc/rc.conf
    with no immediate reboot. When I appended the line to
    /boot/device.hints, I rebooted for that too. This box is a workstation
    with one user, me, so uptime is not a issue.

    As far as the order of the steps, please see the original email. I did
    start X last after doing everything in the original email, as the mouse
    did not work at all until all steps were complete.
     
    >
    >No, let's fix the mouse first, then we worry about the mouse wheel.
    >
    >
    >[/ref]
    I re-read "man psm" and I believe the flags i set (/boot/device.hints)
    keep the mouse driver at level 0.
    A level 1 driver would make the scroll wheel work. When I boot with a
    level 1 driver, my mouse is completly dead in X. It is beyond my skills
    and desire, to code a custom driver :)
     
    >
    >----------------------------------------------------------------------------
    >Chuck Robey | Interests include C & Java programming, FreeBSD,
    >org | electronics, communications, and SF/Fantasy.
    >
    >New Year's Resolution: I will not sphroxify gullible people into looking up
    >fictitious words in the dictionary (on the wall at my old fraternity,
    >Signa Phi Nothing).
    >----------------------------------------------------------------------------
    >
    >
    >
    >[/ref]

    Eric Guest

Similar Threads

  1. Logitech mouse scroll wheel?
    By LeoDD webforumsuser@macromedia.com in forum Macromedia Dreamweaver
    Replies: 2
    Last Post: April 10th, 04:33 PM
  2. Compile FreeBSD RELENG_5 on FreeBSD 4-STABLE
    By Brovo Karokin in forum FreeBSD
    Replies: 1
    Last Post: February 25th, 09:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139