Professional Web Applications Themes

Mandrake 9.1 problem with MS Intellieye Mouse (USB) - Linux Setup, Configuration & Administration

First off, sorry for the cross posting! I'm just trying to reach the widest audience. I'm brand new to the world of Linux! Down to business. I installed Mandrake 9.1 and during the entire installation process my mouse worked perfectly. After the PC reset and it started to boot up, my Intellieye mouse dies and refuses to work unless I go into the BIOS and change the interupt mode from APIC to PIC. Then the mouse is perfect except when I boot back into Windows XP then my computer hangs and refuses to boot until I switch the irq mode ...

  1. #1

    Default Mandrake 9.1 problem with MS Intellieye Mouse (USB)

    First off, sorry for the cross posting! I'm just trying to reach the
    widest audience. I'm brand new to the world of Linux!

    Down to business. I installed Mandrake 9.1 and during the entire
    installation process my mouse worked perfectly. After the PC reset and
    it started to boot up, my Intellieye mouse dies and refuses to work
    unless I go into the BIOS and change the interupt mode from APIC to
    PIC. Then the mouse is perfect except when I boot back into Windows XP
    then my computer hangs and refuses to boot until I switch the irq mode
    back to APIC. I understand what APIC/PIC is for but why is it killing
    my mouse in Mandrake with APIC turned on?

    When I installed Mandrake (which I re-did a few times) I tried
    checking the box to 'Force PIC' and this made no difference. Checking
    or un-checking it, no dice either way.

    So since I'm new to Linux I thought lemme try a distro that looks a
    lot like Windows XP. I turned to Lycoris. Using the most stable build
    (a year old) it gets to the 'Launching Lizard' part during the bootup
    process and my PC hangs. I went to the console and saw some errors
    about it not being to create some files/folders. Yes, I followed the
    instructions to hit Alt-f3 during boot and then log in as root and
    type cd /tmp then rm * and that did squat. It seems that a LOT, and I
    mean LOT, of people are having the exact same probs with this build
    and even their beta (rc0 114? 119?) build and the only answer they can
    spit out on their forums to us is..."download the checksum file and
    make sure your ISO is not damaged". IMHO, that's a sad sad way to
    avoid helping people.

    On the plus side, Knoppix (Linux on a CD) loads and sees my USB mouse
    just fine. But since they don't have a GUI installer and all......I
    think I'll pass on them. My last hope is Redhat I guess.

    So if somebody knows a WORKING fix for Lycoris or a way to get
    Mandrake to see my USB mouse without having to change the IRQ mode
    every reboot, I'd much appreciate it!!

    Feel free to email me at [email]john1290hotmail.com[/email]

    System specs:
    ASUS P4S533 motherboard (SiS chipset)
    1 gig of DDR ram
    Pentium 4 2.0Ghz
    120 gig IDE NTFS C: drive
    80 gig IDE drive for Linux (I'll be using the "boot loader from
    floppy" option
    GeForce 4 Ti4400 128 megs of ram
    SBLive OEM
    SiS built in ethernet
    USB ports are built in (ohci) (tried all USB ports and same prob)
    52x CD-burner

    Again, thanks for any/all help!
    John Guest

  2. #2

    Default Re: Mandrake 9.1 problem with MS Intellieye Mouse (USB)

    On Tue, 19 Aug 2003 18:31:59 -0700, John wrote:
    > 52x CD-burner
    >
    > Again, thanks for any/all help!
    What is HID support set at in your kernel version? Also check
    whether OHCI support is in the kernel or is a kernel module and if it's
    loading correctly
    nolo Guest

  3. #3

    Default Re: Mandrake 9.1 problem with MS Intellieye Mouse (USB)

    On Tue, 19 Aug 2003 18:31:59 -0700, John wrote:
    > First off, sorry for the cross posting! I'm just trying to reach the
    > widest audience. I'm brand new to the world of Linux!
    Well, crossposting is evil, but that's OK. Welcome.
    > Down to business. I installed Mandrake 9.1 and during the entire
    > installation process my mouse worked perfectly. After the PC reset and
    > it started to boot up, my Intellieye mouse dies and refuses to work
    > unless I go into the BIOS and change the interupt mode from APIC to PIC.
    > Then the mouse is perfect except when I boot back into Windows XP then
    > my computer hangs and refuses to boot until I switch the irq mode back
    > to APIC. I understand what APIC/PIC is for but why is it killing my
    > mouse in Mandrake with APIC turned on?
    Well, either the hardware or Mandrake's kernel version must be doing APIC
    wrong. (Very possibly the hardware, because many manufacturers only test
    Windows, and if that boots, they ship.) Anyway, you can tell the Linux
    kernel not to use APIC, and it may work.

    Get Mandrake to boot, and then edit /etc/lilo.conf. (You'll need to be
    root to do this, at a shell, type su.) Notice the "image=" blocks. In
    the "image=" block whose "label=" corresponds to the boot menu option you
    use, there is an "append=" line. Add noapic to the settings on this line.
    Now, run the command "lilo". If that looks successful, you can reboot,
    and it might work regardless of the BIOS setting.

    You can also change kernel arguments for just one boot, to experiment, but
    the above changes will be permanent. Also, this assumes you're using
    LILO, not GRUB. LILO is the default on Mandrake. In GRUB, follow the
    instructions to edit the command line for one boot, or edit
    /boot/grub/menu.lst.

    --
    Nucleon, <tcfelkermtco.com>
    <http://vlevel.sourceforge.net> - Stop fiddling with the volume knob.

    65 != 97, 0x41 != 0x61, 0101 != 0141,
    similarly, 'A' != 'a'

    Nucleon Guest

Similar Threads

  1. Help with Mouse Within and Mouse Leave problem...
    By Khanh75 webforumsuser@macromedia.com in forum Macromedia Director 3D
    Replies: 2
    Last Post: December 3rd, 08:22 PM
  2. Mandrake 9.1 problem install - please help.
    By Andrew Scott in forum Linux Setup, Configuration & Administration
    Replies: 3
    Last Post: September 17th, 02:41 PM
  3. Problem with Mandrake 9.1
    By Scott Foster in forum Linux Setup, Configuration & Administration
    Replies: 0
    Last Post: August 30th, 03:49 AM
  4. nVidia TV-OUT problem on Mandrake 9.1 XFree4.3
    By Vampire at Wicked Empire in forum Linux Setup, Configuration & Administration
    Replies: 1
    Last Post: July 23rd, 05:02 AM
  5. Problems with mouse under mandrake 8.1
    By Stephen J Fromm in forum Linux Setup, Configuration & Administration
    Replies: 0
    Last Post: July 22nd, 06:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139