Professional Web Applications Themes

Menu not showing on IE5? - Macromedia Dreamweaver

Hiya Folks, my client is on IE 5 and he says that the sub menu doesn't show up. Is this right? It's held in a layer and appears when you mouse over "About Us" on the lefthand side menu. can someone check this for me please as I'm on IE6. [url]http://www.ingentus.com/clients/coh/index.htm[/url] TIA jac....

  1. #1

    Default Menu not showing on IE5?

    Hiya Folks,
    my client is on IE 5 and he says that the sub menu doesn't show up. Is this
    right? It's held in a layer and appears when you mouse over "About Us" on
    the lefthand side menu. can someone check this for me please as I'm on IE6.

    [url]http://www.ingentus.com/clients/coh/index.htm[/url]

    TIA
    jac.



    Jaclyn Guest

  2. #2

    Default Re: Menu not showing on IE5?

    Thanks Murray - so other than that (which I'll fix) the menu shows up fine
    on IE5?

    cheers
    jac.

    "Murray *TMM*" <forumsHAHAgreat-web-sights.com> wrote in message
    news:beuahv$gi$1forums.macromedia.com...
    > Jaclyn:
    >
    > I don't see anything particularly troubling on that page other than this -
    >
    > <div id="subnav" style="position:absolute; left:313px; top:292px;
    > width:170px; height:70px; z-index:2; visibility: hidden">
    > <table width="100%"
    >
    > Don't use percent width tables within layers. Browsers can get confused
    > about where the left hand margin is if you do.
    >
    > --
    > Murray --- ICQ 71997575
    > Team Macromedia Volunteer for Dreamweaver MX
    > (If you *MUST* email me, don't LAUGH when you do so!)
    > ==================
    > [url]news://forums.macromedia.com/macromedia.dreamweaver[/url] - THE BEST WAY TO GET
    > ANSWERS
    > ==================
    > [url]http://www.dreamweavermx-templates.com[/url] - Template Triage!
    > [url]http://www.projectseven.com/go[/url] - DW FAQs, Tutorials & Resources
    > [url]http://www.DreamweaverFAQ.com[/url] - DW FAQs, Tutorials & Resources
    > [url]http://www.macromedia.com/support/search/[/url] - Macromedia (MM) Technotes
    > ==================
    >
    >
    > "Jaclyn" <jaclyningentus.com> wrote in message
    > news:beu9ok$s83$1forums.macromedia.com...
    > > Hiya Folks,
    > > my client is on IE 5 and he says that the sub menu doesn't show up. Is
    > this
    > > right? It's held in a layer and appears when you mouse over "About Us"
    on
    > > the lefthand side menu. can someone check this for me please as I'm on
    > IE6.
    > >
    > > [url]http://www.ingentus.com/clients/coh/index.htm[/url]
    > >
    > > TIA
    > > jac.
    > >
    > >
    > >
    >
    >

    Jaclyn Guest

  3. #3

    Default Re: Menu not showing on IE5?


    Jac

    BTW, your menu works fine in IE6.1, NS 7.1, and Mozilla 1.4. The
    submenus don't work in Opera 7.11, though.

    Bob

    On Mon, 14 Jul 2003 14:03:52 +0100, "Jaclyn" <jaclyningentus.com>
    wrote:
    >Hiya Folks,
    >my client is on IE 5 and he says that the sub menu doesn't show up.
    Is this
    >right? It's held in a layer and appears when you mouse over "About
    Us" on
    >the lefthand side menu. can someone check this for me please as I'm
    on IE6.
    >
    >[url]http://www.ingentus.com/clients/coh/index.htm[/url]
    >
    >TIA
    >jac.
    >
    >
    CompuGenie Guest

  4. #4

    Default Re: Menu not showing on IE5?

    Jaclyn:

    I didn't check - don't have IE5 on any system. But that's the only thing I
    could see that might be causing a problem.

    --
    Murray --- ICQ 71997575
    Team Macromedia Volunteer for Dreamweaver MX
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    [url]news://forums.macromedia.com/macromedia.dreamweaver[/url] - THE BEST WAY TO GET
    ANSWERS
    ==================
    [url]http://www.dreamweavermx-templates.com[/url] - Template Triage!
    [url]http://www.projectseven.com/go[/url] - DW FAQs, Tutorials & Resources
    [url]http://www.DreamweaverFAQ.com[/url] - DW FAQs, Tutorials & Resources
    [url]http://www.macromedia.com/support/search/[/url] - Macromedia (MM) Technotes
    ==================


    "Jaclyn" <jaclyningentus.com> wrote in message
    news:beubod$2ur$1forums.macromedia.com...
    > Thanks Murray - so other than that (which I'll fix) the menu shows up fine
    > on IE5?
    >
    > cheers
    > jac.
    >
    > "Murray *TMM*" <forumsHAHAgreat-web-sights.com> wrote in message
    > news:beuahv$gi$1forums.macromedia.com...
    > > Jaclyn:
    > >
    > > I don't see anything particularly troubling on that page other than
    this -
    > >
    > > <div id="subnav" style="position:absolute; left:313px; top:292px;
    > > width:170px; height:70px; z-index:2; visibility: hidden">
    > > <table width="100%"
    > >
    > > Don't use percent width tables within layers. Browsers can get confused
    > > about where the left hand margin is if you do.
    > >
    > > --
    > > Murray --- ICQ 71997575
    > > Team Macromedia Volunteer for Dreamweaver MX
    > > (If you *MUST* email me, don't LAUGH when you do so!)
    > > ==================
    > > [url]news://forums.macromedia.com/macromedia.dreamweaver[/url] - THE BEST WAY TO
    GET
    > > ANSWERS
    > > ==================
    > > [url]http://www.dreamweavermx-templates.com[/url] - Template Triage!
    > > [url]http://www.projectseven.com/go[/url] - DW FAQs, Tutorials & Resources
    > > [url]http://www.DreamweaverFAQ.com[/url] - DW FAQs, Tutorials & Resources
    > > [url]http://www.macromedia.com/support/search/[/url] - Macromedia (MM) Technotes
    > > ==================
    > >
    > >
    > > "Jaclyn" <jaclyningentus.com> wrote in message
    > > news:beu9ok$s83$1forums.macromedia.com...
    > > > Hiya Folks,
    > > > my client is on IE 5 and he says that the sub menu doesn't show up. Is
    > > this
    > > > right? It's held in a layer and appears when you mouse over "About Us"
    > on
    > > > the lefthand side menu. can someone check this for me please as I'm on
    > > IE6.
    > > >
    > > > [url]http://www.ingentus.com/clients/coh/index.htm[/url]
    > > >
    > > > TIA
    > > > jac.
    > > >
    > > >
    > > >
    > >
    > >
    >
    >

    Murray *TMM* Guest

  5. #5

    Default Re: Menu not showing on IE5?

    Seems to work fine in IE 5.5 SP2 on PC

    --

    Dave
    -----------------------------------------------------------------
    If I were half as smart as people think I am...
    I'd be twice as smart as I was before I forgot everything.
    (Official victim of CRAFT Syndrome)

    =======================


    David R. Wheeler Guest

  6. #6

    Default Re: Menu not showing on IE5?

    Jaclyn wrote:
    > Thanks Dave - anyone else?
    >
    > "David R. Wheeler" wrote in message
    > news:beuf43$a6k$1forums.macromedia.com...
    > Seems to work fine in IE 5.5 SP2 on PC
    >
    > --
    >
    > Dave
    > -----------------------------------------------------------------
    > If I were half as smart as people think I am...
    > I'd be twice as smart as I was before I forgot everything.
    > (Official victim of CRAFT Syndrome)
    >
    > =======================
    >
    >
    >
    >
    Its not working in Mac IE5 so maybe your client has that browser.

    osgood Guest

  7. #7

    Default Re: Menu not showing on IE5?

    Jaclyn wrote:
    > Thanks Dave - anyone else?
    >
    > "David R. Wheeler" wrote in message
    > news:beuf43$a6k$1forums.macromedia.com...
    > Seems to work fine in IE 5.5 SP2 on PC
    >
    > --
    >
    > Dave
    > -----------------------------------------------------------------
    > If I were half as smart as people think I am...
    > I'd be twice as smart as I was before I forgot everything.
    > (Official victim of CRAFT Syndrome)
    >
    > =======================
    >
    >
    >
    >
    Its your 'iframe' that is causing the menu to mysteriously disappear in
    IE 5. iframes are 'active elements' meaning in some browsers they will
    assume the top most position above all other elements on the page.

    Suggest you find an alternative solution to either the flyout menu or
    the iframe itself.

    osgood Guest

  8. #8

    Default Re: Menu not showing on IE5?

    > If I was to put the flyout sub menu appearing above the about us link
    > & so keep it
    > within the width of the lefthandside nav that should fix the problem
    > shouldn't it? Have you any better suggestions? Client wants the flyout
    > & the
    > iframe.
    Yes that would work ok. I dont have any better suggestion other than to
    revise the layout, which is not really an option at this stage I presume.

    You havent attached the onResize behaviour to the submenu/closer layers
    yet, I guess you know that and will?


    Personally I would always apply the snap to the trigger image itself
    onMouseOver and the onResize behaviour to the <body> tag. Thats the way
    the folks at PV11, who know their stuff, advise.

    Also depending on what browser/platform your client is viewing in you
    should below:

    Snap contains a workaround hack for IE5.0 on the Mac, OS9, that did not
    correctly pick up the default body margins. IE5.1, and IE5.2 for Mac,
    OSX actually get this correct. On your page, you can safely disable this
    workaround in the Snap code by placing a set of comment slashes (//) if
    front of the two offending lines:
    change this:
    if(navigator.appVersion.indexOf("MSIE 5")>-1 &&
    navigator.appVersion.indexOf("Mac")>-1){
    xx+=pInt(doent.body.leftMargin);yy+=pIn t(doent.body.topMargin);}
    to this:
    //if(navigator.appVersion.indexOf("MSIE 5")>-1 &&
    navigator.appVersion.indexOf("Mac")>-1){
    //xx+=pInt(doent.body.leftMargin);yy+=pIn t(doent.body.topMargin);}--

    osgood Guest

  9. Moderated Post

    Default Re: Menu not showing on IE5?

    Removed by Administrator
    Murray *TMM* Guest
    Moderated Post

  10. #10

    Default Re: Menu not showing on IE5?

    Hiya Murray,
    they were just after the effect. & that, at the time, seemed to be the best
    way around it. I think I have it sorted now though - I tightened up the
    table & image sizes for the sub menu so it fits within the overall with of
    the LHS column.

    thanks Murray,

    jac.


    "Murray *TMM*" <forumsHAHAgreat-web-sights.com> wrote in message
    news:bev6v4$o7u$1forums.macromedia.com...
    > Jaclyn:
    >
    > Does the client know what an IFrame is? Or do they just want the effect
    you
    > have on that page?
    >
    > --
    > Murray --- ICQ 71997575


    Jaclyn Guest

Similar Threads

  1. xml menu not showing in published html
    By firas_81 in forum Macromedia Flash Data Integration
    Replies: 1
    Last Post: April 17th, 08:27 PM
  2. pop-up menu showing up behind flash element
    By Jason Barr in forum Macromedia Dynamic HTML
    Replies: 1
    Last Post: January 27th, 12:10 AM
  3. RDS menu option not showing in administrator
    By is2 in forum Coldfusion Server Administration
    Replies: 1
    Last Post: August 30th, 11:09 PM
  4. Keep over image while showing popup menu
    By pneumagion in forum Macromedia Dynamic HTML
    Replies: 4
    Last Post: February 10th, 07:06 PM
  5. Pop-up menu not showing up when button in down state
    By flybaby webforumsuser@macromedia.com in forum Macromedia Fireworks
    Replies: 1
    Last Post: August 13th, 03:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139