Professional Web Applications Themes

mgetty+sendfax = BUSY - Linux Setup, Configuration & Administration

Running SuSE 8.0 mgetty+sendfax worked perfectly (out of the box) so I never tinkered with it. I have upgraded to SuSE 8.2 and cannot make it work - please help. Am running mgetty 1.1.30-43 as shipped with SuSE 8.2. professional. The system communicates with the modem but always returns BUSY for the remote fax machine - after dialing and attempting handshaking. Please see the attached sendfax log. I installed Hylafax to see if this cured the problem but it didn't. The modem is a SmartLink 5634TS. Since this was working I am confident that the modem is OK. thanks in ...

  1. #1

    Default mgetty+sendfax = BUSY

    Running SuSE 8.0 mgetty+sendfax worked perfectly (out of the box) so I
    never tinkered with it. I have upgraded to SuSE 8.2 and cannot make it
    work - please help.

    Am running mgetty 1.1.30-43 as shipped with SuSE 8.2. professional.

    The system communicates with the modem but always returns BUSY for the
    remote fax machine - after dialing and attempting handshaking. Please
    see the attached sendfax log.

    I installed Hylafax to see if this cured the problem but it didn't.

    The modem is a SmartLink 5634TS. Since this was working I am confident
    that the modem is OK.

    thanks in advance
    Ted


    --
    08/30 21:43:01 sendfax: experimental test release 1.1.30-Dec16
    08/30 21:43:01 sendfax.c compiled at Mar 17 2003, 14:49:17
    08/30 21:43:01 sending fax to 01242258172
    08/30 21:43:01 checking /etc/hosts
    08/30 21:43:01 makelock(ttyS0) called
    08/30 21:43:01 do_makelock: lock='/var/lock/LCK..ttyS0'
    08/30 21:43:01 lock made
    08/30 21:43:01 tss: set speed to 38400 (017)
    08/30 21:43:01 tio_set_flow_control( HARD )
    08/30 21:43:01 yS0 fax_open_device succeeded, ttyS0 -> 4
    08/30 21:43:01 yS0 reading specific data for port 'ttyS0'
    08/30 21:43:01 yS0 reading /etc/mgetty+sendfax/sendfax.config...
    08/30 21:43:01 yS0 conf lib: read: 'verbose y'
    08/30 21:43:01 yS0 conf lib: read: 'debug 5'
    08/30 21:43:01 yS0 conf lib: read: 'fax-devices ttyS0'
    08/30 21:43:01 yS0 conf lib: read: 'fax-id 44 1684 275064'
    08/30 21:43:01 yS0 conf lib: read: 'dial-prefix ATD'
    08/30 21:43:01 yS0 conf lib: read: 'max-tries 3'
    08/30 21:43:01 yS0 conf lib: read: 'max-tries-continue y'
    08/30 21:43:01 yS0 key: 'fax-devices', type=1, flags=4, data=(ignored)
    08/30 21:43:01 yS0 key: 'modem-init', type=1, flags=0, data=(empty)
    08/30 21:43:01 yS0 key: 'modem-handshake', type=1, flags=0, data=(empty)
    08/30 21:43:01 yS0 key: 'modem-type', type=1, flags=1, data=auto
    08/30 21:43:01 yS0 key: 'modem-quirks', type=0, flags=0, data=(empty)
    08/30 21:43:01 yS0 key: 'fax-send-flow', type=4, flags=1, data=7
    08/30 21:43:01 yS0 key: 'fax-rec-flow', type=4, flags=1, data=7
    08/30 21:43:01 yS0 key: 'max-tries', type=0, flags=3, data=3
    08/30 21:43:01 yS0 key: 'max-tries-continue', type=3, flags=3, data=TRUE
    08/30 21:43:01 yS0 key: 'speed', type=0, flags=1, data=38400
    08/30 21:43:01 yS0 key: 'switchbd', type=0, flags=1, data=0
    08/30 21:43:01 yS0 key: 'open-delay', type=0, flags=0, data=(empty)
    08/30 21:43:01 yS0 key: 'ignore-carrier', type=3, flags=1, data=TRUE
    08/30 21:43:01 yS0 key: 'dial-prefix', type=1, flags=3, data=ATD
    08/30 21:43:01 yS0 key: 'fax-id', type=1, flags=3, data=44 1684 275064
    08/30 21:43:01 yS0 key: 'poll-dir', type=1, flags=1, data=.
    08/30 21:43:01 yS0 key: 'normal-res', type=3, flags=1, data=FALSE
    08/30 21:43:01 yS0 key: 'fax-min-speed', type=0, flags=1, data=0
    08/30 21:43:01 yS0 key: 'fax-max-speed', type=0, flags=1, data=14400
    08/30 21:43:01 yS0 key: 'debug', type=0, flags=3, data=5
    08/30 21:43:01 yS0 key: 'verbose', type=3, flags=3, data=TRUE
    08/30 21:43:01 yS0 key: '', type=3, flags=1, data=FALSE
    08/30 21:43:01 yS0 key: 'page-header', type=1, flags=0, data=(empty)
    08/30 21:43:01 yS0 key: '', type=3, flags=1, data=FALSE
    08/30 21:43:01 yS0 key: '', type=3, flags=1, data=FALSE
    08/30 21:43:01 yS0 key: '', type=1, flags=1, data=
    08/30 21:43:01 yS0 tss: set speed to 38400 (017)
    08/30 21:43:01 yS0 mdm_send: 'ATV1Q0'
    08/30 21:43:01 yS0 mdm_command: string 'ATV1Q0'
    08/30 21:43:01 yS0 mdm_command: string 'OK' -> OK
    08/30 21:43:01 yS0 mdm_send: 'ATI'
    08/30 21:43:01 yS0 mdm_gis: string 1: '5601'
    08/30 21:43:01 yS0 mdm_identify: string '5601'
    08/30 21:43:01 yS0 USR Courier/Sportster 56k detected
    08/30 21:43:01 yS0 mdm_send: 'ATI3'
    08/30 21:43:01 yS0 mdm_gis: string 1: 'Texas Instruments RK 56000 Voice Fax Rev. 10.A.29'
    08/30 21:43:01 yS0 additional info: 'Texas Instruments RK 56000 Voice Fax Rev. 10.A.29'
    08/30 21:43:01 yS0 mdm_send: 'AT+FCLASS=2.0'
    08/30 21:43:01 yS0 mdm_command: string 'AT+FCLASS=2.0'
    08/30 21:43:01 yS0 mdm_command: string 'OK' -> OK
    08/30 21:43:01 yS0 mdm_send: 'AT+FLI="44 1684 275064"'
    08/30 21:43:01 yS0 mdm_command: string 'AT+FLI="44 1684 275064"'
    08/30 21:43:02 yS0 mdm_command: string 'OK' -> OK
    08/30 21:43:02 yS0 mdm_send: 'AT+FCC=1,5,0,2,0,0,0,0'
    08/30 21:43:02 yS0 mdm_command: string 'AT+FCC=1,5,0,2,0,0,0,0'
    08/30 21:43:02 yS0 mdm_command: string 'OK' -> OK
    08/30 21:43:02 yS0 mdm_send: 'AT+FBO=0'
    08/30 21:43:02 yS0 mdm_command: string 'AT+FBO=0'
    08/30 21:43:02 yS0 mdm_command: string 'OK' -> OK
    08/30 21:43:02 yS0 mdm_send: 'AT+FNR=1,1,1,0'
    08/30 21:43:02 yS0 mdm_command: string 'AT+FNR=1,1,1,0'
    08/30 21:43:02 yS0 mdm_command: string 'OK' -> OK
    08/30 21:43:02 yS0 mdm_send: 'AT+FLO=2'
    08/30 21:43:02 yS0 mdm_command: string 'AT+FLO=2'
    08/30 21:43:02 yS0 mdm_command: string 'OK' -> OK
    08/30 21:43:02 yS0 fax_send: 'ATD01242258172'
    08/30 21:43:02 yS0 fax_wait_for(OK)
    08/30 21:43:02 yS0 fax_wait_for: string 'ATD01242258172'
    08/30 21:43:08 yS0 fax_wait_for: string 'BUSY'
    08/30 21:43:08 yS0 ABORTING: line='BUSY'
    08/30 21:43:08 ##### failed dialing, phone="01242258172", +FHS:-2, dev=ttyS0, time=6s, acct=""

    08/30 21:43:08 yS0 fax_send: 'AT+FCLASS=0'
    08/30 21:43:08 yS0 removing lock file
    tb Guest

  2. #2

    Default Re: mgetty+sendfax = BUSY

    tb <fuzziesmadasafish.com> writes:

    ]This is a multi-part message in MIME format.
    ]--------------090803010503020305060608
    ]Content-Type: text/plain; cht=us-ascii; format=flowed
    ]Content-Transfer-Encoding: 7bit

    ]Running SuSE 8.0 mgetty+sendfax worked perfectly (out of the box) so I
    ]never tinkered with it. I have upgraded to SuSE 8.2 and cannot make it
    ]work - please help.

    ]Am running mgetty 1.1.30-43 as shipped with SuSE 8.2. professional.

    ]The system communicates with the modem but always returns BUSY for the
    ]remote fax machine - after dialing and attempting handshaking. Please
    ]see the attached sendfax log.

    Might I suggest that the remote system is busy? It is the modem which is
    sending back the response "BUSY". So, eitehr your modem is defective or
    the remote site actually is busy. Have youtried dialing it on the phone?
    Have you tried leaving the modem volume control on while it is dialing
    so you can hear what happens at the other end?



    ]08/30 21:43:02 yS0 fax_wait_for: string 'ATD01242258172'
    ]08/30 21:43:08 yS0 fax_wait_for: string 'BUSY'
    ]08/30 21:43:08 yS0 ABORTING: line='BUSY'
    ]08/30 21:43:08 ##### failed dialing, phone="01242258172", +FHS:-2, dev=ttyS0, time=6s, acct=""


    Bill Unruh Guest

  3. #3

    Default Re: mgetty+sendfax = BUSY

    Bill Unruh wrote:
    > tb <fuzziesmadasafish.com> writes:
    >
    > ]This is a multi-part message in MIME format.
    > ]--------------090803010503020305060608
    > ]Content-Type: text/plain; cht=us-ascii; format=flowed
    > ]Content-Transfer-Encoding: 7bit
    >
    > ]Running SuSE 8.0 mgetty+sendfax worked perfectly (out of the box) so I
    > ]never tinkered with it. I have upgraded to SuSE 8.2 and cannot make it
    > ]work - please help.
    >
    > ]Am running mgetty 1.1.30-43 as shipped with SuSE 8.2. professional.
    >
    > ]The system communicates with the modem but always returns BUSY for the
    > ]remote fax machine - after dialing and attempting handshaking. Please
    > ]see the attached sendfax log.
    >
    > Might I suggest that the remote system is busy? It is the modem which is
    > sending back the response "BUSY". So, eitehr your modem is defective or
    > the remote site actually is busy. Have youtried dialing it on the phone?
    > Have you tried leaving the modem volume control on while it is dialing
    > so you can hear what happens at the other end?
    I have dialed in a number of times by phone and get a fax tone in
    response. Listening to the modem it appears not to actually ring the fax
    machine. The modem works fine for data, am using it to read the news
    groups. I suspect that I requre a different initialisation string for
    the modem. reading the manual and trying various settings have proved
    futile :(. Does anyone have a working SmartLink modem tht could pass on
    the initialisation string?

    tks
    >
    >
    >
    > ]08/30 21:43:02 yS0 fax_wait_for: string 'ATD01242258172'
    > ]08/30 21:43:08 yS0 fax_wait_for: string 'BUSY'
    > ]08/30 21:43:08 yS0 ABORTING: line='BUSY'
    > ]08/30 21:43:08 ##### failed dialing, phone="01242258172", +FHS:-2, dev=ttyS0, time=6s, acct=""
    >
    >
    tb Guest

  4. #4

    Default Re: mgetty+sendfax = BUSY

    Looking at the data connection it uses ATDT as the dial string rather
    than ATD. This certainly seems to make a difference and the modem
    deffinately dials. However, it still fails to connect - doesn't
    recognise the fax and negotiate. Since I have tried it under W2K using
    the software supplied as well as my older OS/2 box (where it was
    working) and it fails on both so I suspect that the modem has given up.

    Many thanks for the input - am sure I'll be back with questions. So far
    VERY impressed with the available software.

    thanks & cheers
    Ted
    > tb <fuzziesmadasafish.com> writes:
    >
    > [...]
    >
    >
    >>08/30 21:43:02 yS0 fax_send: 'ATD01242258172'
    >
    >
    > This is the string sent to _your_ modem...
    >
    >
    >>08/30 21:43:02 yS0 fax_wait_for(OK)
    >
    >
    > ...and it waits for an OK.
    >
    >
    >>08/30 21:43:02 yS0 fax_wait_for: string 'ATD01242258172'
    >
    >
    > --which it never receives; instead, it gets "BUSY".
    >
    > The problem is either
    >
    > - an incorrect INIT string;
    > - incorrect permissions on the device, or
    > - incorrect setup of the mgetty lockfiles.
    >
    > Since you wrote that data connections work fine, check
    > that very command (ATD01242258172) with minicom, or
    > with sendfax but with modem speaker turned on. I am
    > pretty sure that the modem doesn't dial at all.
    >
    > Michael
    tb Guest

Similar Threads

  1. Busy cursor does not go away
    By gumnam in forum Macromedia Flex General Discussion
    Replies: 1
    Last Post: March 1st, 09:32 PM
  2. I would like a few first impressions if your not busy, thanks.
    By kO2n in forum Adobe Flash, Flex & Director
    Replies: 2
    Last Post: September 24th, 09:32 AM
  3. mgetty AutoPPP failing
    By Thomas Krennwallner in forum Debian
    Replies: 1
    Last Post: July 19th, 10:50 PM
  4. processor is busy
    By Steve Busch in forum Windows Networking
    Replies: 1
    Last Post: July 8th, 11:12 PM
  5. sendfax parameters for HylaFax
    By Nico Kadel-Garcia in forum Linux Setup, Configuration & Administration
    Replies: 0
    Last Post: July 2nd, 03:02 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139