Professional Web Applications Themes

missing fonts upon printing - Adobe Indesign Macintosh

Hi. I'm using InDesign, vesion 2.0.2, on a G4 800 MHz iMac running Mac OS X 10.4.8, having 1GB of memory. The problem is that some fonts seem to missing when I print. (One such page uses Skia Regular and Shalom OldStyle.) Such fonts appear okay onscreen. Note the following: (1) If I print the page directly from InDesign, the fonts are replaced by Courier Italic. (2) If I export to PDF, the Shalom font is missing, but the Skia displays okay. (3) If I use the standard Print dialog, but save the resulting file as PostScript, the Shalom font ...

  1. #1

    Default missing fonts upon printing

    Hi.

    I'm using InDesign, vesion 2.0.2, on a G4 800 MHz iMac running Mac OS X 10.4.8, having 1GB of memory.

    The problem is that some fonts seem to missing when I print. (One such page uses Skia Regular and Shalom OldStyle.) Such fonts appear okay onscreen.

    Note the following:

    (1) If I print the page directly from InDesign, the fonts are replaced by Courier Italic.

    (2) If I export to PDF, the Shalom font is missing, but the Skia displays okay.

    (3) If I use the standard Print dialog, but save the resulting file as PostScript, the Shalom font is there, but certain things break in the Skia font:
    (a) Underlined "h" seems to backspace one character, i.e., it's superimposed on the preceding character.
    (b) The apostrophe is replaced by a wide space.

    BTW, I did a PreFlight check; I am not accessing any fonts that don't exist.

    Suggestions? Thanks.
    Art_Werschulz@adobeforums.com Guest

  2. #2

    Default Re: missing fonts upon printing

    Make sure to enable download PPD fonts when printing.

    Bob
    Bob Guest

  3. #3

    Default Re: missing fonts upon printing

    Hi.

    Many thanks!! That solved the problem.
    Art_Werschulz@adobeforums.com Guest

  4. #4

    Default Re: missing fonts upon printing

    Hi.

    Here's something related.

    Although printing now includes the missing font, said fonts disappear when I export the file to PDF. How can I make them appear in the exported file?

    Thanks.
    Art_Werschulz@adobeforums.com Guest

  5. #5

    Default Re: missing fonts upon printing

    Sounds like a subsetting issue. If the font resides on the RIP in a different, older or newer version than the one on your system and therefore in the PDF, sometimes characters get skipped or misaligned. Why? Not sure, but I think it's got something to do with older fonts having a different character ID system. Embedding the entire font forces the RIP or the displaying system to use the version of the font embedded in the PDF. Set the PDF Export settings to "Subset fonts when percent of characters used is less than:" to "0%". This will embed the entire font in the PDF.
    Greg_Gaspard@adobeforums.com Guest

  6. #6

    Default Re: missing fonts upon printing

    Hi.

    What's "RIP"?

    At any rate, the problem may not be an InDesign problem per se. I followed your advice, and saw no change when I used Preview to look at the PDF. However, when I used Acrobat Reader to look at the PDF, the font was there.

    I did get a warning "Cannot extract the embedded font 'ShalomOldStyle'. Some characters may not display or print correctly." However, all the characters appeared to be there. Ideas on how to fix this? Does it matter? Does it explain why Preview couldn't see the font?

    Thanks.
    Art_Werschulz@adobeforums.com Guest

  7. #7

    Default Re: missing fonts upon printing

    Regardless of whether a font is partially or fully embedded in a PDF file, when that PDF file is printed, the font in the PDF overrides whatever is in the RIP, unless of course you have some CloneScript RIP that does not obey the PostScript (or PDF) language specification.

    - Dov
    Dov Guest

Similar Threads

  1. Missing fonts that aren't missing
    By Jack_Gregory@adobeforums.com in forum Adobe Indesign Windows
    Replies: 7
    Last Post: March 19th, 04:33 PM
  2. Help with Missing Fonts
    By Rodney_Jefferson@adobeforums.com in forum Adobe Indesign Windows
    Replies: 3
    Last Post: May 26th, 08:41 AM
  3. says fonts missing, but they are there
    By overprintboy@adobeforums.com in forum Adobe Illustrator Windows
    Replies: 1
    Last Post: April 1st, 12:33 AM
  4. HELP HELP HELP FONTS MISSING!!!!!
    By kl2 webforumsuser@macromedia.com in forum Macromedia Freehand
    Replies: 1
    Last Post: October 31st, 08:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139