Professional Web Applications Themes

missing ide-scsi in debian? - Linux Setup, Configuration & Administration

I would like to use my IDE CD-R on woody debian. I read how to use modconf to enable IDE SCSI emulation. However, when I ran modconf and looked in kernel/drivers/scsi the ide-scsi module was not there. Does anyone know how to get the ide-scsi module? Do I need to recompile the kernel or can I apt-get a kernel module? if helpful, here is my system information: MyComputer: uname -a Linux MyComputer 2.4.18 #2 Thu Apr 11 14:37:17 EDT 2002 sparc64 unknown thanks, andy...

  1. #1

    Default missing ide-scsi in debian?

    I would like to use my IDE CD-R on woody debian. I read how to use
    modconf to enable IDE SCSI emulation. However, when I ran modconf and
    looked in kernel/drivers/scsi the ide-scsi module was not there. Does
    anyone know how to get the ide-scsi module? Do I need
    to recompile the kernel or can I apt-get a kernel module?

    if helpful, here is my system information:

    MyComputer: uname -a
    Linux MyComputer 2.4.18 #2 Thu Apr 11 14:37:17 EDT 2002 sparc64 unknown

    thanks, andy

    tolonen Guest

  2. #2

    Default Re: missing ide-scsi in debian?


    tolonen wrote in message
    <3fdb50dd$0$576$mit.edu>... 
    and 
    Does 
    unknown 

    Did you compile the kernel you are now using? If so, you need to
    re-compile and set the scsi stuff as 'm' or 'y' in the config step.

    --
    Bob R
    POVrookie
    --
    MinGW (GNU compiler): http://www.mingw.com/
    Dev-C++ IDE: http://www.bloodshed.net/
    V IDE & V GUI: http://www.objectcentral.com/
    POVray: http://www.povray.org/
    Good C++ book: http://www.mindview.net/Books
    alt.comp.lang.learn.c-c++: ftp://snurse-l.org/pub/acllc-c++/faq


    Bob Guest

  3. #3

    Default Re: missing ide-scsi in debian?


    Bob R wrote: 

    Thanks for the advice. I compiled 2.4.21 using make-kpkg and set all the
    scsi stuff to m using xconfig. I now have sr_mod and sg installed as
    modules. However, ide-scsi is still not available using modconf. the
    files ide-scsi.c and ide-scsi.h exist in /usr/src/2.4.21/drivers/scsi.
    however, following compilation, ide-scsi.o does not exist in
    /lib/modules/2.4.21/kernel/drivers/scsi. it seems from the following
    discussion that ide-scsi is not compiled by default in debian for sparc:

    http://lists.debian.org/debian-sparc/2002/debian-sparc-200210/msg00103.html

    Is there anyway to control what modules get compiled along with the
    kernel? how might i specify that ide-scsi.o should get compiled?

    thanks, andy

    tolonen Guest

  4. #4

    Default Re: missing ide-scsi in debian?

    tolonen (mit.edu.invalid) wrote:

    : Bob R wrote:
    : >
    : > Did you compile the kernel you are now using? If so, you need to
    : > re-compile and set the scsi stuff as 'm' or 'y' in the config step.
    : >

    : Thanks for the advice. I compiled 2.4.21 using make-kpkg and set all the
    : scsi stuff to m using xconfig. I now have sr_mod and sg installed as
    : modules. However, ide-scsi is still not available using modconf. the
    : files ide-scsi.c and ide-scsi.h exist in /usr/src/2.4.21/drivers/scsi.
    : however, following compilation, ide-scsi.o does not exist in
    : /lib/modules/2.4.21/kernel/drivers/scsi. it seems from the following
    : discussion that ide-scsi is not compiled by default in debian for sparc:

    : http://lists.debian.org/debian-sparc/2002/debian-sparc-200210/msg00103.html

    : Is there anyway to control what modules get compiled along with the
    : kernel? how might i specify that ide-scsi.o should get compiled?

    : thanks, andy

    Unless you have some other reason to recompile your own kernel,
    "ide-scsi.o" is in "kernel-image-2.4.21-sparc64_33_sparc.deb".
    Check this out:
    ftp://ftp.debian.org/debian/pool/main/k/kernel-image-sparc-2.4/
    Alex Guest

Similar Threads

  1. Lilo: strange warnings when scsi boot + ide-scsi emulation
    By Mannr@uwaterloo.ca in forum Linux Setup, Configuration & Administration
    Replies: 1
    Last Post: August 9th, 01:50 AM
  2. utopia.sty missing from Debian teTeX 2.0.2 unstable packages
    By R (Chandra) Chandrasekhar in forum Debian
    Replies: 1
    Last Post: July 10th, 06:30 PM
  3. SCSI ID problem leads to PVs Missing
    By futsnfup in forum AIX
    Replies: 1
    Last Post: July 1st, 02:29 PM
  4. Replies: 1
    Last Post: June 30th, 05:26 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139