Professional Web Applications Themes

mount: /dev/cdrom is not a valid block device - Linux Setup, Configuration & Administration

On Wed, 07 Jan 2004 11:37:13 -0600, William Winkler wrote:   Stop trying to mount an audio CD, it has no filesystem and does not "mount" from Win<anything> either. You "play" it with a player, a really simple concept. -- The M$ warcry: Quantity is no substitute for quality, but it's the only one we've got....

  1. #1

    Default Re: mount: /dev/cdrom is not a valid block device

    On Wed, 07 Jan 2004 11:37:13 -0600, William Winkler wrote:
     
    Stop trying to mount an audio CD, it has no filesystem and does not
    "mount" from Win<anything> either. You "play" it with a player, a really
    simple concept.
    --
    The M$ warcry:
    Quantity is no substitute for quality, but it's the only one we've got.
    nunya Guest

  2. #2

    Default mount: /dev/cdrom is not a valid block device

    I recently installed Red Hat 7 on an old computer I hadn't gotten around to
    throwing out. It installed OK from CD, but after that I couldn't get to the
    CD player. I tried a mount command:

    mount -r -t iso9660 /dev/cdrom /mnt/cdrom

    but get the message

    mount: /dev/cdrom is not a valid block device

    (And mount ... /dev/hdb ... gets the same error.)

    The CD drive is connected to the same ribbon cable as my hard disk, but is
    not recognized by my system bios, which shows only a primary master. When I
    was running Windows 98, Windows added the CD player to the Windows system
    hardware list, and it showed up in Windows Explorer as the D disk. (If it
    matters, this computer is old enough to have the old bus architecture that
    manufacturers quit using about 1997.)

    Any ideas whether Linux can get to this CD player? It seems odd that the
    Linux installer can operate the CD player, but Linux itself can't!

    Thanks,
    Bill


    William Guest

  3. #3

    Default Re: mount: /dev/cdrom is not a valid block device

    William Winkler <nospam.nospamcom> wrote: 

    And dmesg | more tells you that the CD is recognized?
    Davide

    --
    | Microsoft does have a Y2K problem... it's called Linux!
    Davide Guest

  4. #4

    Default read the message before you post a reply

    As I said, I used the CD player for the Linux installation CD. Obviously
    I'm talking about data CDs, not music CDs. Take a look at Davide Bianchi's
    reply if you want to learn how to be helpful.


    William Guest

  5. #5

    Default Re: mount: /dev/cdrom is not a valid block device

    Thanks for the info. demsg said:

    hdb: ATAPI CDROM ATAPI CD/DVD-ROM drive
    hdb: driver not present

    When I tried to install Linux 8, the install procedure asked what driver to
    use for the CD player, and gave a list of choices -- and I even think an
    ATAPI was on the list. I tried to load several of them, but they all ended
    up saying "driver not loaded". I gave up on Linux 8 and went back to Linux
    7, which didn't ask for a driver.

    I had to boot the Linux installation from floppy. It occurs to me that the
    device drivers are probably in that dos... directory on the installation CD,
    and I needed to copy the device drivers onto the installation boot floppy.
    I'd try that now, but I borrowed the Linux CDs from the public library; I've
    already returned them and someone else has checked them out.

    If those drivers are available for download somewhere on the Internet (along
    with instructions for how to install a CD driver from a floppy!), please let
    me know. Meanwhile, I'll put myself on the waiting list at the library.

    Thanks a bunch,
    Bill


    "Davide Bianchi" <net> wrote in message
    news:bthgod$76cj9$news.uni-berlin.de... 
    >
    > And dmesg | more tells you that the CD is recognized?
    > Davide
    >
    > --
    > | Microsoft does have a Y2K problem... it's called Linux![/ref]


    William Guest

  6. #6

    Default Re: mount: /dev/cdrom is not a valid block device

    On Wed, 07 Jan 2004 11:37:13 -0600, William Winkler typed:
     

    <snip>
     

    Try using the command as root from the console or xterm session:
    /sbin/depmod -ae


    --
    SCO + RICO Act = Justice

    Hi! I'm a .sig virus! Copy me to your .sig!

    Lenard Guest

  7. #7

    Default Re: mount: /dev/cdrom is not a valid block device

    William Winkler <nospam.com> wrote: 

    So, he knows that there is a CD, but he doesn't know which.
     

    I think you have to download the source of the kernel (unless you
    already installed them in /usr/src/linux) and then compile
    the driver from the kernel. IIRC there is an 'Old IDE/atapi support'
    option in the kernel.

    Davide


    --
    | Q: How many Microsoft tech writers does it take to change a lightbulb?
    | A: Twelve. One to work the bulb, and eleven to write a 1,123 page
    | guide to changing lightbulbs ("Learn Lightbulb Management in 21
    | Days").
    |
    |
    Davide Guest

  8. #8

    Default Re: mount: /dev/cdrom is not a valid block device

    depmod returned no output.
    However... dmesg indicated that there is no device driver for /dev/hdb...
    see my reply to Davide Bianchi.

    Thanks for giving me an idea to try out.
    Bill

    "Lenard" <0.0.1> wrote in message
    news:0.0.1... 
    >
    > <snip>

    >
    > Try using the command as root from the console or xterm session:
    > /sbin/depmod -ae
    >
    >
    > --
    > SCO + RICO Act = Justice
    >
    > Hi! I'm a .sig virus! Copy me to your .sig!
    >[/ref]


    William Guest

  9. #9

    Default Re: mount: /dev/cdrom is not a valid block device

    William Winkler <nospam.com> wrote: 

    You might try booting the install diskette and switching to another
    console using <alt><Fn> (Fn => F2, F3, F4 or ???) Some install
    programs have another console available in which you can type
    commands. Then type "lsmod" and try to figure out whuich module is
    the one that works with your CDROM. Once you know that, you can type
    "modprobe <name>" (as root) when you have the regular install running
    and it should load the correct driver. Most likely the module is
    available and you just need to figure out which one it is. If that
    works, then you need to figure out how to get it to load automagically
    so you don't have to 'modprobe' every time you want to use the CDROM.

    HTH,
    hank

    hbarta Guest

  10. #10

    Default Dissing newbies from "nunya", was Re: mount: /dev/cdrom is not a valid block device


    "nunya" <0.0.1> wrote in message
    news:0.0.1...
    [ post deleted ] 

    My ghod, it *IS* Peter Breuer insulting the newbies again. Or his clone....


    Nico Guest

  11. #11

    Default Re: Dissing newbies from "nunya", was Re: mount: /dev/cdrom is not a valid block device

    Stop spreading your disinformation please, once again you are absolutely
    off the mark.
    Actually what IS insulting is the likes of yourself trying to play
    net-cop, while posting with an M$hit product to Linux newsgroups. You
    smell a lot like another foolish know nothing (tracker) to me.
    --
    The M$ warcry:
    Quantity is no substitute for quality, but it's the only one we've got.
    nunya Guest

  12. #12

    Default Re: Dissing newbies from "nunya", was Re: mount: /dev/cdrom is not a valid block device

     
    Obviously NOT YOU. 
    My newsreader is configured just fine .......... for ME, maybe not for
    YOU. If yours does not keep threads in order properly that is YOUR
    problem. 
    Yeah, GUESS. Guessing has no place in a technical group. 
    Who are you to "guarantee that what YOU know about Linux would fit in one
    of his sub-sub-sub-directories on a forgotten partition" ? h/s/it's
    defender? Personally, I have been working on and with *nix since the Minix
    days and have no need of your (nor Nico's) obviously non-technical
    non-expertise.
    If you want to help someone, then do so ......... do not guess, or answer
    with what YOU want.
    --
    The M$ warcry:
    Quantity is no substitute for quality, but it's the only one we've got.
    nunya Guest

  13. Moderated Post

    Default Re: Dissing newbies from "nunya", was Re: mount: /dev/cdrom is not a valid block device

    Removed by Administrator
    nunya Guest
    Moderated Post

  14. #14

    Default Re: Dissing newbies from "nunya", was Re: mount: /dev/cdrom is not a valid block device

    On Mon, 12 Jan 2004 10:03:39 +0000, nunya <0.0.1> wrote: 

    Who are you talking to?

    ------------------------

    And how does someone who can't even configure their newsreader and lacks
    the sense to at least manually type in the name of the person they are
    replying to, with a few snippets of that post to identify it, has
    the audacity to talk down to anyone on matters technical?

    If you are addressing Nico, my guess would be that he's at work and is
    forced to use Windoze there.

    I guarantee that what YOU know about Linux would fit in one of his sub-sub-
    sub-directories on a forgotten partition.

    AC

    Alan Guest

  15. Moderated Post

    Default Re: Dissing newbies from "nunya", was Re: mount: /dev/cdrom is not a valid block device

    Removed by Administrator
    Alan Guest
    Moderated Post

  16. #16

    Default Re: mount: /dev/cdrom is not a valid block device

    "William Winkler" <nospam.com> wrote in message news:<bthp6e$pee$cc.utexas.edu>... 
    > >
    > > <snip>
    > > 
    > >
    > > Try using the command as root from the console or xterm session:
    > > /sbin/depmod -ae
    > >
    > >
    > > --
    > > SCO + RICO Act = Justice
    > >
    > > Hi! I'm a .sig virus! Copy me to your .sig!
    > >[/ref][/ref]

    As the OP mentioned, the BIOS itself is not recognising the CD-ROM, to
    check the jumper settings on the CD-ROM may be a good idea also if he
    has a spare ribbon cable connect it to the secondary IDE port on the
    Motherboard.

    HTH
    pankaj Guest

Similar Threads

  1. mount: /dev/cdrom: can't read superblock
    By Angus in forum Linux Setup, Configuration & Administration
    Replies: 4
    Last Post: October 28th, 08:54 AM
  2. Can't mount cdrom
    By dirk65mb in forum Linux Setup, Configuration & Administration
    Replies: 3
    Last Post: September 21st, 04:42 PM
  3. I have delete my cdrom device
    By Tacit in forum Mac Applications & Software
    Replies: 2
    Last Post: July 12th, 11:38 AM
  4. open firmare, append device cdrom?
    By smoKing in forum Mac Portable
    Replies: 1
    Last Post: July 9th, 04:32 AM
  5. Cannot mount cdrom if I use GRUB
    By Marino Fernandez in forum Debian
    Replies: 2
    Last Post: July 4th, 10:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139