Professional Web Applications Themes

mount second hdd for user - Linux Setup, Configuration & Administration

Hello, I am trying to mount my second hdd for user, but I keep failing :-D Here are some details: I use Mandrake 9.1, first hdd has linux (boot, swap, root ext3) and win (ntfs and vfat) partitions. They all work fine, I can configure them to be mounted for the user. I put in the new harddisk, and I have tried to mount with the following command: mount -t ext2 -o uid=my_user /dev/hdb1 /mnt/mount_dir But I get this error: mount: wrong fs type, bad option, bad superblock on /dev/hdb1, or too many mounted file systems I have also used ...

  1. #1

    Default mount second hdd for user

    Hello,

    I am trying to mount my second hdd for user, but I keep failing :-D

    Here are some details:

    I use Mandrake 9.1, first hdd has linux (boot, swap, root ext3) and win
    (ntfs and vfat) partitions. They all work fine, I can configure them to
    be mounted for the user. I put in the new harddisk, and I have tried to
    mount with the following command:

    mount -t ext2 -o uid=my_user /dev/hdb1 /mnt/mount_dir

    But I get this error:

    mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
    or too many mounted file systems


    I have also used MandrakeControlCenter's feature to manage partitions,
    and if I just set it, and do not alter the options, it will be mounted
    after reboot, but only for the root. If I add the options uid=my_user
    and gid=my_user, after reboot it will not be mounted at all.

    I appreciate any help,
    Bogdan

    @(none)web.de Guest

  2. #2

    Default Re: mount second hdd for user

    Hello

    none (<">) wrote:
    > I am trying to mount my second hdd for user, but I keep failing :-D
    >
    > Here are some details:
    >
    > I use Mandrake 9.1, first hdd has linux (boot, swap, root ext3) and
    > win (ntfs and vfat) partitions. They all work fine, I can configure
    > them to be mounted for the user. I put in the new harddisk, and I have
    > tried to mount with the following command:
    >
    > mount -t ext2 -o uid=my_user /dev/hdb1 /mnt/mount_dir
    >
    > But I get this error:
    >
    > mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
    > or too many mounted file systems
    According to the mount manage, ext2 filesystems do not have an "uid"
    option. This option is used for filesystems like Windows FAT that do
    not have own ownership for files. Mount your ext2 filesystem normally
    and use chown to change file ownership.

    best regards
    Andreas Janssen

    --
    Andreas Janssen
    [email]andreas.janssenbigfoot.com[/email]
    PGP-Key-ID: 0xDC801674
    Registered Linux User #267976
    Andreas Janssen Guest

  3. #3

    Default Re: mount second hdd for user

    On Mon, 15 Sep 2003 17:12:58 +0200, (none)web.de
    <> wrote:
    > Hello,
    >
    > I am trying to mount my second hdd for user, but I keep failing :-D
    >
    > Here are some details:
    >
    > I use Mandrake 9.1, first hdd has linux (boot, swap, root ext3) and win
    > (ntfs and vfat) partitions. They all work fine, I can configure them to
    > be mounted for the user. I put in the new harddisk, and I have tried to
    > mount with the following command:
    >
    > mount -t ext2 -o uid=my_user /dev/hdb1 /mnt/mount_dir
    >
    > But I get this error:
    >
    > mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
    > or too many mounted file systems
    >
    > I have also used MandrakeControlCenter's feature to manage partitions,
    > and if I just set it, and do not alter the options, it will be mounted
    > after reboot, but only for the root. If I add the options uid=my_user
    > and gid=my_user, after reboot it will not be mounted at all.
    >
    The uid= and gid= options are for inferior file systems (FAT, NTFS).
    With a Linux file system, you can use chown and chmod.

    --
    Commander Spiral Pyjama Pseudo-Rhinocerous Feline Thingamajig Bill Mar
    (the First)
    Ozy and Millie Name Generator [url]http://heifong.phase.org/omname.php[/url]
    Bill Marcum Guest

  4. #4

    Default Re: mount second hdd for user

    Andreas Janssen wrote:
    > Hello
    >
    > none (<">) wrote:
    >
    >
    >>I am trying to mount my second hdd for user, but I keep failing :-D
    >>
    >>Here are some details:
    >>
    >>I use Mandrake 9.1, first hdd has linux (boot, swap, root ext3) and
    >>win (ntfs and vfat) partitions. They all work fine, I can configure
    >>them to be mounted for the user. I put in the new harddisk, and I have
    >>tried to mount with the following command:
    >>
    >>mount -t ext2 -o uid=my_user /dev/hdb1 /mnt/mount_dir
    >>
    >>But I get this error:
    >>
    >>mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
    >> or too many mounted file systems
    >
    >
    > According to the mount manage, ext2 filesystems do not have an "uid"
    > option. This option is used for filesystems like Windows FAT that do
    > not have own ownership for files. Mount your ext2 filesystem normally
    > and use chown to change file ownership.
    >
    > best regards
    > Andreas Janssen
    >
    It worked, thank you very much!

    Bogdan

    @(none)web.de Guest

Similar Threads

  1. Mount / Umount in user mode
    By Bachelier Vincent in forum FreeBSD
    Replies: 2
    Last Post: February 25th, 06:45 AM
  2. Mount in user mode && USBD for external HDD
    By Bachelier Vincent in forum FreeBSD
    Replies: 2
    Last Post: February 22nd, 06:57 AM
  3. user mode mount question
    By George in forum Linux / Unix Administration
    Replies: 1
    Last Post: June 25th, 04:04 PM
  4. mount vcr
    By Not so quick in forum Photography
    Replies: 9
    Last Post: September 4th, 06:40 PM
  5. Replies: 1
    Last Post: August 21st, 01:21 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139