Professional Web Applications Themes

MySQL can't find messagefile when installed passively - MySQL

Hi, I'm trying to install mysql silently using the /passive switch as part of the installation of my program on Window XP. I can install it fine and install it as a service all using my installer, but I can't get it to start, not even manually. If I try starting it from a prompt I get the following message: F:\Doents and Settings\Lionel van den Berg>mysqld-nt --verbose 070224 7:24:37 [ERROR] Can't find messagefile 'C:\mysql\share\english\errmsg.sy s' 070224 7:24:37 [ERROR] Aborting F:\Doents and Settings\Lionel van den Berg> There was an old bug report about this but the problem was fixed and I ...

  1. #1

    Default MySQL can't find messagefile when installed passively

    Hi,

    I'm trying to install mysql silently using the /passive switch as part
    of the installation of my program on Window XP. I can install it fine
    and install it as a service all using my installer, but I can't get it
    to start, not even manually. If I try starting it from a prompt I get
    the following message:

    F:\Doents and Settings\Lionel van den Berg>mysqld-nt --verbose
    070224 7:24:37 [ERROR] Can't find messagefile
    'C:\mysql\share\english\errmsg.sy
    s'
    070224 7:24:37 [ERROR] Aborting


    F:\Doents and Settings\Lionel van den Berg>

    There was an old bug report about this but the problem was fixed and I
    made sure I got the very latest version.

    Anyone got any idea what I can do to get it to run or look in the
    correct spot for errmsg.sy? MySQL doesn't even install to c:\mysql as
    I'm sure everyone knows.

    Thanks

    Lionel.
    Lionel Guest

  2. #2

    Default Re: MySQL can't find messagefile when installed passively

    :(


    Lionel van den Berg wrote: 
    Lionel Guest

  3. #3

    Default Re: MySQL can't find messagefile when installed passively [SOLUTION]

    Lionel van den Berg wrote: 

    [SOLUTION]
    As I was installing I was adding the mysql bin directory to my path. I
    would then invoke mysqld-nt with the system command and apparently MySQL
    didn't like that. If I invoke mysqld-nt with the full path it works. The
    only critical part that I have to do this on is installing mysql as a
    service:
    c:\Program Files\MySQL\MySQL Server 5.0\bin\mysqld-nt.exe install

    I don't know if this could be classified as a bug so I'm not sure that I
    should submit a bug report?

    Lionel.
    Lionel Guest

Similar Threads

  1. INSTALLED, now HOW I FIND AND USE?
    By wicked_breaks in forum Macromedia Exchange Dreamweaver Extensions
    Replies: 2
    Last Post: March 11th, 02:19 PM
  2. ExtUtils::Installed can't find Prima?
    By pGG in forum PERL Modules
    Replies: 0
    Last Post: January 6th, 08:59 AM
  3. [newbie]how to find out a feature is installed
    By Guido Lenk in forum Sun Solaris
    Replies: 7
    Last Post: August 1st, 10:54 AM
  4. How do I find out what graphics card i have installed?
    By jayloveroni in forum Windows XP/2000/ME
    Replies: 3
    Last Post: July 15th, 06:55 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139