Professional Web Applications Themes

Need fresh look with NIS and menus - Sun Solaris

Solaris 5.6 Sparcstation 4 I have a machine that in part of a NIS domain, within an intranet. All of a sudden when the user logs into the machine, he does not get the menus that he was getting before. IE specific app menus. I set up a test box and added it to the same domain, and when I log in with his user id, I DO get his correct menus. I have been doing a stare and compare between both machines and all files seem correct. I have re-added the machine to the domain using ypinit -c, and ...

  1. #1

    Default Need fresh look with NIS and menus

    Solaris 5.6
    Sparcstation 4

    I have a machine that in part of a NIS domain, within an intranet.

    All of a sudden when the user logs into the machine, he does not get the
    menus that he was getting before. IE specific app menus.

    I set up a test box and added it to the same domain, and when I log in with
    his user id, I DO get his correct menus.

    I have been doing a stare and compare between both machines and all files
    seem correct.


    I have re-added the machine to the domain using ypinit -c, and then ypstart.
    Which is fine because I can log in with his user id, other wise I would not
    have be able to.

    The only thing that I can find different is in the /var/adm/messages I get
    an error that...
    sendmail[205]: My unqualified host name (workstn) unknown; sleeping for
    retry
    Oct 2 11:33:43 workstn sendmail[205]: unable to qualify my own domain name
    (workstn) -- using short name

    All files are the same, meaning

    hosts file
    # Internet host table
    #
    127.0.0.1 localhost
    142.161.50.104 workstn loghost
    [snipit]

    # cat nodename
    workstn
    # cat hostname.le0
    workstn
    # cat defaultdomain
    operations

    # cat nsswitch.conf
    # /etc/nsswitch.nis:
    #
    [snipit]
    # consult /etc "files" only if nis is down.
    hosts: nis [NOTFOUND=continue] files [NOTFOUND=continue] dns
    networks: nis [NOTFOUND=return] files


    As well, I copied over the
    /auto_direct
    /auto_home
    /auto_master

    # cat auto_direct
    /menus -rw,soft aug:/export/menus
    /dist -rw,soft aug:/export/dist

    The /menus (this is where the user pulls the menus from) is mounted and
    there.

    Please do not tell me to put the fully qualified host name in the host
    table, all machines in our domain are set up the same, and do not have that
    in the host file. (plus, I tried and still does not work)

    I know I am missing something...

    Any ideas where to start?

    Laura


    LHradowy Guest

  2. #2

    Default Re: Need fresh look with NIS and menus

    Hi

    LHradowy wrote: 
    [cut[

    Not just a case of locale selection at login time, or as selected
    in /etd/default/init?

    Gavin

    Gavin Guest

  3. #3

    Default Re: Need fresh look with NIS and menus


    "george" <com> wrote in message
    news:OFZeb.2059$force9.net... 

    Correct it is in the .dt folder.
    What I am getting at is that I can login on another machine, with his login
    and get the menus from his .dt folder, but when I log in on his workstation
    with the same id, I do not...


    LHradowy Guest

  4. #4

    Default Re: Need fresh look with NIS and menus


    "george" <com> wrote in message
    news:y30fb.2150$force9.net... 
    .. 
    > login 
    > workstation 
    >
    >[/ref]
    If I use another user it works....


    LHradowy Guest

  5. #5

    Default Re: Need fresh look with NIS and menus

    SORRY IT DOES NOT WORK!
    "george" <com> wrote in message
    news:y30fb.2150$force9.net... 
    .. 
    > login 
    > workstation 
    >
    >[/ref]


    LHradowy Guest

  6. #6

    Default Re: Need fresh look with NIS and menus

    MIght be wrong but I think personalised menus are in users home dir.
    Possibly in .dt hidden folder.
    George


    george Guest

  7. #7

    Default Re: Need fresh look with NIS and menus

    What happens when you log into his workstation with a different id.to his .
    I would try his to see if the problem is still there for a different user.
    George
     
    login 
    workstation 


    george Guest

Similar Threads

  1. Fresh
    By newcf in forum Coldfusion - Getting Started
    Replies: 9
    Last Post: August 29th, 08:36 PM
  2. start fresh
    By MIKE in forum AIX
    Replies: 3
    Last Post: October 9th, 08:09 PM
  3. hi, all, i'm fresh here!
    By alfred in forum PHP Development
    Replies: 1
    Last Post: September 4th, 11:48 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139