Professional Web Applications Themes

nfs setup and automount problem - Mac Applications & Software

Steven wrote:   PS: the typo here has already been corrected: nfs_server_flags="-u -t -n 4" Steven -- nl...

  1. #1

    Default Re: nfs setup and automount problem

    Steven wrote:

     

    PS: the typo here has already been corrected:

    nfs_server_flags="-u -t -n 4"


    Steven


    --
    nl


    Steven Guest

  2. #2

    Default Re: nfs setup and automount problem

    Steven wrote:


    ---8<---

     

    I think I resolved this automount problem. Automount had already
    substituted an alias for the directory "/mount/1". I removed that and
    created a new directory "1". This resolved the error.

    I still cannot get the volume to mount though. Now I get the following
    message on the FreeBSD side:

    "NFS request from unprivileged port (192.168.0.1:49167)"

    Steven

    --
    nl


    Steven Guest

  3. #3

    Default Re: nfs setup and automount problem

    Steven <nl> writes:
    [...] 

    Can you try mounting the FS on OS X from a Terminal while root?

    $ sudo mount server:/usr/www/htdocs /local/dir

    Does the error repeat?

    P.S. You may also want to ask in comp.unix.bsd.freebsd.misc. I don't
    know how many OS X users about NFS. :>

    --
    David Magda <dmagda at ee.ryerson.ca>, http://www.magda.ca/
    Because the innovator has for enemies all those who have done well under
    the old conditions, and lukewarm defenders in those who may do well
    under the new. -- Niccolo Machiavelli, _The Prince_, Chapter VI
    David Guest

  4. #4

    Default Re: nfs setup and automount problem

    On Mon, 11 Aug 2003 15:09:03 +0200, Steven wrote:

     [/ref]
     
     

    Try using the "-P" option in order to force the mount request to come
    from a privileged port.

    That is, add "-P" to the list of "opts" you are using in the automount
    entry.



    --
    Dave Seaman
    Judge Yohn's mistakes revealed in Mumia Abu-Jamal ruling.
    <http://www.commoncouragepress.com/index.cfm?action=book&bookid=228>
    Dave Guest

  5. #5

    Default Re: nfs setup and automount problem

    David Magda wrote:
     
    >
    >
    > Can you try mounting the FS on OS X from a Terminal while root?
    >
    > $ sudo mount server:/usr/www/htdocs /local/dir
    >
    > Does the error repeat?[/ref]

    Yes. Exactly the same.
     

    I already did:-)

    Steven


    --
    nl


    Steven Guest

  6. #6

    Default Re: nfs setup and automount problem

    Dave Seaman wrote:

     [/ref]


    >
    > Try using the "-P" option in order to force the mount request to come
    > from a privileged port.
    >
    > That is, add "-P" to the list of "opts" you are using in the automount
    > entry.[/ref]

    I got the same advise in comp.unix.bsd.freebsd.misc

    When I do this - "opts" = ( "w", "-P" ); - The "NFS request from
    unprivileged port (192.168.0.1:49167)" message doesn't appear anymore.
    But nothing else happens either. I don't get my prompt back, no reaction
    on the server and no mounted volume... I guess there's something else
    missing... Any ideas?

    Steven

    --
    nl


    Steven Guest

  7. #7

    Default Re: nfs setup and automount problem

    On Tue, 12 Aug 2003 02:43:06 +0200, Steven wrote: 

     [/ref]
     [/ref][/ref]
     [/ref][/ref]
     [/ref][/ref]
     [/ref]
     [/ref]
     
     

    You don't get your prompt back? I take it you mean in the Terminal.
    What command are you typing? I thought you were entering the information
    in NetInfo Manager to set up an automount.

    I'm pretty sure you don't want "w". You might possibly want "-w", but I
    don't see why. I use "opts" = ( "-s", "-P", "net", "-b" ) in NetInfo to
    define an automount from a Solaris box and it works fine (including
    read-write access). I haven't had to look at that in ages and my Solaris
    home is just always there when I want it, which is many times a day.

    Did you reboot the Mac after the failed attempts without the "-P" option?
    That's the only way to make the mount point usable again. Try deleting
    and recreating the mount point to make sure. If you can't delete it,
    something's wrong.

    You also need either a reboot or a SIGHUP to the automount daemon to
    enable the changes you made in the mounts directory. You might Google on
    "mac os x nfs automount" to find some more complete instructions.

    If fixing the "w" option and rebooting doesn't do it, then perhaps the
    problem is on the FreeBSD side.


    --
    Dave Seaman
    Judge Yohn's mistakes revealed in Mumia Abu-Jamal ruling.
    <http://www.commoncouragepress.com/index.cfm?action=book&bookid=228>
    Dave Guest

Similar Threads

  1. Automount problem (structure below mount point)
    By Tim Day in forum Linux Setup, Configuration & Administration
    Replies: 1
    Last Post: August 15th, 11:05 AM
  2. automount permissions problem
    By Neal Lippman in forum Debian
    Replies: 2
    Last Post: July 27th, 11:10 AM
  3. Automount
    By JZidar in forum Debian
    Replies: 5
    Last Post: July 4th, 05:20 PM
  4. automount on AIX 4.3.3
    By Steve Nottingham in forum AIX
    Replies: 0
    Last Post: June 26th, 10:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139