Professional Web Applications Themes

NIB Builder refuses pictures - Mac Programming

Hello All, I have tried every way I can think of - including the accepted way - of adding a .rsrc file with PICTures in it to my project and having NIB Builder see the picts. Alas, nothing is seen but broken icons. What the hell gives? It should not be this hard to get pictures here. This is ridiculous! *sigh* I'm using Panther, XCode, etc. etc. Any help would be appreciated. This also doesn't work in 10.2.8. nlexcom...

  1. #1

    Default NIB Builder refuses pictures

    Hello All,

    I have tried every way I can think of - including the accepted way -
    of adding a .rsrc file with PICTures in it to my project and having
    NIB Builder see the picts.

    Alas, nothing is seen but broken icons. What the hell gives? It should
    not be this hard to get pictures here. This is ridiculous!

    *sigh*

    I'm using Panther, XCode, etc. etc.

    Any help would be appreciated. This also doesn't work in 10.2.8.

    nlexcom
    Neil Guest

  2. #2

    Default Re: NIB Builder refuses pictures

    In article <google.com>,
    com (Neil Alexander) wrote:
     

    Give us less information. We're all psychic in here, and we like a
    challenge :-)

    Seriously, it'd help to know *WHAT* you have tried. All *you* can think
    of isn't necessary all *we* can think of, after all.

    Cheers,
    -- M. Uli Kusterer
    http://www.zathras.de
    Uli Guest

  3. #3

    Default Re: NIB Builder refuses pictures

    > Seriously, it'd help to know *WHAT* you have tried. All *you* can think 

    Sorry, I tried the "Moonshot" example in "Learning Carbon".

    I tried "import Resource File" in Nib Builder - but it doesn't show
    PICT resources.
    I tried dragging the file atop the .nib file - and it invariably goes
    to the "sounds" tab, and does nothing.

    I tried adding the file to the project in Project builder - and
    nothing shows up.

    This is weird, because I have done other applications in the past and
    they worked. I was hoping that somebody could tell me what changed.

    Thanks!

    nlexcom
    Neil Guest

  4. #4

    Default Re: NIB Builder refuses pictures

    In article <google.com>,
    com (Neil Alexander) wrote:
     

    Just drag the image straight onto the NIB doent you're working on,
    where you want it to go. I did this in one of my apps (quite a while
    ago, so I'm a bit fuzzy) but I think thats how I did it.

    --
    |\/| /| |2 |<
    mehaase(at)sas(dot)upenn(dot)edu
    Mark Guest

  5. #5

    Default Re: NIB Builder refuses pictures

    In article <google.com>,
    com (Neil Alexander) wrote:
     

    OS X doesn't use resource files. Put the pictures, as
    separate files, in your project. Interface Builder will
    show them in its 'Image' tab.

    Generally speaking, if you're using a tool as modern as
    Interface Builder, you'll have to move on from resources.


    Simon Guest

  6. #6

    Default Re: NIB Builder refuses pictures

    Thanks for your tips, but I had already tried those. Something changed
    with 10.2.8, I think. Don't know what.

    Anyway, I gave up on them and turned each pic into its own .pict file.
    *sigh*.

    nlexcom
    Neil Guest

  7. #7

    Default Re: NIB Builder refuses pictures

    In article <google.com>,
    com (Neil Alexander) wrote:
     

    Import Resource File, AFAIK, is for importing dialog layouts. Since
    NIBs aren't supposed to contain images themselves anymore, they probably
    don't support that anymore.
     

    See above. It doesn't copy images into NIBs anymore, so this will very
    likely not work.
     

    This is how it works (and it worked just fine for my app, at least with
    'cicn's). Several points you should check:

    1) Is this a data fork or resource fork res file? It may be that IB
    only supports one but not the other, I'm not sure offhand.
    2) Did you open the NIB from out of the project, so IB knows what
    project it belongs to?

    HTH,
    -- Uli
    Uli Guest

Similar Threads

  1. Shockwave refuses to work
    By neilnapier in forum Macromedia Shockwave
    Replies: 0
    Last Post: May 24th, 08:40 PM
  2. Report Builder (expression builder syntax)
    By *Ludwig* in forum Coldfusion - Getting Started
    Replies: 4
    Last Post: March 9th, 12:18 AM
  3. Acrobat 5.05 refuses to print to PDF in Win XP
    By Frank_Hurt@adobeforums.com in forum Adobe Acrobat Windows
    Replies: 10
    Last Post: June 12th, 06:58 PM
  4. Replies: 1
    Last Post: March 2nd, 03:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139