Professional Web Applications Themes

"No CSS Styles" message - Macromedia Dreamweaver

I am creating HTML pages with a linked .CSS doent, but the CSS styles window says "No CSS Styles". But, the link to the .CSS file is in the HEAD section and it works. This is true whenther I hand code a .CSS doent in Notepad, use an external CSS Editor like Stylemaster, or use the built-in CSS editor in DWMX. Am I doing something wrong? Is it a DWMX bug? Again, the stylesheet is actually working fine with my HTML doents, so this is actually just a minor annoyance that I'd like to correct, if possible. Thanks! Bob...

  1. #1

    Default "No CSS Styles" message

    I am creating HTML pages with a linked .CSS doent, but the CSS styles window says "No CSS Styles". But, the link to the .CSS file is in the HEAD section and it works.

    This is true whenther I hand code a .CSS doent in Notepad, use an external CSS Editor like Stylemaster, or use the built-in CSS editor in DWMX.

    Am I doing something wrong? Is it a DWMX bug? Again, the stylesheet is actually working fine with my HTML doents, so this is actually just a minor annoyance that I'd like to correct, if possible.

    Thanks!
    Bob


    CompuGenie webforumsuser@macromedia.com Guest

  2. #2

    Default Re: "No CSS Styles" message

    Compu:

    What styles are contained in the file?

    If they are custom classes then the message you are getting is wrong - we
    need to figure out why you are getting it.

    If they are redefined tags, then the message you are getting is correct. A
    redefined tag is applied to all matching tags on the page automatically -
    you do not really have styles that you can apply manually.

    So - show me the contents of your stylesheet.

    --
    Murray --- ICQ 71997575
    Team Macromedia Volunteer for Dreamweaver MX
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    [url]news://forums.macromedia.com/macromedia.dreamweaver[/url] - THE BEST WAY TO GET
    ANSWERS
    ==================
    [url]http://www.dreamweavermx-templates.com[/url] - Template Triage!
    [url]http://www.projectseven.com/go[/url] - DW FAQs, Tutorials & Resources
    [url]http://www.DreamweaverFAQ.com[/url] - DW FAQs, Tutorials & Resources
    [url]http://www.macromedia.com/support/search/[/url] - Macromedia (MM) Technotes
    ==================

    "CompuGenie" <webforumsusermacromedia.com> wrote in message
    news:bekr69$t7v$1forums.macromedia.com...
    > I am creating HTML pages with a linked .CSS doent, but the CSS styles
    window says "No CSS Styles". But, the link to the .CSS file is in the HEAD
    section and it works.
    >
    > This is true whenther I hand code a .CSS doent in Notepad, use an
    external CSS Editor like Stylemaster, or use the built-in CSS editor in
    DWMX.
    >
    > Am I doing something wrong? Is it a DWMX bug? Again, the stylesheet is
    actually working fine with my HTML doents, so this is actually just a
    minor annoyance that I'd like to correct, if possible.
    >
    > Thanks!
    > Bob
    >
    >

    Murray *TMM* Guest

  3. #3

    Default Re: "No CSS Styles" message

    I sure appreciate you looking at this for me, Murray! Here's a simple example without any complex inheritance or layout stuff (it works fine in IE, NS & Opera for this site; it just doesn't show up as being attached in the styles window of DWMX):

    body {
    font-family: Arial, Verdana, Helvetica, sans-serif;
    font-size: 11px;
    color: #000000;
    background-image: url(images/sealslogobackground.jpg);
    background-repeat: repeat;
    }

    td, li {
    font-family: Arial, Verdana, Helvetica, sans-serif;
    font-size: 11px;
    color:#000000;
    background-color: #FFFFFF;
    }

    p {
    font-family: Arial, Verdana, Helvetica, sans-serif;
    font-size: 11px;
    color:#000000;
    }

    h1, h2, h3, h4, h5, h6 {
    font-family: Arial, Verdana, Helvetica, sans-serif;
    }

    h1 {
    font-size: 20px;
    color: #104594;
    font-weight: bold;
    text-align: center;
    }

    h2 {
    color: #104594;
    font-size: 17px;
    text-align: center;
    }

    h3 {
    color: #104594;
    font-size: 15px;
    font-weight: bold;
    text-align: center;
    }

    h4 {
    color: #000000;
    font-size: 11px;
    font-weight: bold;
    text-align: center;
    }

    h5 {
    color: #104594;
    font-size: 11px;
    font-weight: bold;
    text-align: center;
    }

    h6 {
    color: #000000;
    font-size: 9px;
    font-weight: bold;
    text-align: center;
    }

    a:link {
    font-family: Arial, Verdana, Helvetica, sans-serif;
    color: #FF0000;
    font-weight: bold;
    text-decoration: none;
    }

    a:visited {
    font-family: Arial, Verdana, Helvetica, sans-serif;
    color: #FF0000;
    font-weight: bold;
    text-decoration: none;
    }

    a:hover {
    font-family: Arial, Verdana, Helvetica, sans-serif;
    color: #0099FF;
    text-decoration: none;
    }

    a:active {
    font-family: Arial, Verdana, Helvetica, sans-serif;
    color: #FF0000;
    font-weight: bold;
    text-decoration: none;
    }



    CompuGenie webforumsuser@macromedia.com Guest

  4. #4

    Default Re: "No CSS Styles" message

    Compu:

    There are no custom classes there. All of those styles are redefined tags
    and are automatically applied to any tag that matches the context. That's
    why you get the no styles message. There are none that you would have any
    opportunity to apply since they are all already applied.

    To see what I mean, add this style to your stylesheet -

    ..test { font-family: monospace; font-color: red; }

    Do you see styles now?

    --
    Murray --- ICQ 71997575
    Team Macromedia Volunteer for Dreamweaver MX
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    [url]news://forums.macromedia.com/macromedia.dreamweaver[/url] - THE BEST WAY TO GET
    ANSWERS
    ==================
    [url]http://www.dreamweavermx-templates.com[/url] - Template Triage!
    [url]http://www.projectseven.com/go[/url] - DW FAQs, Tutorials & Resources
    [url]http://www.DreamweaverFAQ.com[/url] - DW FAQs, Tutorials & Resources
    [url]http://www.macromedia.com/support/search/[/url] - Macromedia (MM) Technotes
    ==================

    "CompuGenie" <webforumsusermacromedia.com> wrote in message
    news:belb9t$jh1$1forums.macromedia.com...
    > I sure appreciate you looking at this for me, Murray! Here's a simple
    example without any complex inheritance or layout stuff (it works fine in
    IE, NS & Opera for this site; it just doesn't show up as being attached in
    the styles window of DWMX):
    >
    > body {
    > font-family: Arial, Verdana, Helvetica, sans-serif;
    > font-size: 11px;
    > color: #000000;
    > background-image: url(images/sealslogobackground.jpg);
    > background-repeat: repeat;
    > }
    >
    > td, li {
    > font-family: Arial, Verdana, Helvetica, sans-serif;
    > font-size: 11px;
    > color:#000000;
    > background-color: #FFFFFF;
    > }
    >
    > p {
    > font-family: Arial, Verdana, Helvetica, sans-serif;
    > font-size: 11px;
    > color:#000000;
    > }
    >
    > h1, h2, h3, h4, h5, h6 {
    > font-family: Arial, Verdana, Helvetica, sans-serif;
    > }
    >
    > h1 {
    > font-size: 20px;
    > color: #104594;
    > font-weight: bold;
    > text-align: center;
    > }
    >
    > h2 {
    > color: #104594;
    > font-size: 17px;
    > text-align: center;
    > }
    >
    > h3 {
    > color: #104594;
    > font-size: 15px;
    > font-weight: bold;
    > text-align: center;
    > }
    >
    > h4 {
    > color: #000000;
    > font-size: 11px;
    > font-weight: bold;
    > text-align: center;
    > }
    >
    > h5 {
    > color: #104594;
    > font-size: 11px;
    > font-weight: bold;
    > text-align: center;
    > }
    >
    > h6 {
    > color: #000000;
    > font-size: 9px;
    > font-weight: bold;
    > text-align: center;
    > }
    >
    > a:link {
    > font-family: Arial, Verdana, Helvetica, sans-serif;
    > color: #FF0000;
    > font-weight: bold;
    > text-decoration: none;
    > }
    >
    > a:visited {
    > font-family: Arial, Verdana, Helvetica, sans-serif;
    > color: #FF0000;
    > font-weight: bold;
    > text-decoration: none;
    > }
    >
    > a:hover {
    > font-family: Arial, Verdana, Helvetica, sans-serif;
    > color: #0099FF;
    > text-decoration: none;
    > }
    >
    > a:active {
    > font-family: Arial, Verdana, Helvetica, sans-serif;
    > color: #FF0000;
    > font-weight: bold;
    > text-decoration: none;
    > }
    >
    >
    >

    Murray *TMM* Guest

  5. #5

    Default Re: "No CSS Styles" message

    Thank you, Murray -- yes I do! This is embarrassing, but I didn't
    realize that was what the styles window was for. Since DWMX came out,
    I figured it was a bug in the program. Now I see how useful this is
    for when you create custom classes.

    Thanks again!

    Bob

    On Fri, 11 Jul 2003 07:40:59 -0400, "Murray *TMM*"
    <forumsHAHAgreat-web-sights.com> wrote:
    >Compu:
    >
    >There are no custom classes there. All of those styles are redefined
    tags
    >and are automatically applied to any tag that matches the context.
    That's
    >why you get the no styles message. There are none that you would
    have any
    >opportunity to apply since they are all already applied.
    >
    >To see what I mean, add this style to your stylesheet -
    >
    >.test { font-family: monospace; font-color: red; }
    >
    >Do you see styles now?
    CompuGenie Guest

Similar Threads

  1. can styleName="multiple styles"???
    By mitchgrrt in forum Macromedia Flex General Discussion
    Replies: 2
    Last Post: May 20th, 02:21 PM
  2. CFINPUT type="radio" w/ "value" requires "label"
    By Iceborer in forum Macromedia ColdFusion
    Replies: 2
    Last Post: February 21st, 06:16 PM
  3. I've lost my "Styles" in my Lighting Effects
    By Cindy Krueger in forum Adobe Photoshop 7, CS, CS2 & CS3
    Replies: 4
    Last Post: October 14th, 12:00 AM
  4. Founded: "Styles Repository"
    By Coen Naninck in forum Macromedia Fireworks
    Replies: 8
    Last Post: July 23rd, 08:37 PM
  5. "Start" "Program" "Menu" list is empty
    By Pete in forum Windows XP/2000/ME
    Replies: 2
    Last Post: July 10th, 10:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139