Professional Web Applications Themes

NoClassDefFoundError resulting in "500 Null" - Coldfusion Server Administration

Im being hit with the "500 null" error on every page load. CFMX7 was working fine, until restart it seems. After restart it has given me this error consistantly. The underlying Java Error is : 05/11 10:58:17 error java.lang.NoClassDefFoundError at coldfusion.CfmServlet.getFilterChain(CfmServlet.ja va:59) at coldfusion.CfmServlet.service(CfmServlet.java:101) at coldfusion.bootstrap.BootstrapServlet.service(Boot strapServlet.java:78) at jrun.servlet.ServletInvoker.invoke(ServletInvoker. java:91) at jrun.servlet.JRunInvokerChain.invokeNext(JRunInvok erChain.java:42) at jrun.servlet.JRunRequestDispatcher.invoke(JRunRequ estDispatcher.java:257) at jrun.servlet.ServletEngineService.dispatch(Servlet EngineService.java:527) at jrun.servlet.jrpp.JRunProxyService.invokeRunnable( JRunProxyService.java:204) at jrunx.scheduler.ThreadPool$DownstreamMetrics.invok eRunnable(ThreadPool.java:349) at jrunx.scheduler.ThreadPool$ThreadThrottle.invokeRu nnable(ThreadPool.java:457) at jrunx.scheduler.ThreadPool$UpstreamMetrics.invokeR unnable(ThreadPool.java:295) at jrunx.scheduler.WorkerThread.run(WorkerThread.java :66) I have restarted services, restarted the computer, uninstalled and reinstalled connectors using the bat files AND by using the java configurer. I'm stuck, lost, and on ...

  1. #1

    Default NoClassDefFoundError resulting in "500 Null"

    Im being hit with the "500 null" error on every page load. CFMX7 was working
    fine, until restart it seems. After restart it has given me this error
    consistantly. The underlying Java Error is :

    05/11 10:58:17 error
    java.lang.NoClassDefFoundError
    at coldfusion.CfmServlet.getFilterChain(CfmServlet.ja va:59)
    at coldfusion.CfmServlet.service(CfmServlet.java:101)
    at coldfusion.bootstrap.BootstrapServlet.service(Boot strapServlet.java:78)
    at jrun.servlet.ServletInvoker.invoke(ServletInvoker. java:91)
    at jrun.servlet.JRunInvokerChain.invokeNext(JRunInvok erChain.java:42)
    at jrun.servlet.JRunRequestDispatcher.invoke(JRunRequ estDispatcher.java:257)
    at jrun.servlet.ServletEngineService.dispatch(Servlet EngineService.java:527)
    at
    jrun.servlet.jrpp.JRunProxyService.invokeRunnable( JRunProxyService.java:204)
    at
    jrunx.scheduler.ThreadPool$DownstreamMetrics.invok eRunnable(ThreadPool.java:349)
    at
    jrunx.scheduler.ThreadPool$ThreadThrottle.invokeRu nnable(ThreadPool.java:457)
    at
    jrunx.scheduler.ThreadPool$UpstreamMetrics.invokeR unnable(ThreadPool.java:295)
    at jrunx.scheduler.WorkerThread.run(WorkerThread.java :66)

    I have restarted services, restarted the computer, uninstalled and reinstalled
    connectors using the bat files AND by using the java configurer. I'm stuck,
    lost, and on the clock. Can anyone help me?

    Mike Carper Guest

  2. #2

    Default Re: NoClassDefFoundError resulting in "500 Null"

    I should also mention that upon startup of the coldfusion service, i recieve a
    large Java error whose message is summarized as:

    java.lang.StackOverflowError
    at
    coldfusion.log.CFFileAppender$AppendPrivilegeActio n.run(CFFileAppender.java:98)
    at java.security.AccessController.doPrivileged(Native Method)
    at coldfusion.log.CFFileAppender.doAppend(CFFileAppen der.java:72)
    at
    org.apache.log4j.helpers.AppenderAttachableImpl.ap pendLoopOnAppenders(AppenderAt
    tachableImpl.java:57)

    that last line, and its hierarchy of methods is repeated 94 times, its a
    LoopOn Appenders, apparently (the method name i assume). for some reason that
    loop is failing.

    then written at the end of that message is this one:
    [0]javax.servlet.ServletException
    at
    coldfusion.bootstrap.ClassloaderHelper.initServlet Class(ClassloaderHelper.java:1
    02)
    at coldfusion.bootstrap.BootstrapServlet.init(Bootstr apServlet.java:48)
    at
    jrun.servlet.WebApplicationService.loadServlet(Web ApplicationService.java:1243)
    at
    jrun.servlet.WebApplicationService.preloadServlets (WebApplicationService.java:79
    0)
    at
    jrun.servlet.WebApplicationService.postStart(WebAp plicationService.java:297)
    at jrun.ea.EnterpriseApplication.start(EnterpriseAppl ication.java:203)
    at jrun.deployment.DeployerService.initModules(Deploy erService.java:710)
    at
    jrun.deployment.DeployerService.createWatchedDeplo yment(DeployerService.java:242
    )
    at jrun.deployment.DeployerService.deploy(DeployerSer vice.java:430)
    at jrun.deployment.DeployerService.handleEvent(Deploy erService.java:381)
    at jrunx.kernel.JRunServiceDeployer.fireEvent(JRunSer viceDeployer.java:710)
    at
    jrunx.kernel.JRunServiceDeployer.deployServices(JR unServiceDeployer.java:111)
    at jrunx.kernel.DeploymentService.loadServices(Deploy mentService.java:46)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknow n Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.sun.management.jmx.MBeanServerImpl.invoke(MBea nServerImpl.java:1628)
    at com.sun.management.jmx.MBeanServerImpl.invoke(MBea nServerImpl.java:1523)
    at jrunx.kernel.JRun.startServer(JRun.java:575)
    at jrunx.kernel.JRun.<init>(JRun.java:493)
    at jrunx.kernel.JRun$1.run(JRun.java:346)
    at java.security.AccessController.doPrivileged(Native Method)
    at jrunx.kernel.JRun.start(JRun.java:343)
    at jrunx.kernel.JRun.startByNTService(JRun.java:427)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknow n Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Un known Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at jrunx.kernel.JRun.invoke(JRun.java:180)
    at jrunx.kernel.JRun.main(JRun.java:168)

    Mike Carper Guest

  3. #3

    Default Re: NoClassDefFoundError resulting in "500 Null"

    Well, unfortunately, a reinstall of CF fixed the issue. I have yet to restart
    the machine however. I dont consider this to be a fix though, since
    reinstalling on my production server WONT be an option.

    Mike Carper Guest

  4. #4

    Default Re: NoClassDefFoundError resulting in "500 Null"

    Seems liker people have been running into installatioin issues little bit more
    than earlier versions.
    HEre is a quick check list:
    1) Make sure that your installer is right:
    [url]http://www.macromedia.com/cfusion/tdrc/index.cfm?product=coldfusion[/url]
    2) There are a couple of issues with Windows 2003 Sp1
    Running JRun Updaters, Flex 1.0, or ColdFusion MX 6.1 installers or updaters
    on Windows 2003
    [url]http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=b39c1803[/url]

    3) On Windows, the user installing ColdFusion MX 7 must have Administrative
    privileges. Also, the following accounts should have Administrative
    privileges:
    IUSR_{Machine Name}
    IWAM_{Machine Name}
    NT AUTHORITY\Local Service
    NT AUTHORITY\Network
    NT AUTHORITY\Network Service
    NT AUTHORITY\Service
    NT AUTHORITY\System

    Although these accounts typically have Administrative privileges,
    they may be locked down in highly secured environments.
    If you install ColdFusion MX 7 without the appropriate privileges, the
    Install Wizard is unable to create the appropriate directory structure.

    HTH
    Boby Thomas

    bthomas Guest

  5. #5

    Default Re: NoClassDefFoundError resulting in "500 Null"

    Yes, My accounts were all fine. i think it had somthing to do with a spell
    checker Jar file i had loaded, and i think since the path of the jar file
    hadnt (or maybe had automatically been) added to the classpath, that it either
    couldnt find the spellchecker, or, most likely, it was incompatible with mx 7,
    ( since the settings were transfered from the existing mx 6.1 install ). I'm
    scared to put the classpath back in for this jar file, as i dont want to have
    to reinstall again.

    Is there anyway to test if a java app will work without adding it permanently
    into the classpath, like some way to access the app by loading it up at
    runtime, and not on startup? Because if i put that line back in the
    administrator, and restart the server, there is a good chance i'll not be able
    to get back into the administrator, and I dont know how to alter the clsspatch
    outside of the admin, I couldnt find an xml settings file for the
    javasettings...as i figure they're added to the shell command that starts CF.

    I should mention that I'm on Single Server type. Not running on Jrun4

    Mike Carper Guest

  6. #6

    Default Re: NoClassDefFoundError resulting in "500 Null"

    i got exactly the same issue after restarting the services after i'd installed
    hotfix2 for mx7. everything was fine b4 that, even uninstalled and tried it all
    again just to make sure that was the problem!!! Any1 sorted this????

    swirl80 Guest

Similar Threads

  1. Replies: 0
    Last Post: October 11th, 11:23 PM
  2. Replies: 0
    Last Post: October 11th, 11:12 PM
  3. cfqueryparam ignores null="yes" when list="yes"
    By Matt W. in forum Coldfusion Database Access
    Replies: 1
    Last Post: April 22nd, 07:51 PM
  4. "null null" error on line -1
    By multiscan01 in forum Coldfusion - Advanced Techniques
    Replies: 3
    Last Post: August 10th, 06:20 PM
  5. javascript help needed: Trapping "null" from pop up menu so it doesn't display
    By Steve_Egge@adobeforums.com in forum Adobe Acrobat Windows
    Replies: 3
    Last Post: May 20th, 08:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139