Professional Web Applications Themes

not reading sysctl.conf?? - Ubuntu

I have tweaked my broadband settings and I have saved them to my sysctl.conf file. After every reboot, I have to sudo sysctl -p to get the settings loaded. Is there another config file that Ubuntu is reading on boot up that takes precedence over sysctl.conf? Any help would be appreciated....

  1. #1

    Default not reading sysctl.conf??

    I have tweaked my broadband settings and I have saved them to my
    sysctl.conf file. After every reboot, I have to sudo sysctl -p to get the
    settings loaded. Is there another config file that Ubuntu is reading on
    boot up that takes precedence over sysctl.conf? Any help would be
    appreciated.
    mike Guest

  2. #2

    Default Re: not reading sysctl.conf??

    mike wrote: 

    Read the comments at the top of sysctl.conf.

    J
    Jeroen Guest

  3. #3

    Default Re: not reading sysctl.conf??

    On Sun, 15 Oct 2006 18:00:26 +0200, Jeroen Geilman wrote:
     
    >
    > Read the comments at the top of sysctl.conf.
    >
    > J[/ref]

    Oh geez, <smacks head repeatedly>

    talk about not seeing the forest for the trees.....

    Thanks

    mike Guest

  4. #4

    Default Re: not reading sysctl.conf??

    On Sun, 15 Oct 2006 18:00:26 +0200, Jeroen Geilman wrote:
     
    >
    > Read the comments at the top of sysctl.conf.
    >
    > J[/ref]
    ok, I added settings to my /etc/network/options (I created the file).
    Still no joy. Sysctl.conf is suppose to be read on startup, why is it no
    applying the settings?? Did I format them wrong? (this works using sysctl
    -p)

    The following was added to my sysctl.conf file:
    net.core.rmem_default = 127424
    net.core.rmem_max = 127424
    net.core.wmem_default = 127424
    #net.core.wmem_default = 524288
    net.core.wmem_max = 127424
    net.ipv4.tcp_wmem = 4096 87380 127424
    net.ipv4.tcp_rmem = 4096 87380 127424
    net.ipv4.tcp_mem = 524288 524288 127424
    net.ipv4.tcp_rfc1337 = 1
    net.ipv4.ip_no_pmtu_disc = 0
    net.ipv4.tcp_sack = 1
    net.ipv4.tcp_fack = 1
    net.ipv4.tcp_window_scaling = 4
    net.ipv4.tcp_timestamps = 1
    net.ipv4.tcp_ecn = 0
    net.ipv4.route.flush = 1



    mike Guest

  5. #5

    Default Re: not reading sysctl.conf??

    On Sat, 14 Oct 2006 20:26:02 -0700, mike wrote:
     

    meh, I added sysctl -p /etc/sysctl.conf to my /etc/rc.local file. It
    loads it on startup now. <scratches head> I really thought it should
    have been read automatically

    mike Guest

  6. #6

    Default Re: not reading sysctl.conf??

    mike wrote:
     

    Wrong syntax - read the sysctl.conf file! :)


    J.
    Jeroen Guest

Similar Threads

  1. dma/sysctl
    By Luciano in forum FreeBSD
    Replies: 2
    Last Post: March 6th, 12:11 AM
  2. postgresql.conf
    By John Cunningham in forum PostgreSQL / PGSQL
    Replies: 10
    Last Post: December 22nd, 08:58 PM
  3. reading a httpd.conf file
    By Chad Kellerman in forum PERL Beginners
    Replies: 1
    Last Post: January 23rd, 03:42 PM
  4. resolv.conf
    By Timo Kamph in forum Debian
    Replies: 3
    Last Post: July 29th, 10:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139