Professional Web Applications Themes

only packages with major numbers <= 3 are supported by this version of RPM ? - Linux Setup, Configuration & Administration

does this mean I need a newer version of rpm program? I'm running Linux-Mandrake 7.1 GPL . ------------------------------------------start-------------------------------------------- [rootlocalhost /tmp]# rpm -qpi ksh93-2000.10.31.0-1.i386.rpm only packages with major numbers <= 3 are supported by this version of RPM query of ksh93-2000.10.31.0-1.i386.rpm failed [rootlocalhost /tmp]# ------------------------------------------end-------------------------------------------- Thanx in advance. -- \|/ Onismus o o __________________________________oOO_(_)_OOo_____ _________________________ E-Business and Information Management | Tel: +27 11 350 3414 Knowledge Discovery & Dissemination | Fax: +27 11 350 8585 onismusr-AT-absa-DOT-co-DOT-za | Cel: +27 83 591 5310 __________________________________________________ _________________________...

  1. #1

    Default only packages with major numbers <= 3 are supported by this version of RPM ?

    does this mean I need a newer version of rpm program? I'm running Linux-Mandrake 7.1 GPL .


    ------------------------------------------start--------------------------------------------

    [rootlocalhost /tmp]# rpm -qpi ksh93-2000.10.31.0-1.i386.rpm
    only packages with major numbers <= 3 are supported by this version of RPM
    query of ksh93-2000.10.31.0-1.i386.rpm failed
    [rootlocalhost /tmp]#

    ------------------------------------------end--------------------------------------------

    Thanx in advance.

    -- \|/
    Onismus o o
    __________________________________oOO_(_)_OOo_____ _________________________
    E-Business and Information Management | Tel: +27 11 350 3414
    Knowledge Discovery & Dissemination | Fax: +27 11 350 8585
    onismusr-AT-absa-DOT-co-DOT-za | Cel: +27 83 591 5310
    __________________________________________________ _________________________

    Onismus Guest

  2. #2

    Default Re: only packages with major numbers <= 3 are supported by this version of RPM ?

    "Onismus Radebe" <onismusrATabsaDOTcoDOTzaza> wrote in message
    news:3ffb9da5$0$is.co.za... 
    Linux-Mandrake 7.1 GPL .

    Yes. why ?

    you might be suprised to find that 4 is NOT <= 3. 4 is > 3.


    here ends your free lessons.


    Leon. Guest

  3. #3

    Default Re: only packages with major numbers <= 3 are supported by this version of RPM ?


    "Leon." <noemail.com> wrote in message
    news:3ffbd1b4$rivernet.com.au... 
    > Linux-Mandrake 7.1 GPL .
    >
    > Yes. why ?
    >
    > you might be suprised to find that 4 is NOT <= 3. 4 is > 3.
    >
    >
    > here ends your free lessons.
    >
    >[/ref]

    It's my understanding that Mandrake is using the same package manager as
    redhat. So I downloaded rpm version 4 (for redhat 7.2) and i got the
    dependency errors. Maybe I should also mention that I've been using linux
    for 3 months so I'm still a newbie.

    [rootlocalhost /tmp]# rpm -i --test rpm-4.0.3-1.03.i386.rpm
    error: failed dependencies:
    popt = 1.6.3 is needed by rpm-4.0.3-1.03
    rpmlib(CompressedFileNames) <= 3.0.4-1 is needed by rpm-4.0.3-1.03
    libbz2.so.1 is needed by rpm-4.0.3-1.03
    libc.so.6(GLIBC_2.2) is needed by rpm-4.0.3-1.03
    libc.so.6(GLIBC_2.2.3) is needed by rpm-4.0.3-1.03
    [rootlocalhost /tmp]#


    Thanx in advance

    -- \|/
    Onismus o o
    __________________________________oOO_(_)_OOo_____ _________________________
    E-Business and Information Management | Tel: +27 11 350 3414
    Knowledge Discovery & Dissemination | Fax: +27 11 350 8585
    onismusr-AT-absa-DOT-co-DOT-za | Cel: +27 83 591 5310
    __________________________________________________ _________________________

    Onismus Guest

  4. #4

    Default Re: only packages with major numbers <= 3 are supported by this version of RPM ?


    "Onismus Radebe" <onismusrATabsaDOTcoDOTzaza> wrote in message
    news:3ffe4281$0$is.co.za... 
    > > Linux-Mandrake 7.1 GPL .
    > >
    > > Yes. why ?
    > >
    > > you might be suprised to find that 4 is NOT <= 3. 4 is > 3.
    > >
    > >
    > > here ends your free lessons.
    > >
    > >[/ref]
    >
    > It's my understanding that Mandrake is using the same package manager as
    > redhat. So I downloaded rpm version 4 (for redhat 7.2) and i got the
    > dependency errors. Maybe I should also mention that I've been using linux
    > for 3 months so I'm still a newbie.
    >
    > [rootlocalhost /tmp]# rpm -i --test rpm-4.0.3-1.03.i386.rpm
    > error: failed dependencies:
    > popt = 1.6.3 is needed by rpm-4.0.3-1.03
    > rpmlib(CompressedFileNames) <= 3.0.4-1 is needed by rpm-4.0.3-1.03
    > libbz2.so.1 is needed by rpm-4.0.3-1.03
    > libc.so.6(GLIBC_2.2) is needed by rpm-4.0.3-1.03
    > libc.so.6(GLIBC_2.2.3) is needed by rpm-4.0.3-1.03
    > [rootlocalhost /tmp]#[/ref]

    You can't just swap random packages from RedHat releases into Mandrake. You
    probably need to recompile from the SRPM, in order to address the library
    dependencies which will be fairly distinct for your particular distribution.

    But why not use the latest Mandrake RPM package instead?


    Nico Guest

Similar Threads

  1. What is the Supported Java Version
    By MudockSR in forum Coldfusion Server Administration
    Replies: 3
    Last Post: March 27th, 12:18 PM
  2. #40707 [NEW]: checking for db4 major version... Header contains different version
    By BLentz at channing-bete dot com in forum PHP Bugs
    Replies: 3
    Last Post: March 3rd, 08:13 PM
  3. HTTP Version Not Supported
    By MA in forum ASP.NET Web Services
    Replies: 2
    Last Post: March 21st, 05:45 PM
  4. What version of MySQL are supported by CFMX7?
    By Andrew Dixon in forum Coldfusion Database Access
    Replies: 4
    Last Post: March 9th, 12:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139