Professional Web Applications Themes

openntpd UTC problem - FreeBSD

Has anybody had any luck with getting OpenNTPD (net/openntpd) to work with anything other than UTC? I'm on GMT and recently we moved into daylight savings. As OpenNTPD has decided that I'm on UTC, I'm now an hour out (which is causing a few problems, as you can probably guess). Any help would be appreciated, Mark -- PGP: http://www.darklogik.org/pub/pgp/pgp.txt B776 43DC 8A5D EAF9 2126 9A67 A7DA 390F DEFF 9DD1 -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.0 (FreeBSD) iQIVAwUBQkjDDafaOQ/e/53RAQrvVA/7B8w4fVNSCcW7Crpp1RM9wBwcDRyWgh5+ jqFHp/VOoval/gCeIL4N+wessrRVKIIpD1+ZDVPsyWFV2Oh/9KOspXVbe/3WmnBr i3/nAbqxTrVfa7MYqsbR8SgUEYDuvaiZMiyyP7OJxA0+nZDUTAdwq n9FeeoWtfgC EqvAg3JB0I7BMSPCVwaUmE7/aLg7DQ1ZqfEUrlSJl4O54NgA87Au/W0iWHUii/jl AyJK+oYzajNeanQAeKTiq4QL7Bg2lyo6q9dzMGhDngbCtNb4pt J5kT7zdrp0K/2f w143K6k6SYnGQdiGr2lnox1oHOPRLZVsTCaEFU86uczr48Et4G nT/7z9fi/b9oPc YK0If9NhFQMHK4uIxkBnDVWxdE7heB+DFe4+/2qoykHHZ1ttWvTn3JsBSx5qF74q 4CTX86H3ZA6FiGwxEFH0mk7vhpS405L5c0WGy7SZd8+Y2cnZnb nelYLPa1Tt5qJD 86MyV9m4eG+zxfh5w6JauyiqDwTXb/sXLVnC+PNb58dPwGnmogXbR6aNTAQHUa+6 cmefilA6/o2Z9NToz0fhLSgPNTw1eOjYLsrdLy/iEya/o0QGgGXiaELssUrEFAR/ 9zVfH0bS/qs8GBRi4QjRwGOPfeh8AMZ0aF9MtIYndpbEcIe1Cx1Sujtdeib W+qgm TE+7tgqkWmQ= =Bm4v -----END PGP SIGNATURE-----...

  1. #1

    Default openntpd UTC problem

    Has anybody had any luck with getting OpenNTPD (net/openntpd) to work
    with anything other than UTC? I'm on GMT and recently we moved into
    daylight savings. As OpenNTPD has decided that I'm on UTC, I'm now
    an hour out (which is causing a few problems, as you can probably
    guess).

    Any help would be appreciated,
    Mark

    --
    PGP: http://www.darklogik.org/pub/pgp/pgp.txt
    B776 43DC 8A5D EAF9 2126 9A67 A7DA 390F DEFF 9DD1

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.0 (FreeBSD)

    iQIVAwUBQkjDDafaOQ/e/53RAQrvVA/7B8w4fVNSCcW7Crpp1RM9wBwcDRyWgh5+
    jqFHp/VOoval/gCeIL4N+wessrRVKIIpD1+ZDVPsyWFV2Oh/9KOspXVbe/3WmnBr
    i3/nAbqxTrVfa7MYqsbR8SgUEYDuvaiZMiyyP7OJxA0+nZDUTAdwq n9FeeoWtfgC
    EqvAg3JB0I7BMSPCVwaUmE7/aLg7DQ1ZqfEUrlSJl4O54NgA87Au/W0iWHUii/jl
    AyJK+oYzajNeanQAeKTiq4QL7Bg2lyo6q9dzMGhDngbCtNb4pt J5kT7zdrp0K/2f
    w143K6k6SYnGQdiGr2lnox1oHOPRLZVsTCaEFU86uczr48Et4G nT/7z9fi/b9oPc
    YK0If9NhFQMHK4uIxkBnDVWxdE7heB+DFe4+/2qoykHHZ1ttWvTn3JsBSx5qF74q
    4CTX86H3ZA6FiGwxEFH0mk7vhpS405L5c0WGy7SZd8+Y2cnZnb nelYLPa1Tt5qJD
    86MyV9m4eG+zxfh5w6JauyiqDwTXb/sXLVnC+PNb58dPwGnmogXbR6aNTAQHUa+6
    cmefilA6/o2Z9NToz0fhLSgPNTw1eOjYLsrdLy/iEya/o0QGgGXiaELssUrEFAR/
    9zVfH0bS/qs8GBRi4QjRwGOPfeh8AMZ0aF9MtIYndpbEcIe1Cx1Sujtdeib W+qgm
    TE+7tgqkWmQ=
    =Bm4v
    -----END PGP SIGNATURE-----

    markzero Guest

  2. #2

    Default Re: openntpd UTC problem

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    On 2005-03-29, markzero scribbled these
    curious markings: 

    It's "Just Worked"[tm] for me, on all three of my systems (OpenBSD
    3.6/3.7-current, FreeBSD 4.10-stable (yes, I know, but after tonight
    that installation will be history), and FreeBSD 5-STABLE). I'm in EST.
    Isn't there a setting for your timezone that configures whether your
    system clock is set to UTC?

    Best Regards,
    Christopher Nehren
    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.0 (FreeBSD)

    iD8DBQFCSMf7k/lo7zvzJioRApvSAJ4zaIWHXOqAW/DUvaNe2JhK3rouJwCfXQ9o
    rL1ExXs11CvYrZv573T6j/M=
    =nHRl
    -----END PGP SIGNATURE-----

    --
    I abhor a system designed for the "user", if that word is a coded
    pejorative meaning "stupid and unsophisticated". -- Ken Thompson
    If you ask the wrong questions, you get answers like "42" and "God".
    Unix is user friendly. However, it isn't idiot friendly.

    Christopher Guest

  3. #3

    Default Re: openntpd UTC problem

    > On 2005-03-29, markzero scribbled these 
    >
    > It's "Just Worked"[tm] for me, on all three of my systems (OpenBSD
    > 3.6/3.7-current, FreeBSD 4.10-stable (yes, I know, but after tonight
    > that installation will be history), and FreeBSD 5-STABLE). I'm in EST.
    > Isn't there a setting for your timezone that configures whether your
    > system clock is set to UTC?[/ref]

    Hmm, the closest I can get is to symlink /usr/share/zoneinfo/GMT with
    /etc/localtime. I'm still an hour off though, as the ntpd isn't taking
    daylight savings into consideration.

    Mark

    --
    PGP: http://www.darklogik.org/pub/pgp/pgp.txt
    B776 43DC 8A5D EAF9 2126 9A67 A7DA 390F DEFF 9DD1

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.4.0 (FreeBSD)

    iQIVAwUBQkjTS6faOQ/e/53RAQpFehAApgsXlrTF27iVgALrgHFSSJoYJybyudZ3
    qtRx6jGpFLUW2fk+OtIt7UEY7u9cmcitLA9BzOsqe7yVb5UTH3 URdhIooEUp+aj/
    zOeO3Pcl8zEGiafZZ58lJHN5s8zfzEUz51s+oXqRLpgM0sVQxQ 2VJTZW353vsuye
    TO5gHqyrbsoc0t7Aa8WmBE3pj4AXXi5HnbPdgNuvJaZGwnnXwu ZgnSWWy0aLEEGL
    /eCwTfJzqCN08Uva/IJm/4gf1Gutwv1+eXzr0zKTXqiQu5NX8pcaZrHtQvZnSQoo
    sLLuwMN3/Tl8JlWWfs8n+eK49QONvWcYBIdAQRS1vJVze6RASteyoegQFLS gio4O
    6QKRDZUefJD1ZPJcW4NvwEP+hwVkIa+03ljzMqzhWgkXbdCknN gEwukUMx5E1Gxu
    wOMbKKCVCS+xzBBTjIdtWq4Y7FxcLBJ6OkQ9OPkE7Kpof+NeM7 rOd+wmtfvlrsub
    ddfOYmmlSQsOV5wh9XKaTpMtpFRNGnALKu8+zPlQfaKwkfGyu0 rJAWQrcDIARugG
    8j3HPrr39tiTy9PVdaGkkbmHE9WBhohyxFVYqtzFpDJEzf1vZq/jNNnqbt7axw+D
    LwuoDgT2hdwKCl0y9uH6jnO6tvPcSFGhihtGlB4UE9wuogPV3R wACqSxvmyEV61A
    9TEfGoZ3scM=
    =OPQo
    -----END PGP SIGNATURE-----

    markzero Guest

  4. #4

    Default Re: openntpd UTC problem

    markzero writes:
     

    UTC is the same as GMT, within a few seconds. Neither time zone
    observes any change in the summer months. If you want a change in
    summer, you might try something like WET (Western European Time), which
    is the same as GMT except that it switches to summer time during the
    summer. You can use tzsetup to pick a time zone. Remember also that
    your local real-time clock on your machine should be set to UTC. The
    NTP protocol always uses UTC internally.

    --
    Anthony


    Anthony Guest

  5. #5

    Default Re: openntpd UTC problem



    markzero wrote:
     

    ntp (open and otherwise) only deals in UTC - the time the system shows
    when you you type 'date' is a function of UTC and the timezone setting
    for the system. run sysinstall then select configure and timezone to
    set the correct timezone from the menu.

    On another note openntp is not particularly accurate (if you can live
    with +/- 100ms then fine otherwise use ntpd)


    John


    John Guest

  6. #6

    Default Re: openntpd UTC problem

    On Tuesday 29 March 2005 05:42, Anthony Atkielski wrote: 
    >
    > UTC is the same as GMT, within a few seconds. Neither time zone
    > observes any change in the summer months. If you want a change in
    > summer, you might try something like WET (Western European Time), which
    > is the same as GMT except that it switches to summer time during the
    > summer. You can use tzsetup to pick a time zone. Remember also that
    > your local real-time clock on your machine should be set to UTC.[/ref]

    Not necessarily, if you run a dual-boot computer with windows you normally set
    your cmos clock to local time and let the less flexible OS handle the
    change-over.

    There's a sysinstall menu entry for setting your location, and type of clock,
    which I presumably forgot to set (one of the pitfalls of living in GMT). I
    had similar problems which all sorted themselves out when I ran sysinstall
    and rebooted. My time zone is now BST.



    RW Guest

Similar Threads

  1. contribute problem - access denied file may not existpermission problem
    By Al1973 in forum Macromedia Contribute Connection Administrtion
    Replies: 6
    Last Post: September 17th, 04:16 PM
  2. Replies: 2
    Last Post: September 30th, 12:13 PM
  3. Replies: 0
    Last Post: August 2nd, 03:03 PM
  4. Replies: 2
    Last Post: July 17th, 07:27 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139