Professional Web Applications Themes

Openssh Slow on 5.07 - SCO

In article <bJhRa.7892$r35.1703fe03.atl2.webusenet.com>, willjay <willjayexcite.com> wrote: >I just installed 5.07 on a Compaq Pentium Pro Quad 200mz >Proliant. Openssh is very slow to login and screen updates >freeze for periods of 4 - 5 seconds. Overall slow - or just a very long time to get logged in. If the latter the machine doesn't have enough horsepower. I used to get slow logins in a remote machine and a HW upgrade impoved the login time dramatically. -- Bill Vermillion - bv wjv . com...

  1. #1

    Default Re: Openssh Slow on 5.07

    In article <bJhRa.7892$r35.1703fe03.atl2.webusenet.com>, willjay
    <willjayexcite.com> wrote:
    >I just installed 5.07 on a Compaq Pentium Pro Quad 200mz
    >Proliant. Openssh is very slow to login and screen updates
    >freeze for periods of 4 - 5 seconds.
    Overall slow - or just a very long time to get logged in.

    If the latter the machine doesn't have enough horsepower.

    I used to get slow logins in a remote machine and a HW upgrade
    impoved the login time dramatically.


    --
    Bill Vermillion - bv wjv . com
    Bill Vermillion Guest

  2. #2

    Default Re: Openssh Slow on 5.07

    willjay wrote:
    >
    > I just installed 5.07 on a Compaq Pentium Pro Quad 200mz Proliant. Openssh
    > is very slow to login and screen updates freeze for periods of 4 - 5
    > seconds.
    >
    > What's my options.
    >
    > Thanks
    > wj
    Is this on a LAN or a WAN/VPN/internet connection? A quad PP200 should have
    lots of power to run an ssh session. I am wondering if you are seeing a
    MTU problem instead. If you are running through routers etc., then try
    reducing the MTU to 1380 from 1500.

    Mike

    --
    Michael Brown

    The Kingsway Group
    Mike Brown Guest

  3. #3

    Default Re: Openssh Slow on 5.07

    willjay wrote:
    > I guess it is the encryption and compression that is at fault. My question
    > is why my store bought ssh works fine and Openssh does not.
    >
    Have you tried with the "-C" flag (compression disabled) and the "+C"
    flag (compression enabled) ?

    Any difference ?

    Best,
    Roberto

    --
    ---------------------------------------------------------------------
    Roberto Zini email : r.zini<AT>strhold.it
    Technical Support Manager -- Strhold Evolution Division R.E. (ITALY)
    ---------------------------------------------------------------------
    "Has anybody around here seen an aircraft carrier?"
    (Pete "Maverick" Mitchell - Top Gun)

    Roberto Zini Guest

  4. #4

    Default Re: Openssh Slow on 5.07

    I have experienced this on 3 different systems, slower cpu's 400mhz or less
    that is, and I do see a big difference. What happens is the screen updates,
    and hesitates for about 1 or 2 sec then finishs. It is consistently
    hesitant, not under loads, that is.



    "Jean-Pierre Radley" <jprjpr.com> wrote in message
    news:20030717005130.GB18752jpradley.jpr.com...
    > willjay typed (on Thu, Jul 17, 2003 at 07:19:37PM -0400):
    >
    > | "Jean-Pierre Radley" <jprjpr.com> wrote in message
    > | news:20030716204419.GA3917jpradley.jpr.com...
    > |
    > | > willjay typed (on Thu, Jul 17, 2003 at 03:40:31PM -0400):
    > | >
    > | > | I just installed 5.07 on a Compaq Pentium Pro Quad 200mz
    > | > | Proliant. Openssh is very slow to login and screen updates freeze
    > | > | for periods of 4 - 5 seconds.
    > | >
    > | > What platform are you coming *from*, and is going to the 5.0.7 box
    > | > any slower or faster using ssh vs. telnet?
    >
    > Top-posting reverted. :-)
    >
    > | I'm coming from 5.06 with ssh installed. ssh worked fine on this
    > | Proliant
    > |
    > | Openssh is much slower than telnet. I tested telnet and it works just
    > | fine. I check Tinyterm and Anzio and both have the hesitation. Are
    > | there any tunable parameters?
    >
    > I run ssh and telnet from 5.0.6 to 5.0.7, or the other way around, and see
    > abolutely no speed differences.
    >
    > --
    > JP


    willjay Guest

  5. #5

    Default Re: Openssh Slow on 5.07

    Stephen M. Dunn wrote:
    > In article <bJhRa.7892$r35.1703fe03.atl2.webusenet.com> "willjay" <willjayexcite.com> writes:
    > $I just installed 5.07 on a Compaq Pentium Pro Quad 200mz Proliant. Openssh
    > $is very slow to login and screen updates freeze for periods of 4 - 5
    > $seconds.
    >
    > I have a client who recently upgraded from an older machine
    > (5.0.5, PIII 700 or thereabouts, openssh 3.3 or 3.4) to a new
    > single-processor Xeon 2.4 GHz with a gig of RAM and 5.0.7.
    > When I say upgraded, it was done as a fresh install on the new
    > box, and then I manually imported users via ap, moved files,
    > updated config files, etc. so I'm confident that I didn't whack
    > part of the new OS or openssh with old stuff.
    >
    > Both the client and server parts of openssh are slower on this
    > machine than on the older machine. Connecting to a remote machine
    > via ssh results in a 15-30 second (haven't actually timed it)
    > delay after providing the user name and password, before the
    > next thing shows up (the TERM= line from the .profile). Connecting
    > to the new machine from a remote machine is somewhat slower; there's
    > a delay of a few seconds (maybe 5 or so - again, haven't timed it)
    > after providing either a user name and password or user name and
    > the password for a private keyfile.
    >
    > It's not a big deal for me since I rarely need to ssh from that
    > box to another and I can deal with a 5-second delay when I connect
    > in from elsewhere. One of these days I may try turning on debugging
    > to see if I can figure out at what point it's bogging down.
    >
    > In both cases, I haven't noticed anything unusual once the
    > login has completed - screen updates etc. seem to work just as
    > well as they did on the older box.
    Stephen, your case sounds like a DNS problem. If your DNS was
    completely failing, you would see 60-second pauses. Short pauses smell
    like you have two "nameserver" lines in /etc/resolv.conf, and the first
    one points to an IP address that isn't there at all. If it pointed to a
    live machine that wasn't serving DNS, queries would get an immediate
    negative response and the querant would immediately move on to the 2nd
    server. If there's no machine at the IP address (or it's behind a
    firewall that doesn't transmit ICMP error packets), you'll get a 5-10
    second timeout before the querant moves on to the next choice.

    I have no idea about the original poster's pauses. He should do some
    basic performance ysis -- check for maxed-out CPU, that sort of
    thing.
    >Bela<
    Bela Lubkin Guest

  6. #6

    Default Re: Openssh Slow on 5.07

    Mike Brown <miketkg.ca> wrote in message news:<3F174409.9EE2EAC6tkg.ca>...
    > willjay wrote:
    > >
    > > I just installed 5.07 on a Compaq Pentium Pro Quad 200mz Proliant. Openssh
    > > is very slow to login and screen updates freeze for periods of 4 - 5
    > > seconds.
    > >
    > > What's my options.
    > >
    > > Thanks
    > > wj
    >
    > Is this on a LAN or a WAN/VPN/internet connection? A quad PP200 should have
    > lots of power to run an ssh session. I am wondering if you are seeing a
    > MTU problem instead. If you are running through routers etc., then try
    > reducing the MTU to 1380 from 1500.
    >
    > Mike

    It is an WAN/internet connection. Please explain MTU? It is thur a
    router. Actually it's very complicated connection. However, telnet is
    working fine. Just Openssh is working slowly.
    Will Jay Guest

  7. #7

    Default Re: Openssh Slow on 5.07

    Will Jay typed (on Thu, Jul 24, 2003 at 02:47:13PM -0700):
    | Mike Brown <miketkg.ca> wrote in message news:<3F174409.9EE2EAC6tkg.ca>...
    | > willjay wrote:
    | > >
    | > > I just installed 5.07 on a Compaq Pentium Pro Quad 200mz Proliant. Openssh
    | > > is very slow to login and screen updates freeze for periods of 4 - 5
    | > > seconds.
    | > >
    | > > What's my options.
    | > >
    | > > Thanks
    | > > wj
    | >
    | > Is this on a LAN or a WAN/VPN/internet connection? A quad PP200 should have
    | > lots of power to run an ssh session. I am wondering if you are seeing a
    | > MTU problem instead. If you are running through routers etc., then try
    | > reducing the MTU to 1380 from 1500.
    | >
    | > Mike
    |
    |
    | It is an WAN/internet connection. Please explain MTU? It is thur a
    | router. Actually it's very complicated connection. However, telnet is
    | working fine. Just Openssh is working slowly.

    Is compression enabled or disabled in the sshd.config file?

    It's a good speed-up if you're using PPP over modems and telephone
    lines. It's not useful otherwise.

    --
    JP
    Jean-Pierre Radley Guest

  8. #8

    Default Re: Openssh Slow on 5.07

    Will Jay wrote:
    >
    > Mike Brown <miketkg.ca> wrote in message news:<3F174409.9EE2EAC6tkg.ca>...
    > > willjay wrote:
    > > >
    > > > I just installed 5.07 on a Compaq Pentium Pro Quad 200mz Proliant. Openssh
    > > > is very slow to login and screen updates freeze for periods of 4 - 5
    > > > seconds.
    > > >
    > > > What's my options.
    > > >
    > > > Thanks
    > > > wj
    > >
    > > Is this on a LAN or a WAN/VPN/internet connection? A quad PP200 should have
    > > lots of power to run an ssh session. I am wondering if you are seeing a
    > > MTU problem instead. If you are running through routers etc., then try
    > > reducing the MTU to 1380 from 1500.
    > >
    > > Mike
    >
    > It is an WAN/internet connection. Please explain MTU? It is thur a
    > router. Actually it's very complicated connection. However, telnet is
    > working fine. Just Openssh is working slowly.
    From some of the additional info it looks like MTU is a long shot, but
    it is very easy to test. If you type in "ifconfig -a" the system will
    report back its network settings, including the MTU. Choose the interface
    that is supporting the default route, such as net0, and type
    "ifconfig net0 mtu 1380".

    Then open a ssh connection and see if its better.

    Mike

    --
    Michael Brown

    The Kingsway Group
    Mike Brown Guest

Similar Threads

  1. Bug in Contribute > openssh
    By jwever in forum Macromedia Contribute Connection Administrtion
    Replies: 0
    Last Post: March 7th, 10:01 AM
  2. updating system version of OpenSSH
    By David Newman in forum FreeBSD
    Replies: 4
    Last Post: February 27th, 03:44 PM
  3. compiling openssh 3.7p1 on aix 5.1
    By Tim Bruijnzeels in forum AIX
    Replies: 0
    Last Post: September 17th, 11:46 AM
  4. openssh on aix4.2
    By samara in forum AIX
    Replies: 4
    Last Post: August 9th, 11:37 AM
  5. OpenSSH & autostart
    By Piotr Szumny in forum AIX
    Replies: 0
    Last Post: August 5th, 03:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139