Professional Web Applications Themes

"Operation must use an updateable query".- after conversion to NTFS - ASP Database

You need to set NTFS permissions for IUSR (which weren't in place, obviously, when using FAT32). Right-click the folder, hit sharing and security, and on the security tab, make sure IUSR_MachineName is there and has read/write/modify. And stop using ODBC! [url]http://www.aspfaq.com/2126[/url] -- [url]http://www.aspfaq.com/[/url] (Reverse address to reply.) "only_me" <nospam.chris.bartleyntlworld.com> wrote in message news:oAbSc.537$Qs4.377newsfe5-gui.ntli.net... > Just converted one of my volumes to NTFS ( XP Pro), > asp sites on that volume now give " Operation must use an updateable query". > asp sites on another drive which is still FAT32 still working OK > So just a permissions thing between ...

  1. #1

    Default Re: "Operation must use an updateable query".- after conversion to NTFS

    You need to set NTFS permissions for IUSR (which weren't in place,
    obviously, when using FAT32).

    Right-click the folder, hit sharing and security, and on the security tab,
    make sure IUSR_MachineName is there and has read/write/modify.

    And stop using ODBC! [url]http://www.aspfaq.com/2126[/url]

    --
    [url]http://www.aspfaq.com/[/url]
    (Reverse address to reply.)




    "only_me" <nospam.chris.bartleyntlworld.com> wrote in message
    news:oAbSc.537$Qs4.377newsfe5-gui.ntli.net...
    > Just converted one of my volumes to NTFS ( XP Pro),
    > asp sites on that volume now give " Operation must use an updateable
    query".
    > asp sites on another drive which is still FAT32 still working OK
    > So just a permissions thing between IIS and NTFS - but where ?
    > TIA
    >
    >

    Aaron [SQL Server MVP] Guest

  2. #2

    Default "Operation must use an updateable query".- after conversion to NTFS

    Just converted one of my volumes to NTFS ( XP Pro),
    asp sites on that volume now give " Operation must use an updateable query".
    asp sites on another drive which is still FAT32 still working OK
    So just a permissions thing between IIS and NTFS - but where ?
    TIA


    only_me Guest

  3. #3

    Default Re: "Operation must use an updateable query".- after conversion to NTFS

    No security tab seen ?
    just sharing and web sharing ( and general and customise)
    in web sharing - I set share this folder and enabled write permissions since
    it wasn't already set
    No change !

    "Stop using ODBC" - I'm not, I'm using OLDB AFAIK
    i.e. "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=........"

    apologies in advance for another thread posted with same question -

    "Aaron [SQL Server MVP]" <ten.xocdnartreb.noraa> wrote in message
    news:ez5u06xfEHA.2604TK2MSFTNGP10.phx.gbl...
    > You need to set NTFS permissions for IUSR (which weren't in place,
    > obviously, when using FAT32).
    >
    > Right-click the folder, hit sharing and security, and on the security tab,
    > make sure IUSR_MachineName is there and has read/write/modify.
    >
    > And stop using ODBC! [url]http://www.aspfaq.com/2126[/url]
    >
    > --
    > [url]http://www.aspfaq.com/[/url]
    > (Reverse address to reply.)
    >
    >
    >
    >
    > "only_me" <nospam.chris.bartleyntlworld.com> wrote in message
    > news:oAbSc.537$Qs4.377newsfe5-gui.ntli.net...
    > > Just converted one of my volumes to NTFS ( XP Pro),
    > > asp sites on that volume now give " Operation must use an updateable
    > query".
    > > asp sites on another drive which is still FAT32 still working OK
    > > So just a permissions thing between IIS and NTFS - but where ?
    > > TIA
    > >
    > >
    >
    >

    only_me Guest

  4. #4

    Default Re: "Operation must use an updateable query".- after conversion toNTFS

    Disable simple file & printer sharing. If you have XP Home you need to
    boot into safe mode to do this. It will only be disabled while you are
    in safe mode so the changes may not take effect. IF you are running XP
    Home I strongly urge you to upgrade to XP Pro.

    I am glad though you are smart enough to have stopped using ODBC. I
    think he posted that because so many people who post here have no idea
    that it's a very bad idea to use ODBC.

    only_me wrote:
    > No security tab seen ?
    > just sharing and web sharing ( and general and customise)
    > in web sharing - I set share this folder and enabled write permissions since
    > it wasn't already set
    > No change !
    >
    > "Stop using ODBC" - I'm not, I'm using OLDB AFAIK
    > i.e. "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=........"
    >
    > apologies in advance for another thread posted with same question -
    >
    > "Aaron [SQL Server MVP]" <ten.xocdnartreb.noraa> wrote in message
    > news:ez5u06xfEHA.2604TK2MSFTNGP10.phx.gbl...
    >
    >>You need to set NTFS permissions for IUSR (which weren't in place,
    >>obviously, when using FAT32).
    >>
    >>Right-click the folder, hit sharing and security, and on the security tab,
    >>make sure IUSR_MachineName is there and has read/write/modify.
    >>
    >>And stop using ODBC! [url]http://www.aspfaq.com/2126[/url]
    >>
    >>--
    >>[url]http://www.aspfaq.com/[/url]
    >>(Reverse address to reply.)
    >>
    >>
    >>
    >>
    >>"only_me" <nospam.chris.bartleyntlworld.com> wrote in message
    >>news:oAbSc.537$Qs4.377newsfe5-gui.ntli.net...
    >>
    >>>Just converted one of my volumes to NTFS ( XP Pro),
    >>>asp sites on that volume now give " Operation must use an updateable
    >>
    >>query".
    >>
    >>>asp sites on another drive which is still FAT32 still working OK
    >>>So just a permissions thing between IIS and NTFS - but where ?
    >>>TIA
    >>>
    >>>
    >>
    >>
    >
    >
    joker Guest

  5. #5

    Default Re: "Operation must use an updateable query".- after conversion to NTFS

    I'm using XP pro,
    I just uninstalled "file & printer sharing" ( not simple ?)
    But that didn't change the tabs available when right clicking on the folder

    "joker" <no-spamnetzero.com> wrote in message
    news:u5KUvm3fEHA.4040TK2MSFTNGP10.phx.gbl...
    > Disable simple file & printer sharing. If you have XP Home you need to
    > boot into safe mode to do this. It will only be disabled while you are
    > in safe mode so the changes may not take effect. IF you are running XP
    > Home I strongly urge you to upgrade to XP Pro.
    >
    > I am glad though you are smart enough to have stopped using ODBC. I
    > think he posted that because so many people who post here have no idea
    > that it's a very bad idea to use ODBC.
    >
    > only_me wrote:
    >
    > > No security tab seen ?
    > > just sharing and web sharing ( and general and customise)
    > > in web sharing - I set share this folder and enabled write permissions
    since
    > > it wasn't already set
    > > No change !
    > >
    > > "Stop using ODBC" - I'm not, I'm using OLDB AFAIK
    > > i.e. "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=........"
    > >
    > > apologies in advance for another thread posted with same question -
    > >
    > > "Aaron [SQL Server MVP]" <ten.xocdnartreb.noraa> wrote in message
    > > news:ez5u06xfEHA.2604TK2MSFTNGP10.phx.gbl...
    > >
    > >>You need to set NTFS permissions for IUSR (which weren't in place,
    > >>obviously, when using FAT32).
    > >>
    > >>Right-click the folder, hit sharing and security, and on the security
    tab,
    > >>make sure IUSR_MachineName is there and has read/write/modify.
    > >>
    > >>And stop using ODBC! [url]http://www.aspfaq.com/2126[/url]
    > >>
    > >>--
    > >>[url]http://www.aspfaq.com/[/url]
    > >>(Reverse address to reply.)
    > >>
    > >>
    > >>
    > >>
    > >>"only_me" <nospam.chris.bartleyntlworld.com> wrote in message
    > >>news:oAbSc.537$Qs4.377newsfe5-gui.ntli.net...
    > >>
    > >>>Just converted one of my volumes to NTFS ( XP Pro),
    > >>>asp sites on that volume now give " Operation must use an updateable
    > >>
    > >>query".
    > >>
    > >>>asp sites on another drive which is still FAT32 still working OK
    > >>>So just a permissions thing between IIS and NTFS - but where ?
    > >>>TIA
    > >>>
    > >>>
    > >>
    > >>
    > >
    > >
    >

    only_me Guest

  6. #6

    Default Re: "Operation must use an updateable query".- after conversion to NTFS

    OK - found it !
    Needed "file & printer sharing" loaded
    It was in the "sharing" tab - under "network sharing and security"
    checked both the "share" and "allows users to change" checkboxes

    "only_me" <only_mehotmail.com> wrote in message
    news:eGQkVI4fEHA.3944tk2msftngp13.phx.gbl...
    > I'm using XP pro,
    > I just uninstalled "file & printer sharing" ( not simple ?)
    > But that didn't change the tabs available when right clicking on the
    folder
    >
    > "joker" <no-spamnetzero.com> wrote in message
    > news:u5KUvm3fEHA.4040TK2MSFTNGP10.phx.gbl...
    > > Disable simple file & printer sharing. If you have XP Home you need to
    > > boot into safe mode to do this. It will only be disabled while you are
    > > in safe mode so the changes may not take effect. IF you are running XP
    > > Home I strongly urge you to upgrade to XP Pro.
    > >
    > > I am glad though you are smart enough to have stopped using ODBC. I
    > > think he posted that because so many people who post here have no idea
    > > that it's a very bad idea to use ODBC.
    > >
    > > only_me wrote:
    > >
    > > > No security tab seen ?
    > > > just sharing and web sharing ( and general and customise)
    > > > in web sharing - I set share this folder and enabled write permissions
    > since
    > > > it wasn't already set
    > > > No change !
    > > >
    > > > "Stop using ODBC" - I'm not, I'm using OLDB AFAIK
    > > > i.e. "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=........"
    > > >
    > > > apologies in advance for another thread posted with same question -
    > > >
    > > > "Aaron [SQL Server MVP]" <ten.xocdnartreb.noraa> wrote in message
    > > > news:ez5u06xfEHA.2604TK2MSFTNGP10.phx.gbl...
    > > >
    > > >>You need to set NTFS permissions for IUSR (which weren't in place,
    > > >>obviously, when using FAT32).
    > > >>
    > > >>Right-click the folder, hit sharing and security, and on the security
    > tab,
    > > >>make sure IUSR_MachineName is there and has read/write/modify.
    > > >>
    > > >>And stop using ODBC! [url]http://www.aspfaq.com/2126[/url]
    > > >>
    > > >>--
    > > >>[url]http://www.aspfaq.com/[/url]
    > > >>(Reverse address to reply.)
    > > >>
    > > >>
    > > >>
    > > >>
    > > >>"only_me" <nospam.chris.bartleyntlworld.com> wrote in message
    > > >>news:oAbSc.537$Qs4.377newsfe5-gui.ntli.net...
    > > >>
    > > >>>Just converted one of my volumes to NTFS ( XP Pro),
    > > >>>asp sites on that volume now give " Operation must use an updateable
    > > >>
    > > >>query".
    > > >>
    > > >>>asp sites on another drive which is still FAT32 still working OK
    > > >>>So just a permissions thing between IIS and NTFS - but where ?
    > > >>>TIA
    > > >>>
    > > >>>
    > > >>
    > > >>
    > > >
    > > >
    > >
    >
    >

    only_me Guest

  7. #7

    Default Re: "Operation must use an updateable query".- after conversion to NTFS

    [url]http://www.aspfaq.com/2205[/url]

    --
    [url]http://www.aspfaq.com/[/url]
    (Reverse address to reply.)




    "only_me" <only_mehotmail.com> wrote in message
    news:u0AiNQ4fEHA.2848TK2MSFTNGP10.phx.gbl...
    > OK - found it !
    > Needed "file & printer sharing" loaded
    > It was in the "sharing" tab - under "network sharing and security"
    > checked both the "share" and "allows users to change" checkboxes
    >
    > "only_me" <only_mehotmail.com> wrote in message
    > news:eGQkVI4fEHA.3944tk2msftngp13.phx.gbl...
    > > I'm using XP pro,
    > > I just uninstalled "file & printer sharing" ( not simple ?)
    > > But that didn't change the tabs available when right clicking on the
    > folder
    > >
    > > "joker" <no-spamnetzero.com> wrote in message
    > > news:u5KUvm3fEHA.4040TK2MSFTNGP10.phx.gbl...
    > > > Disable simple file & printer sharing. If you have XP Home you need
    to
    > > > boot into safe mode to do this. It will only be disabled while you
    are
    > > > in safe mode so the changes may not take effect. IF you are running
    XP
    > > > Home I strongly urge you to upgrade to XP Pro.
    > > >
    > > > I am glad though you are smart enough to have stopped using ODBC. I
    > > > think he posted that because so many people who post here have no idea
    > > > that it's a very bad idea to use ODBC.
    > > >
    > > > only_me wrote:
    > > >
    > > > > No security tab seen ?
    > > > > just sharing and web sharing ( and general and customise)
    > > > > in web sharing - I set share this folder and enabled write
    permissions
    > > since
    > > > > it wasn't already set
    > > > > No change !
    > > > >
    > > > > "Stop using ODBC" - I'm not, I'm using OLDB AFAIK
    > > > > i.e. "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=........"
    > > > >
    > > > > apologies in advance for another thread posted with same question -
    > > > >
    > > > > "Aaron [SQL Server MVP]" <ten.xocdnartreb.noraa> wrote in message
    > > > > news:ez5u06xfEHA.2604TK2MSFTNGP10.phx.gbl...
    > > > >
    > > > >>You need to set NTFS permissions for IUSR (which weren't in place,
    > > > >>obviously, when using FAT32).
    > > > >>
    > > > >>Right-click the folder, hit sharing and security, and on the
    security
    > > tab,
    > > > >>make sure IUSR_MachineName is there and has read/write/modify.
    > > > >>
    > > > >>And stop using ODBC! [url]http://www.aspfaq.com/2126[/url]
    > > > >>
    > > > >>--
    > > > >>[url]http://www.aspfaq.com/[/url]
    > > > >>(Reverse address to reply.)
    > > > >>
    > > > >>
    > > > >>
    > > > >>
    > > > >>"only_me" <nospam.chris.bartleyntlworld.com> wrote in message
    > > > >>news:oAbSc.537$Qs4.377newsfe5-gui.ntli.net...
    > > > >>
    > > > >>>Just converted one of my volumes to NTFS ( XP Pro),
    > > > >>>asp sites on that volume now give " Operation must use an
    updateable
    > > > >>
    > > > >>query".
    > > > >>
    > > > >>>asp sites on another drive which is still FAT32 still working OK
    > > > >>>So just a permissions thing between IIS and NTFS - but where ?
    > > > >>>TIA
    > > > >>>
    > > > >>>
    > > > >>
    > > > >>
    > > > >
    > > > >
    > > >
    > >
    > >
    >
    >

    Aaron [SQL Server MVP] Guest

Similar Threads

  1. operation must use updateable query
    By Tomas in forum ASP Database
    Replies: 3
    Last Post: June 4th, 05:08 AM
  2. Operation must use an updateable query.
    By Frustrated in forum ASP Database
    Replies: 16
    Last Post: April 13th, 06:25 PM
  3. Operation must use an updateable query Error
    By Ray P. in forum ASP Database
    Replies: 2
    Last Post: November 30th, 05:14 AM
  4. Replies: 5
    Last Post: August 11th, 07:44 PM
  5. Replies: 2
    Last Post: July 29th, 07:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139