Professional Web Applications Themes

paper size - Debian

trying to print things via enscript and mpage. they're both defaulting to a4 paper, and i can't figure out how to specify letter paper. with enscript, -M letter looks like it should work: -M name, --media=name Select an output media name. Enscript's default output media is determined from libpaper and falls back to A4. .... but does not. the -b Letter option from mpage looks similarly promising: -bpapertype Prepare output for selected paper type. Papersize can be A3 for European A3, A4 for European A4, Letter for US Letter or Legal for Legal sized paper. For default see 'mpage -x'. ...

  1. #1

    Default paper size

    trying to print things via enscript and mpage. they're both
    defaulting to a4 paper, and i can't figure out how to specify letter
    paper.

    with enscript, -M letter looks like it should work:

    -M name, --media=name
    Select an output media name. Enscript's default output
    media is determined from libpaper and falls back to A4.

    .... but does not.

    the -b Letter option from mpage looks similarly promising:

    -bpapertype
    Prepare output for selected paper type. Papersize can be A3
    for European A3, A4 for European A4, Letter for US Letter
    or Legal for Legal sized paper. For default see 'mpage -x'.
    To see the list of currently available types, just give
    the 'mpage -bl' or 'mpage -b?' command (Note: mpage exits
    after finding such option use.)

    ... but also poos.

    is there some environment variable i need set? this works fine on
    other debian systems i use (that i did not, unfortunately, install
    myself) without `env` showing anything about paper sizes ...

    tia,

    </nori>

    --
    .~. nori sccs.swarthmore.edu
    /V\ [url]http://www.sccs.swarthmore.edu/~nori/jnl/[/url]
    // \\ maenad.net
    /( )\ [url]www.maenad.net[/url]
    ^`~'^
    get my (*new*) key here:
    [url]http://www.maenad.net/geek/gpg/7ede5499.asc[/url]
    (please *remove* old key 11e031f1!)


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    nori heikkinen Guest

  2. #2

    Default Re: paper size

    On Wed, Jul 23, 2003 at 11:47:08AM -0400, nori heikkinen wrote:
    > is there some environment variable i need set? this works fine on
    > other debian systems i use (that i did not, unfortunately, install
    > myself) without `env` showing anything about paper sizes ...
    I'm not sure, but /etc/papersize may have something to do with this.

    Bijan


    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v1.2.2 (GNU/Linux)

    iD8DBQE/Hq9nUof+95vTyAwRAp1+AJ92uRZBVOc8e6Q5O3QPwIMxnAwJtQ CeIgk8
    ccxynhmPj2h5QdHlgoNS/FI=
    =LX4b
    -----END PGP SIGNATURE-----

    Bijan Soleymani Guest

  3. #3

    Default Re: paper size

    Check /etc/papersize.


    Ernest Johanson
    Systems Administrator
    Fuller Theological Seminary


    On Wed, 23 Jul 2003, nori heikkinen wrote:
    > Date: Wed, 23 Jul 2003 11:47:08 -0400
    > From: nori heikkinen <norisccs.swarthmore.edu>
    > To: debian-user <debian-userlists.debian.org>
    > Subject: paper size
    >
    > trying to print things via enscript and mpage. they're both
    > defaulting to a4 paper, and i can't figure out how to specify letter
    > paper.
    >
    > with enscript, -M letter looks like it should work:
    >
    > -M name, --media=name
    > Select an output media name. Enscript's default output
    > media is determined from libpaper and falls back to A4.
    >
    > ... but does not.
    >
    > the -b Letter option from mpage looks similarly promising:
    >
    > -bpapertype
    > Prepare output for selected paper type. Papersize can be A3
    > for European A3, A4 for European A4, Letter for US Letter
    > or Legal for Legal sized paper. For default see 'mpage -x'.
    > To see the list of currently available types, just give
    > the 'mpage -bl' or 'mpage -b?' command (Note: mpage exits
    > after finding such option use.)
    >
    > .. but also poos.
    >
    > is there some environment variable i need set? this works fine on
    > other debian systems i use (that i did not, unfortunately, install
    > myself) without `env` showing anything about paper sizes ...
    >
    > tia,
    >
    > </nori>
    >
    > --
    > .~. nori sccs.swarthmore.edu
    > /V\ [url]http://www.sccs.swarthmore.edu/~nori/jnl/[/url]
    > // \\ maenad.net
    > /( )\ [url]www.maenad.net[/url]
    > ^`~'^
    > get my (*new*) key here:
    > [url]http://www.maenad.net/geek/gpg/7ede5499.asc[/url]
    > (please *remove* old key 11e031f1!)
    >

    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Ernest Johanson Guest

  4. #4

    Default Re: paper size

    on Wed, 23 Jul 2003 04:56:36PM +0100, Antony Gelberg insinuated:
    > You could check the contents of /etc/papersize.
    letter
    > apropos paper, and then man papersize are two useful commands that
    > you might have tried. Not sure if that file is used by those
    > specific applications, but it's what I'd look at first. :)
    checked all of them, and they're all set to letter ... just exported
    the PAPERSIZE env variable to letter, and still no dice.

    am i missing something?

    thanks,

    </nori>

    --
    .~. nori sccs.swarthmore.edu
    /V\ [url]http://www.sccs.swarthmore.edu/~nori/jnl/[/url]
    // \\ maenad.net
    /( )\ [url]www.maenad.net[/url]
    ^`~'^
    get my (*new*) key here:
    [url]http://www.maenad.net/geek/gpg/7ede5499.asc[/url]
    (please *remove* old key 11e031f1!)


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    nori heikkinen Guest

  5. #5

    Default Re: paper size


    Once upon a time nori heikkinen was quoted as saying:
    > trying to print things via enscript and mpage. they're both
    > defaulting to a4 paper, and i can't figure out how to specify letter
    > paper.
    If I'm correct the file you need is /etc/papersize

    try installing the package libpaper1

    Hope that helps

    Mark

    --
    To steal ideas from one person is plagiarism,
    to steal ideas from many is research.



    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Mark C Guest

  6. #6

    Default Re: paper size

    On Wed, 2003-07-23 at 19:00, nori heikkinen wrote:
    > checked all of them, and they're all set to letter ... just exported
    > the PAPERSIZE env variable to letter, and still no dice.
    >
    > am i missing something?
    letter ;)

    Seriously, I had a very similar problem, I had set everything up to use
    A4 (UK), and then setup cups, in every gnome print option, the A4 option
    vanished and left me with letter.
    In the end I tracked it down to the drivers I was using with cups (gimp
    print), I used the New Cups HP drivers and A4 magically popped backup.

    I know its not the same, but It may be worth checking the drivers the
    printer is using
    (but at the same time I may be wrong, as printing is one of my very,very
    weak points).

    Mark



    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Mark C Guest

  7. #7

    Default Re: paper size

    on Wed, 23 Jul 2003 11:46:53PM +0100, Mark C insinuated:
    > On Wed, 2003-07-23 at 19:00, nori heikkinen wrote:
    >
    > > checked all of them, and they're all set to letter ... just exported
    > > the PAPERSIZE env variable to letter, and still no dice.
    > >
    > > am i missing something?
    >
    > letter ;)
    >
    > Seriously, I had a very similar problem, I had set everything up to use
    > A4 (UK), and then setup cups, in every gnome print option, the A4 option
    > vanished and left me with letter.
    > In the end I tracked it down to the drivers I was using with cups (gimp
    > print), I used the New Cups HP drivers and A4 magically popped backup.
    >
    > I know its not the same, but It may be worth checking the drivers the
    > printer is using
    > (but at the same time I may be wrong, as printing is one of my very,very
    > weak points).
    yeah, but that's not even the issue -- i don't get as far as even
    printing it out. in fact, until yesterday, i didn't have networked
    printing configured correctly, so i was printing to ps, sending the
    files to a friend, and having him print them for me -- and it was in
    the ps files themselves that i was noticing the paper size. a
    particular doent, if printed on a4, is 16 pages, and if on letter,
    it's 19 pages. i only have to look at the command-line output of the
    enscript command to see what the paper size was.

    recap of what i know:

    i have had libpaper1. my /etc/papersize is set to letter, as is my
    $PAPERSIZE environment variable. `paperconf` == letter.
    /usr/sbin/paperconfig just modifies /etc/papersize, which is already
    letter.

    what else is there left to do??

    thanks again,

    </nori>

    --
    .~. nori sccs.swarthmore.edu
    /V\ [url]http://www.sccs.swarthmore.edu/~nori/jnl/[/url]
    // \\ maenad.net
    /( )\ [url]www.maenad.net[/url]
    ^`~'^
    get my (*new*) key here:
    [url]http://www.maenad.net/geek/gpg/7ede5499.asc[/url]
    (please *remove* old key 11e031f1!)


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    nori heikkinen Guest

  8. #8

    Default Re: paper size

    On Fri, Jul 25, 2003 at 09:57:48AM -0400, nori heikkinen wrote:
    > i have had libpaper1. my /etc/papersize is set to letter, as is my
    > $PAPERSIZE environment variable. `paperconf` == letter.
    > /usr/sbin/paperconfig just modifies /etc/papersize, which is already
    > letter.
    >
    > what else is there left to do??
    Have you looked in /etc/enscript.cfg ??

    --
    Paul


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Paul Worrall Guest

  9. #9

    Default Re: paper size

    on Fri, 25 Jul 2003 06:15:54PM +0100, Paul Worrall insinuated:
    > On Fri, Jul 25, 2003 at 09:57:48AM -0400, nori heikkinen wrote:
    > > i have had libpaper1. my /etc/papersize is set to letter, as is my
    > > $PAPERSIZE environment variable. `paperconf` == letter.
    > > /usr/sbin/paperconfig just modifies /etc/papersize, which is already
    > > letter.
    > >
    > > what else is there left to do??
    >
    > Have you looked in /etc/enscript.cfg ??
    that's it! thanks!! :)

    </nori>

    --
    .~. nori sccs.swarthmore.edu
    /V\ [url]http://www.sccs.swarthmore.edu/~nori/jnl/[/url]
    // \\ maenad.net
    /( )\ [url]www.maenad.net[/url]
    ^`~'^
    get my (*new*) key here:
    [url]http://www.maenad.net/geek/gpg/7ede5499.asc[/url]
    (please *remove* old key 11e031f1!)


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    nori heikkinen Guest

Similar Threads

  1. Get doent paper size - using AxAcroPDF?
    By Rob_Whittlesey@adobeforums.com in forum Adobe Acrobat SDK
    Replies: 2
    Last Post: March 17th, 02:07 PM
  2. Specifying Paper Size in WinXP ID CS
    By Rick_Carpenter@adobeforums.com in forum Adobe Indesign Windows
    Replies: 0
    Last Post: April 23rd, 03:06 PM
  3. mixed paper size
    By dan_claiborne@adobeforums.com in forum Adobe Acrobat Windows
    Replies: 6
    Last Post: April 9th, 02:00 PM
  4. Legal paper size..
    By Carl_Satterwhite@adobeforums.com in forum Adobe Photoshop Mac CS, CS2 & CS3
    Replies: 8
    Last Post: March 5th, 10:28 PM
  5. A4 paper size not available for printer
    By Jerome Acks Jr in forum Debian
    Replies: 0
    Last Post: June 30th, 04:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139