Professional Web Applications Themes

PERMANENTLY setting shmmax in Linux - Suse Personal Edition 8.2 - Linux Setup, Configuration & Administration

Ok, I have discovered the secret. You may have noticed my other post on this subject. But, it's so old that I can't post to it anymore. So the solution is here. ------------- Big picture. This method uses sysctl. It does not use echo commands. You only edit a few files, and reboot. Just like in Solaris. You need to configure -FOUR- things. NO less. /etc/init.d/boot.sysctl is a script. /etc/init.d/boot.d is a directory. /etc/sysctl.conf is a parameter file. and then you have to create a link. I used: /etc/init.d/boot.d/S20boot.sysctl ------------ Edit the file /etc/sysctl.conf, and insert the value for shmmax ...

  1. #1

    Default PERMANENTLY setting shmmax in Linux - Suse Personal Edition 8.2

    Ok, I have discovered the secret.

    You may have noticed my other post on this subject. But,
    it's so old that I can't post to it anymore. So the
    solution is here.

    -------------

    Big picture.

    This method uses sysctl. It does not use echo commands.
    You only edit a few files, and reboot. Just like in Solaris.


    You need to configure -FOUR- things. NO less.

    /etc/init.d/boot.sysctl is a script.

    /etc/init.d/boot.d is a directory.

    /etc/sysctl.conf is a parameter file.

    and then you have to create a link. I used:

    /etc/init.d/boot.d/S20boot.sysctl


    ------------
    Edit the file /etc/sysctl.conf, and insert the value
    for shmmax into it.

    cat /etc/sysctl.conf
    kernel.shmmax=2147483648


    before:
    cat /proc/sys/kernel/shmmax
    33554432

    start sysctl:
    /etc/init.d/boot.sysctl start

    Setting current sysctl status from /etc/sysctl.conf
    kernel.shmmax = 2147483648

    after:
    cat /proc/sys/kernel/shmmax
    2147483648

    ta da!

    Now, you get this to run at boot time. (He, he, he.
    We'll get that server to serve ME yet, instead of the
    other way around!!!!)

    ------------

    Create the link: /etc/init.d/boot.d/S20boot.sysctl

    cd /etc/init.d/boot.d

    total 8
    drwxr-xr-x 2 root root 4096 Oct 19 19:20 .
    drwxr-xr-x 11 root root 4096 Dec 17 21:39 ..
    lrwxrwxrwx 1 root root 12 Oct 19 19:20 S01boot.proc
    -> ../boot.proc
    ....
    lrwxrwxrwx 1 root root 16 Oct 19 19:20
    S10boot.ipconfig -> ../boot.ipconfig
    lrwxrwxrwx 1 root root 12 Oct 19 19:20 S10boot.klog
    -> ../boot.klog

    ln -s /etc/init.d/boot.sysctl S20boot.sysctl

    lrwxrwxrwx 1 root root 12 Oct 19 19:20 S10boot.klog
    -> ../boot.klog
    lrwxrwxrwx 1 root root 23 Dec 17 22:03 S20boot.sysctl
    -> /etc/init.d/boot.sysctl

    -------------

    - reboot. It works!!!!!!! What a concept.

    cat /proc/sys/kernel/shmmax
    2147483648


    ------------

    Later, I added more entries to /etc/sysctl.conf:

    kernel.shmmax=2147483648
    kernel.shmmni=4096
    kernel.shmall=2097152
    kernel.sem="250 32000 100 128"
    kernel.hostname=white
    fs.file-max=65536


    reboot.

    cat /proc/sys/kernel/shmmax
    2147483648

    cat /proc/sys/kernel/shmmni
    4096

    cat shmall
    2097152

    cat sem
    250 32000 100 128


    ---------

    So, it only took a month and a week to configure the
    memory at boot time. I think that what caused problems
    for me was that so much of the instructions that I found
    either assumed a knowledge that I didn't have yet, or missed
    one of the pieces or steps. Does not compute.


    So, for those of you struggling with such simple
    business, I hope this helps you. Please post your
    solutions when you figure them out.
    linuxquestion@yahoo.com Guest

  2. #2

    Default Re: PERMANENTLY setting shmmax in Linux - Suse Personal Edition 8.2

    |Create the link: /etc/init.d/boot.d/S20boot.sysctl
    |
    |cd /etc/init.d/boot.d
    |
    |total 8
    |drwxr-xr-x 2 root root 4096 Oct 19 19:20 .
    |drwxr-xr-x 11 root root 4096 Dec 17 21:39 ..
    |lrwxrwxrwx 1 root root 12 Oct 19 19:20 S01boot.proc
    |-> ../boot.proc
    |...
    |lrwxrwxrwx 1 root root 16 Oct 19 19:20
    |S10boot.ipconfig -> ../boot.ipconfig
    |lrwxrwxrwx 1 root root 12 Oct 19 19:20 S10boot.klog
    |-> ../boot.klog
    |
    |ln -s /etc/init.d/boot.sysctl S20boot.sysctl
    |
    |lrwxrwxrwx 1 root root 12 Oct 19 19:20 S10boot.klog
    |-> ../boot.klog
    |lrwxrwxrwx 1 root root 23 Dec 17 22:03 S20boot.sysctl
    |-> /etc/init.d/boot.sysctl

    Good for you, but don't do it this way on SUSE. The symlink will get
    wiped out from the boot.d directory the next time you run SuSEconfig
    which is basically anytime after a new package has been installed or YOU
    has updated packages. The reason is SUSE recomputes the dependencies
    between init scripts when reconfigured and assign the sequence number
    using this information, which is why you'll see they are squashed
    towards zero instead of being all over the place between 0 and 99.
    Instead, look at /etc/init.d/skel and make your init script have those
    metadata lines. Then use chkconfig or /sbin/insserv to install that
    script.
    --

    fxysta@yteujf.com Guest

  3. #3

    Default Re: PERMANENTLY setting shmmax in Linux - Suse Personal Edition 8.2

    com writes:
     

    Maybe I am missing something. But it looks that you are talking about
    Oracle on a SuSE GNU/Linux distribution and then the best solution
    would be to get the orarun.rpm package from the following side:

    http://www.suse.de/de/business/certifications/certified_software/oracle/index.html

    The orarun.rpm package performs the setting of the kernel parameter
    among other things that you described in your message.

    Harald
    Harald Guest

  4. #4

    Default Re: PERMANENTLY setting shmmax in Linux - Suse Personal Edition 8.2

    com wrote: 

    Have you had a look at powertweak that comes with Suse, there is a setting in
    there to adjust the shmmax for oracle, this will adjust it on boot
    automagically.

    --
    Mark
    Twixt hill and high water.
    N.Wales, UK.
    Email is spam trap try baskitcaise at gmx dot co dot uk
    baskitcaise Guest

  5. #5

    Default Re: PERMANENTLY setting shmmax in Linux - Suse Personal Edition 8.2

    HI,

    Thanks for your responses.

    Yes, I was trying to configure Suse for Oracle. And yes, I did
    try the orarun package. It didn't work either. It assumed that you
    had already installed oracle and had a number of instances ready
    to start up at boot time. Duh. Unfortunately, dbca did not work
    because shmmax was not configured. Thus the question. I could
    have just hacked it, but ...

    Call me old fashioned. But I like to keep the OS, and the apps
    separate. Config the OS first. Prepare the machine for Oracle,
    memory, environment variables, file systems, etc. Then install.

    And I do expect the fundamentals to work at the OS level. You
    shouldn't have to install oracle in order to get the memory
    configured. That's like Mr. Gates fudging the OS to get MS Office
    products working.

    My lamentations. Thanks again.

    My first post via linux!

    --------------------

    com wrote in message news:<google.com>... 
    linuxquestion@yahoo.com Guest

  6. #6

    Default Re: PERMANENTLY setting shmmax in Linux - Suse Personal Edition 8.2

    com wrote:

    But did you try the options for shmmax in powertweak ( in yast ), that is what
    it is there for, there is a setting for oracle.

    --
    Mark
    Twixt hill and high water.
    N.Wales, UK.
    Email is spam trap try baskitcaise at gmx dot co dot uk
    baskitcaise Guest

Similar Threads

  1. Is there a FMS2 Personal Edition?
    By sparky1962 in forum Macromedia Flash Flashcom
    Replies: 4
    Last Post: September 25th, 09:01 PM
  2. For Sale: FCS MX Personal Edition
    By kauldron in forum Macromedia Flash Flashcom
    Replies: 3
    Last Post: July 31st, 12:32 AM
  3. How to PERMANENTLY set semaphores in Linux - Suse Personal Edition 8.2?
    By linuxquestion@yahoo.com in forum Linux Setup, Configuration & Administration
    Replies: 18
    Last Post: November 21st, 10:28 PM
  4. How to PERMANENTLY set semaphores in Linux - Suse Personal Edition 8.2?
    By linuxquestion@yahoo.com in forum Oracle Server
    Replies: 20
    Last Post: November 21st, 10:28 PM
  5. Installing Suse 8.2 Profesional hangs after this line >>> SuSe Linux Installation ....<<<
    By Nenad Ukropina in forum Linux Setup, Configuration & Administration
    Replies: 0
    Last Post: September 15th, 07:11 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139