Professional Web Applications Themes

Personal Web Sharing Question - Mac Applications & Software

In article <newsguy.com>, LadyMovieFan <zzz> wrote:   Right. Web sharing in Mac OS X is Apache, which comes from Unix, and which does not recognize Mac aliases.   You'd need to create a symbolic link, using Mac OS X's command line. The syntax would be as follows: ln -s /Library/WebServer/Doents [real location here] So if you had the files at /Volumes/FireWireDisk/website, you'd do this: ln -s /Library/WebServer/Doents /Volumes/FireWireDisk/website -- Tom "Tom" Harrington Macaroni, Automated System Maintenance for Mac OS X. Version 1.4: Best cleanup yet, gets files other tools miss. See http://www.atomicbird.com/...

  1. #1

    Default Re: Personal Web Sharing Question

    In article <newsguy.com>,
    LadyMovieFan <zzz> wrote:
     

    Right. Web sharing in Mac OS X is Apache, which comes from Unix, and
    which does not recognize Mac aliases.
     

    You'd need to create a symbolic link, using Mac OS X's command line.
    The syntax would be as follows:

    ln -s /Library/WebServer/Doents [real location here]

    So if you had the files at /Volumes/FireWireDisk/website, you'd do this:

    ln -s /Library/WebServer/Doents /Volumes/FireWireDisk/website

    --
    Tom "Tom" Harrington
    Macaroni, Automated System Maintenance for Mac OS X.
    Version 1.4: Best cleanup yet, gets files other tools miss.
    See http://www.atomicbird.com/
    Tom Guest

  2. #2

    Default Re: Personal Web Sharing Question

    Tom Harrington <no.spam.dammit.net> wrote in comp.sys.mac.system: 
    >
    > Right. Web sharing in Mac OS X is Apache, which comes from Unix, and
    > which does not recognize Mac aliases.

    >
    > You'd need to create a symbolic link, using Mac OS X's command line.
    > The syntax would be as follows:
    >
    > ln -s /Library/WebServer/Doents [real location here]
    >
    > So if you had the files at /Volumes/FireWireDisk/website, you'd do this:
    >
    > ln -s /Library/WebServer/Doents /Volumes/FireWireDisk/website[/ref]

    It works the other way 'round. As with the cp-command, the existing
    file comes first, the new file second:

    ln -s /Volumes/FireWireDisk/website /Library/WebServer/Doents

    Anno
    Anno Guest

  3. #3

    Default Re: Personal Web Sharing Question

    In article <bi4o7e$q3$zrz.TU-Berlin.DE>,
    zrz.tu-berlin.de (Anno Siegel) wrote:
     
    > >
    > > Right. Web sharing in Mac OS X is Apache, which comes from Unix, and
    > > which does not recognize Mac aliases.
    > > 
    > >
    > > You'd need to create a symbolic link, using Mac OS X's command line.
    > > The syntax would be as follows:
    > >
    > > ln -s /Library/WebServer/Doents [real location here]
    > >
    > > So if you had the files at /Volumes/FireWireDisk/website, you'd do this:
    > >
    > > ln -s /Library/WebServer/Doents /Volumes/FireWireDisk/website[/ref]
    >
    > It works the other way 'round. As with the cp-command, the existing
    > file comes first, the new file second:
    >
    > ln -s /Volumes/FireWireDisk/website /Library/WebServer/Doents[/ref]

    D'oh. I was creating the alias in the wrong direction.

    --
    Tom "Tom" Harrington
    Macaroni, Automated System Maintenance for Mac OS X.
    Version 1.4: Best cleanup yet, gets files other tools miss.
    See http://www.atomicbird.com/
    Tom Guest

  4. #4

    Default Re: Personal Web Sharing Question

    At this point, I can *see* folder "Files" on my sites page, but when I click it
    says "You don't have permission to access on this server".

    Checked permssions on "Files" alias using "Command I" and it says owner is
    "myname (Me)" who has "read & write" access. Group shows "staff (Me)" and says
    "read only".

    Other files in Sites folders all have those same permission settings (when
    looking via "Command I") and people are able to get to them, but not to the
    newly created folder link to external drive.

    Checked permissions via Terminal and settings for other folders in Sites folder
    show as: drwxr-xr-x

    Checked permissions via Terminal and settings for external folder show as:
    lrwxr-xr-x

    I'm novice at UNIX and have only dabbled in it a tad bit and not exactly sure
    why folder isn't accessible...but guess it might have to do with the "l" in
    first position?

    Do I need to change "l" to "d" for directory so others can access it? Been
    looking around online at various UNIX resources and do not see anything for
    first character but "-" or "d" - haven't seen any info as to what "l" in first
    position means.

    Nor do I see any info as to how to change first character...or if it's even
    possible.
    LadyMovieFan Guest

Similar Threads

  1. Personal question:Where are you from, and what are youdoing now
    By xiva in forum Macromedia Flex General Discussion
    Replies: 2
    Last Post: November 13th, 09:09 AM
  2. SanFrancisco question ( really stupid, personal topic )
    By jann_lipka@adobeforums.com in forum Adobe Photoshop Mac CS, CS2 & CS3
    Replies: 52
    Last Post: February 25th, 06:05 AM
  3. Personal File Sharing keeps going off
    By Karel Koskuba in forum Mac Applications & Software
    Replies: 0
    Last Post: June 27th, 04:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139