Professional Web Applications Themes

PHP failed to p my script - PHP Development

I received a scary peice of news from one of the user from my site. he saying that he was able to save the source code when trying to view my site (it was not pd at all, he sent me the raw php script of my site) is this an apache hickup or i got some bug in my script? my first thought is apache failed to register the MIME type for that instant, and the make the php file acts like a text file what kinna things i can do to prevent this? so far all i done ...

  1. #1

    Default PHP failed to p my script

    I received a scary peice of news from one of the user from my site. he
    saying that he was able to save the source code when trying to view my site
    (it was not pd at all, he sent me the raw php script of my site)

    is this an apache hickup or i got some bug in my script?

    my first thought is apache failed to register the MIME type for that
    instant, and the make the php file acts like a text file

    what kinna things i can do to prevent this?

    so far all i done is move all my password files (db and other things) above
    the webroot path


    thanks, any input is greatly appreciated!



    Du Guest

  2. #2

    Default Re: PHP failed to p my script

    Du wrote: 
    Hey... my first guess would be that your script's extension is not
    registered? (ie if you have php code inside and .html file and apache
    isn't configured to p .html files.. then your php will come through
    none pd. Does this happen every time? are you able to recreate the
    problem? or has it only happened once as far as you know and worked the
    rest of the time?
    Paul Guest

  3. #3

    Default Re: PHP failed to p my script

    > Hey... my first guess would be that your script's extension is not 


    this never happened to me or any other member of my site, it just strange

    may be my host is doing upgrade on php while that happened


    "Paul" <net> wrote in message
    news:z6ele.1484132$.. 
    > Hey... my first guess would be that your script's extension is not
    > registered? (ie if you have php code inside and .html file and apache
    > isn't configured to p .html files.. then your php will come through
    > none pd. Does this happen every time? are you able to recreate the
    > problem? or has it only happened once as far as you know and worked the
    > rest of the time?[/ref]


    Du Guest

Similar Threads

  1. #40762 [NEW]: xml_pr failed to p mixed coding file
    By forward at hongyu dot org in forum PHP Bugs
    Replies: 2
    Last Post: March 9th, 08:05 AM
  2. Script to p files
    By Lonewolf in forum PERL Beginners
    Replies: 2
    Last Post: February 6th, 08:22 PM
  3. Make this into a script to p?
    By Lone Wolf in forum PERL Beginners
    Replies: 8
    Last Post: February 5th, 10:49 PM
  4. How to p large script faster
    By Wimpie in forum PERL Beginners
    Replies: 0
    Last Post: December 1st, 02:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139