Hello,

Installing PHP 4.3.6 on a i386 platform w/ FreeBSD 4.9 O/S installed and
running apache_1.3.31

make
with ./configure --with-mysql --with-apxs=/usr/local/apache/bin/apxs
--enable-versioning ===>
.........
Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS...

Sorry, I was not able to successfully run APXS. Possible reasons:

1. Perl is not installed;
2. Apache was not compiled with DSO support (--enable-module=so);
3. 'apxs' is not in your path. Try to use --with-apxs=/path/to/apxs
The output of /usr/local/apache/bin/apxs follows
apxs:Error: sbindir/httpd not found or not executable
configure: error: Aborting
.........

Perl is installed
perl -v
This is perl, v5.8.2

httpd -l
Compiled-in modules:
http_core.c
........
........
mod_so.c
mod_setenvif.c
mod_ssl.cmodule

apxs is installed version ( not from source tarball)
ls -l /usr/local/apache/bin/apxs
-rwxr-xr-x 1 root wheel 24624 Jun 21 01:23 /usr/local/apache/bin/apxs*

and is executible

could not interpret the error message : sbindir/httpd not found or not
executable
Hope someone can provide some guidance

Thanks

-- Adam --