Professional Web Applications Themes

phpMyAdmin & mbstring - MySQL

Hi, newb need some help here! phpMyAdmin gives following error message: "The mbstring PHP extension was not found and you seem to be using a multibyte cht. Without the mbstring extension phpMyAdmin is unable to split strings correctly and it may result in unexpected results." So, how I do enable that feature? I try like this: I copy php_mbstring.dll:n to C:\PHP-folder and edit C:\Windows\php.ini -file: 'extension=php_php_mbstring.dll', but it did not remove that phpMyAdminin's error message. I'am using WinXP pro SP2 with: apache 2.0.55 win32-x86 no_ssl php 4.4.1 mysql essentia 4.1.16 win32 phpMyAdmin 2.7.0 pl2 PHP4 is installed with installer and ...

  1. #1

    Default phpMyAdmin & mbstring

    Hi, newb need some help here!

    phpMyAdmin gives following error message: "The mbstring PHP extension was not found and you seem to be using a multibyte cht. Without the mbstring extension phpMyAdmin is unable to split strings correctly and it may result in unexpected results."

    So, how I do enable that feature?

    I try like this: I copy php_mbstring.dll:n to C:\PHP-folder and edit C:\Windows\php.ini -file: 'extension=php_php_mbstring.dll', but it did not remove that phpMyAdminin's error message.

    I'am using WinXP pro SP2 with:
    apache 2.0.55 win32-x86 no_ssl
    php 4.4.1
    mysql essentia 4.1.16 win32
    phpMyAdmin 2.7.0 pl2

    PHP4 is installed with installer and php4apache2.dll is copied to C:\PHP- folder from php-4.4.1-Win32.zip- packed, and Apache's httpd.conf -file is edit required changes what is needed by php4.

    sorry for my BAD english! =(



    ShK Guest

  2. #2

    Default Re: phpMyAdmin & mbstring

    > phpMyAdmin gives following error message: "The mbstring PHP extension
    > was not found and you seem to be using a multibyte cht. Without
    > the mbstring extension phpMyAdmin is unable to split strings correctly
    > and it may result in unexpected results."
    >
    > So, how I do enable that feature?
    >
    > I try like this: I copy php_mbstring.dll to C:\PHP-folder and edit
    > C:\Windows\php.ini -file: 'extension=php_php_mbstring.dll', but it
    > did not remove that phpMyAdminin's error message.
    I think you have a "php_" too much. If removing that still does not
    work, check if the extension_dir is set to the directory containing the
    file php_mbstring.dll

    Best regards
    Dikkie Dik Guest

  3. #3

    Default Re: phpMyAdmin & mbstring

    Just uncomment (remove the semicolon at the beginning) this line in
    php.ini file:

    extension=php_mbstring.dll

    That should do the trick. Multibyte string extension is not enabled by
    default and if you want to manipulate strings in multibyte character
    sets (like UTF-8) you need to use the mb_* functions - and they're only
    available if mbstring extension is enabled.

    By the way this should go to a PHP group, as it's not really MySQL
    related ;-)

    Michal

    Michal Stankoviansky Guest

  4. #4

    Default Re: phpMyAdmin & mbstring

    "Dikkie Dik" <nospamnospam.org> wrote in message news:dqfvh0$2ls$1news.cistron.nl...

    :> phpMyAdmin gives following error message: "The mbstring PHP extension
    : > was not found and you seem to be using a multibyte cht. Without
    : > the mbstring extension phpMyAdmin is unable to split strings correctly
    : > and it may result in unexpected results."
    : > So, how I do enable that feature?
    : > I try like this: I copy php_mbstring.dll to C:\PHP-folder and edit
    : > C:\Windows\php.ini -file: 'extension=php_php_mbstring.dll', but it
    : > did not remove that phpMyAdminin's error message.
    : I think you have a "php_" too much. If removing that still does not
    : work, check if the extension_dir is set to the directory containing the
    : file php_mbstring.dll

    It really was 'extension=php_mbstring.dll'. I change 'extension_dir = "./"' to
    'extension_dir = "C:\PHP"' (becouse I copied php_mbstring.dll to there) and
    reboot computer but it doesnt help... =(

    ShK Guest

  5. #5

    Default Re: phpMyAdmin & mbstring

    "Michal Stankoviansky" <michal.stankoviansky> wrote in message

    : Just uncomment (remove the semicolon at the beginning) this line in
    : php.ini file:
    :
    : extension=php_mbstring.dll
    :
    : That should do the trick. Multibyte string extension is not enabled by

    That was what I exactly did.

    : By the way this should go to a PHP group, as it's not really MySQL
    : related ;-)

    Ok, continue to there...
    ShK Guest

  6. #6

    Default Re: phpMyAdmin & mbstring

    > It really was 'extension=php_mbstring.dll'. I change 'extension_dir = "./"' to
    > 'extension_dir = "C:\PHP"' (becouse I copied php_mbstring.dll to there) and
    > reboot computer but it doesnt help... =(
    >
    Could you try adding a trailing slash? Like:
    extension_dir="C:\PHP\"
    Best regards
    Dikkie Dik Guest

  7. #7

    Default Re: phpMyAdmin & mbstring

    "Dikkie Dik" <nospamnospam.org> wrote in message news:dqm0mm$g0o$1news.cistron.nl...
    > Could you try adding a trailing slash? Like:
    > extension_dir="C:\PHP\"
    > Best regards
    It didnt help. Thanks anyway for all the suggestions...
    ShK Guest

Similar Threads

  1. PhpMyadmin Help
    By hope@hope.com in forum PHP Development
    Replies: 6
    Last Post: March 23rd, 05:03 AM
  2. Help with phpMyAdmin
    By Gamespy007 in forum Macromedia Dynamic HTML
    Replies: 2
    Last Post: March 16th, 02:27 PM
  3. php mbstring
    By Junaid in forum FreeBSD
    Replies: 0
    Last Post: February 16th, 10:41 AM
  4. [PHP-DEV] changes in ext/mbstring (PHP_4_3)
    By Rui Hirokawa in forum PHP Development
    Replies: 3
    Last Post: September 22nd, 03:54 AM
  5. phpmyadmin - help please!
    By David Robley in forum PHP Development
    Replies: 0
    Last Post: July 7th, 10:54 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139